Q&A Discussion of IFS Solutions for our IFS Employees, Partners and Customers
Recently active
Currently we have Azure AD set up as the identity provider. Are we able to configure a second identity provider to work simultaneously for Apps 10?Product Version: UPD16
Hi all,After the latest Windows May update, some users are no longer able to log into IFS Apps 9. They are receiving an error stating that the login service is unavailable. After some investigation, we found that this is caused by Microsoft's hardening of Kerberos Authentication. We are currently in the process of migrating to IFS Cloud, but we still need to use Apps 9 until January 2027.We managed to temporarily resolve the issue by adding a registry key, but this workaround will only work until the June update. After that, we either have to find a permanent fix or stop installing updates.Has anyone else encountered this issue, and if so, how did you fix it? The only long-term solution we can think of is creating a new account and a new keytab file, and then reconfiguring IFS Apps 9 to use them. If anyone has an easier workaround, we would love to hear it!
Does anyone know if it's possible to link the IFS database to Microsoft Fabric?https://learn.microsoft.com/en-us/fabric/database/mirrored-database/open-mirroringWe're currently using the self hosted bi, but I can't say that's a perfect solution so we're looking for better alternatives.
Cloud 24R1 : We would like to export/ import multiple user profiles in one action. When I select two user profiles I do not have the option to export both profiles into one export file?!Anyone in the community knows how I can export/ import multiple USER profiles in one go?
A new version of Perfidia v4.50.221 has been released. The actual version can be downloaded here:https://www.perfidia.de/downloads/psa/psasetup.exePerfidia Forum can also be accessed with GuestAccess (Gastzugang)https://www.perfidia.de/Perfidia?action=forum
Scheduling Demystified has been updated to 24R2. As usual, headlines are tagged with “24R2🌟” for new capabilities, “24R2 ↗” for improved features, and “🖊” for new chapters on existing functionality. Newcomers will find many new conceptual explanations and How-To’s.If you find this document helpful, please consider leaving a 👍 LIKE. And ⭐ SUBSCRIBE to get updates.232 pages cover:Preamble: Direct Assignment vs. Dispatch Console vs. PSO Work Order Management vs. Request Management Modelling Dataset vs. Scheduling Dataset Scheduling Dataset Parallel Background Processing Modelling Dataset and Basic Data Scheduling Optimization Dataset Scheduling Exceptions Communication between MWO, Dispatch Console and PSO Shift Templates The Supply Side of Scheduling: Resources Skill Management The Demand Side of Scheduling: Tasks Availability Patterns Appointment Booking Dispatch Console Direct Assignment Resource Management Integration APIs Appointment Booking Integration API Troubleshooting Don’t f
We have a Boomi integration that runs Shop Orders from MES to IFS that we are migrating from IFS APP10 to Cloud. The issue that we are having is from creating and completing the Manual Inventory Receive. Our Boomi integration worked correctly in APP10 but now shows that it is successful in Boomi while IFS does not receive any Inventory. Our IFS Connector in Boomi for creating the uses ReceiveShopOrderHandling as the projection and Reference_InventoryReceipt as the object. It seems that the Reference_InventoryReceipt object is outdated and I have been attempting to replace it with ReceiveShopOrderSet->InventoryReceiptArray as that is what I see being used in logs when going through the Manual Inventory Receive process in IFS Cloud. When trying to run the new Connector in Boomi, we get an error saying "Failed processing original documents i2i in the IFS Cloud Connection connector: java.lang.Exception: All the keys should be given as input parameters". The Objkey is being set using Bou
In IFS Cloud 24R2, when starting from a service quotation, the preposting can be added after quotation acceptance in the "Prepare Work Order" step.However, when using work task templates added in the service quotation, the tasks already exist in the flow, and the preposting from the work order header is not inherited by these tasks. As a result, preposting must be manually added to each individual task.Is there a way to resolve this issue or apply a workaround?
Hi,do you have any idea, how to implement OAuth2 Authorization Code Flow integration in IFS Aurena? We need to create integration with bank, where is only Authorization Code Flow possible (logging to account, approval in mobile app, configuration, granting priviledges, ...).At this point, I have no idea, how to prepare callbackUrl for accepting GET request with strictly defined URL parameters.Is there any manual how to prepare own SVC not depending on OData protocol?Or use something like /soapgateway to receive and store incomming GET request? Authorization Code Flow
Hello, I am hoping to find information about the add-on to Cloud for the Freight Interface and Credit Card Integration. We are currently on Apps 10 and have these extensions, but are in the first phase of Build and Verify to upgrade to Cloud (24R1) and have not yet applied them to our Cloud environments. Our partner needs additional details to support the upgrade and IFS Support has directed me to the community for answers. 1. What are the artifacts here, change to the solution set, new entities, utilities, etc under a new module, a new k8s container? From our current 24R1 solution set we don’t see anything that suggests that credit cards or freight integration is something that exists. As part of the technical upgrade process, we need to make sure that the database artifacts exist, so this is critical to the process.2. What are the supported IFS release versions? We are doing B&V on 24R1. We do plan to do a release update as part of the plan, but we need to know what the min
When we have defined some conditions in an Event action they work fine in the environment in which they were defined. But when they are exported and imported again as an ACP, (as xml files or a Zip file) we’ve noticed that the conditions stops getting evaluated and the Actions are run regardless what is in the conditions.For example, say we have below event action with below condition, and it was created by importing it from an ACP. Then despite what is in the condition it will execute what is in the Action Details.However, if you open this event Action in the application and do a fake modification to the Condition and do a re-save the issue is gone and the Events are only executed if the conditions are satisfied.When investigating further we realized that this is due to a discrepancy in the NEWLINE character when Event Conditions are saved in the database. When importing the ACPs through an xml it saves the newline characters in the Condition_type and Condition_Value fields as ‘\r\n’
Have you come across this error?Sorry, there was an unexpected server error Have you come across above generic error? If so how have your resolved it or is it still occurring intermittently? Let us know in the comments 😊 Note: This is a generic error message to which the cause could be in different product areas for which you need to analyze with further details. But here we want to understand how many of you faced it, resolved it or still undergoing with this error popup message. Related error messages: Database error occurred. Contact administrator. Url: Related KB Articles:
Hi,when we use Rest call API in worlflow if there are some error we get just the error code, we dont get the message error, but the same call if we use it in Postman we get all details : code error, message error and details, if it’s possible to get the same thing in workflow ?Regards.
Hi, I know the ReqID and I want to know to which RecurringServiceProgram this ReqID belongs. The API-Call: main/ifsapplications/projection/v1/RequestHandling.svc/SrvRequestSet(ReqId='62723')returns "Source": "RecurringService", Which API do I have to use to find the Recurring ServiceProgramm, which has created this request? Best regards Michael PS: We use 26R1.3
Hello everyone, When i go to the page configuration page, almost all pages are missing. I have refreshed the following cache , but nothing happened. Any idea how to recover all pages please? Kind Regards
Hello everybody,I scanned a PDF delivery notice using AI, and then created an “Incoming Dispatch Advice”.However, I have an issue with the delivery address.Why doesn't it retrieve the correct delivery address?
Hi everyone,In IFS, customer receivables are currently linked to the ordering customer. We need them to be linked to the payer instead.Has anyone configured this before? Is there a standard setup, or does it require a customization?Thanks in advance for your feedback.
Hi What settings need to be configured in order to be able to forward a report from the report archive?Kerstin
We have requirement from the customer using PSO to allow the Start of the week to be changed to Sunday, in the Calendar opened in the resource gantt.This will be good for customers that wants custom start of the week and not default to Monday.
Is there a way to fetch vat code from PO when matching with supplier invoice, instead of from the supplier?An example, when purchase order direct/triangulation is used, the supplier of goods (supplier vat code E1) is used both in triangulation (vat code E5) and normal POs (E1). As of now I can’t find a way to see if the invoice is part of a triangulation in External Supplier Invoices nor can I select that vat code should be fetched from PO (to match the vat code on customer order, customer invoice and purchase order) instead from the supplier when matching. How or why not?
Hello,where can i found CRM panel for IFS24R1?Thanks
In IFS Apps 10, existing saved searches are visible and work correctly before any customization is applied.However, after a customization is delivered, the previously created saved searches are no longer visible from the relevant form. They still appear under Saved Searches, but the user cannot see or access them from the form. New saved searches are created under the customized form.Saved SearchesPersonal ProfileHas anyone experienced this issue? Could it be related to the customization or changes to the form metadata?Is there a recommended solution or workaround to make the existing saved searches available again without recreating them?Best Regards,Nisansala
Hi all,Users are required to send E-Invoices including invoices images based on their custom layouts but when processing an e-invoice it always picks the default/standard print layout and generates the xml.There are layouts made based on different country requirements and need to set it up against each company print and currently when trying to send e-invoice there is no option to select it. Is there a way to achieve this or any alternative solutions?Appreciate your answers and suggestions.Thank you.
Hello Everyone,Currently with My client, users on boarding/off boarding process are done by multi-step process:1. User Management I IFS – Data Upload using multiple excel FND Users details, user group, access groups etc, Activate/Deactivate.2. Mobile Application Access in Company Portal using Azure AD to allow them register in Azure AD groups to download application via company portalSSO Login using Azure AD to allow authentication in IFS.Can you please help with if the IFS capability to simplify user onboarding / off boarding users via Integration from Azure/IAM to create users /delete or deactivate users in IFS.Request you to please support with available documentation that helps implement the capability.Regards,KamaleshProduct Version: 25.2.0Business Impact: Needed to simplify users onboarding and off boarding in IFS via Integration.
I am trying to allow a Application Status Tracking Dashboard that is used internally to be able to get to FSM Health Checki was looking at using /OData/perform_health_checkbut when reviewing how to setup the associated user and role. i was not able to restrict the role to appoint where it only has access to perform the heath check. in Functions i added Odata (readonly mode) and recevied authorization error (even though i am calling a status endpoint)so i tried without the readonly and added table restrictions to the Role. That stopped me from getting at the table data but i was still able to perform MPM’s in FSM so updating data. does anyone know how you might be able to Restrict a Role for Odata that allows access to the health check without giving it access to update/create/delete anything else?
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.