Q&A Discussion of IFS Solutions for our IFS Employees, Partners and Customers
Recently active
Hi,We use the ISO20022 payment format for bank transfer. Starting in November, banks will require detailed address information in transfer files. We’ve set the Detailed Address information on Format Specific Information per Institute page and Supplier - Payment - Electronic Payment Address page.The result is almost good, but the street name and building number are in one tag, and the tag name is not correct: This is the correct format for structured xml:or there is a hybrid structured:How do I configure the system to access a particular structure?
Hello everybody,I got an error message on screen “Machine Learning Logs”. Log Text:PlsqlapServer.ERRINV: ExecutionException from Sender thread Caused by: ifs.fnd.connect.senders.ConnectSender$TemporaryFailureException: Exception while sending data Caused by: ifs.fnd.base.SystemException: Bad request error: 400 (Exception with inference request: AggregateException_ctor_DefaultMessage (Request to http://llm-executor-service.mlsvc.svc.cluster.local:8080/v1/models/llm_executor:predict failed with status code InternalServerError: {"error":"LLMExecutorException : CHAT COMPLETION FAORA-06512: in "IFSAPP.ERROR_SYS", Zeile 150ORA-06512: in "IFSAPP.ERROR_SYS", Zeile 368ORA-06512: in "IFSAPP.PLSQLAP_SERVER_API", Zeile 2092ORA-06512: in "IFSAPP.PLSQLAP_SERVER_API", Zeile 2370ORA-06512: in "IFSAPP.PLSQLAP_SERVER_API", Zeile 503ORA-06512: in "IFSAPP.PLSQL_REST_SENDER_API", Zeile 2101ORA-06512: in "IFSAPP.PLSQL_REST_SENDER_API", Zeile 1536ORA-06512: in "IFSAPP.ML_SERVICE_UTIL_API", Zeile 1034 It seem
Hi,With the Maintenance Planner Resource Management lobby, where does Date Range come from? Can this be configured to just look at one day/one week/two weeks?1 day horizon.When I change the planning horizon as well, the graph does not change.30 day horizon.Thanks!
When cloning from the PRD environment to the CFG environment using "Clone Environment" in Environment Studio, data for certain custom events remained in the CFG environment instead of being deleted.Upon contacting support, I was informed that the following tables are excluded from the refresh process due to refresh rules: FND_EVENT_ACTION* FND_EVENT* Custom extension tables Configuration tablesI would like to know how to configure these refresh rules, but I haven't been able to get an answer; if anyone knows how to do this, please let me know.My goal is to refresh all tables so that the data in the target environment is exactly the same as in the source.I saw a similar issue mentioned in another post, but I am asking this question because I do not know the specific steps required to resolve it. IFSクラウドクローン|IFSコミュニティIFS最適化フレームワークにおける背景処理 - IFSクラウドの技術文書PSOでIFSクラウドをクローン(DBからPSOを無効に) |IFSコミュニティ
I am using the STDSIN2 external file template to load PO invoices, where the PO matching parameter is based on the Receipt Reference.My requirement is to load multiple PO lines with multiple receipt references under a single invoice. However, when I upload an invoice containing two different receipt references, the system considers only one receipt reference and ignores the other.Could you please advise whether there is a way to load multiple PO receipts against the same invoice number so that each invoice line can be matched to its respective PO receipt?Please find the example below for reference.At the line level, all four lines have been loaded successfully. However, in the Supplier Invoice Posting Information, only one receipt reference number is populated because the system considers only a single receipt reference from the invoice header.
In my testing for unpegging an Estimate from a Business Opportunity, I find sometimes I can and sometimes I cannot with different Version Statuses and scenarios. When I can’t unpeg the Estimate, I get the error:BusinessOpportunityLine. The ‘Business Opportunity Line” has already been removed by another User. Refreshing the page does not clear this error. What is this error really mean? Are there certain parameters that must be met in order to ‘Unpeg Connected Objects’?Thank you,Jo
Hello, We are trying to create a valid UBL xml file, but the header of IFS is not right. We usehttps://einvoicevalidator.com/The IFS standard output contains urn:ifs:Invoice:1.0<Invoice xmlns="urn:ifs:Invoice:1.0" xmlns:cbc="urn:oasis:names:specification:ubl:schema:xsd:CommonBasicComponents-2" xmlns:cac="urn:ifs:CommonAggregateComponents:1.0" xmlns:iue="urn:ifs:ExtensionComponent:1.0" xmlns:ext="urn:oasis:names:specification:ubl:schema:xsd:CommonExtensionComponents-2">The French UBL should have this form: it only contains urn:oasis:<Invoice xmlns="urn:oasis:names:specification:ubl:schema:xsd:Invoice-2" xmlns:cbc="urn:oasis:names:specification:ubl:schema:xsd:CommonBasicComponents-2" xmlns:cac="urn:oasis:names:specification:ubl:schema:xsd:CommonAggregateComponents-2" xmlns:ext="urn:oasis:names:specification:ubl:schema:xsd:CommonExtensionComponents-2"> So how can we change this value in UBL 2.1 generation The error message:Element '{urn:ifs:Invoice:1.0}Invoice': No ma
In IFS Cloud, I migrated a large set of Resource groups.When I try to add a Person to a Resource Group, I get an error message stating : The Resource already exists. I get the same error when I try to add a new resource group manually. Has anyone encountered this error before ?
Hello everyone, An issue appeared on one of my environment when I try to create resource connections :As you see, there is no connections for this resource but this message is displayed. This was working fine last week, and I don’t know what happened. Do you have an idea ?Thanks, Simon
Good day, support,I am deploying the IFS solution. We have one configuration environment on one database server, one middleware server, and one management server, and similar with UAT. In production, we have 3 application servers running the middleware and one database server and one management server. with this environment, does it mean we dont have Kubernetes in UAT and configuration?
Hi All,I am trying to unreserve items that are reserved to a Customer Order Line which is supplied by DOP. The reservation was made by performing DOP Netting in the DOP Header connected to the customer order line. According to the documentation, un-reserving can be done by following steps given below.From the Inventory Sub Tab of the Supply Tab in DOP Order, right click the reserved stock line and choose the Manual Unreserve option. It takes you to Manual Netting from Inventory window. From there Qty Res value can be reduced to unreserve Reserved Quantities. However, I am getting the error Qty Reserved Can’t be Less Than Qty Delivered. This is due to Reserved Qty being delivered to Parent Order Is there any work around that I can use to unreserve these reserved items while the DOP Header/Order is still open?
Hello, First of all, I have already read all relevant posts here on the above topic.I want to send the following POST in Postman https://server:port/int/ifsapplications/projection/v1/ManualReservationShopOrderHandling.svc/ShopMaterialAllocSet(OrderNo='1010178',ReleaseNo='*',SequenceNo='*',LineItemNo=2)/IfsApp.ManualReservationShopOrderHandling.ShopMaterialAlloc.Unreserve and get the following error. { "error": { "code": "ODP_DESERIALIZATION_ERROR", "message": "Error while de-serializing contents." }} Setting the header parameters - Accept: application/json;odata.metadata=full;IEEE754Compatible=true- Content Type: application/json;IEEE754Compatible=true wasn't the solution, just as an empty body didn't help. The GET call works as expected https://server:port/int/ifsapplications/projection/v1/ManualReservationShopOrderHandling.svc/ShopMaterialAllocSet(OrderNo='1010178',ReleaseNo='*',SequenceNo='*',LineItemNo=2) We are currently using IFS 10 Update 9 Does anyone have a
Hello,We encountered an error when using the latest REST API for the External Report Gateway (ReportGatewayHandler.svc/Upload) : 500 - "{\"error\":{\"code\":\"ODATA_PROVIDER_ERROR\",\"message\":\"An internal server error occurred. Contact administrator.\",\"details\":[{\"code\":\"PROJECTION_IMPL_EXCEPTION\",\"message\":\"Error while pushing message to redis queue\"}]}}" We followed the official documentation:https://docs.ifs.com/techdocs/25r1/050_reporting/000_reporting/251_operational_reporting/001_report_design/010_operational_reports/400_external_reporting_gatewayAll other REST APIs are working correctly.Can anyone help us? Thanks.
Hi All, I have migrated data into Fixed assets Object page by creating a migration job with the view FA_OBJECT.And now I’m trying to import objects to each FA Object to add Acquisition data and Depreciation information.So I created a migration job connecting FA_OBJECT_TRANSACTION view but it seems like that’s not the correct way to migrate them because they’re not showing in balance analysis report. But I can see records in Post Imported Object Transactions page.I would really appreciate it if I could get your guidance to migrate them.Thank you in Advance!
Has anyone found a way to reliable retrieve Sales Part Base Price of a sales part via the pricing hierarchy? Sales Price List: Customer Agreement: This will ultimately be used in the various invoicing reports and customer order confirmation to show discounts without calculating an actual discount percentage aggregated from the discounts applied at the various pricing source and additional discounts applied at the customer order line level. I’m trying to avoid pulling the Sales Part Base Price directly as that can change over time where two renders of the same invoice could disagree.
Hi,I’m experiencing the following issue with IFS Cloud 25R2 SU3 and was wondering if anyone else has come across something similar.What I have done was:1. Create a Query using the Query Designer window.2. Add more than 16 columns to the view.3. Save and publish the Query.4. Create a Quick Sight report based on the Query.5. Open Report Studio and start creating a layout for the report.6. The JSONDataSource is not visible/available. However:7. Go back to the Query created in Query Designer.8. Remove the additional columns so that the Query contains a maximum of 16 columns.9. Save and synchronize the Query.10. Go back to the QuickSight report and open Report Studio again.11. The JSONDataSource is now visible and available. Has anyone experienced a similar issue?Do you know whether this is a bug, a limitation of the tool, or an expected behavior?Or am I missing a configuration or step somewhere?Any advice or insights would be greatly appreciated.Thanks in advance!Chathuri
The standard functionality in IFS Cloud supports inverted currency rates only for EUR, which is configured as inverted by default. For other currencies, the "Inverted Quotation When Reference Currency" field on the Currency Codes page is not editable. However, some customers have business requirements to maintain inverted currency rates for specific currencies. Therefore, clarification is required on the recommended approach and available configuration options to support such scenarios within IFS Cloud.The R&D team has provided a more convenient method for making a Currency Code Inverted by using Company Templates. Steps to FollowOpen the Company Templates page, filter for the STD template, and use the Copy Company Template command to create a new template based on STD. Open the newly created Company Template and select Company Template Component. Select the Accrul component and then open Company Template LU. Select the Currency Code LU and open Company Template Detail. Navigate to
Example. I have two shipment lines attached to a Shipment. Line 1 with qty 10 has 8 in my first handling unit and the reminaing 2 in my second handling unit. Line 2 of my shipment is not in a handling unit. Is there a way to complete this Shipment?
Hi IFS Community, I’m not able to deploy my customized DataCaptRegstrArrivals-Cust.plsql file anymore due to a priority 1 Static Code Analysis error that appears in Developer Studio and was not there some weeks ago: Followed following advice from DataCaptProcessTemplate.plsql but it didn’t work because Developer Studio seems to accept “@DynamicComponentDependency” for private procedures only: Tried to surround the parameters with $IF Component_Wadaco_SYS.INSTALLED $THEN … $ENDbut Developer Studio does not accept it. Also tried to surround the whole procedure with $IF Component_Wadaco_SYS.INSTALLED $THEN … $END.Developer Studio accepts it and generates the code, but the full procedure body is copied in DataCaptRegstrArrivals.api which leads to an error in the package declaration after deployment. Does anyone has an idea for solving this?Thanks
We have a business requirement to distinguish expense reports that are settled through payroll from those processed through the standard reimbursement workflow.Has anyone implemented a similar approach in IFS Cloud to track payroll-paid expenses? What are the best practices for reporting, reconciliation, and distinguishing payroll-settled expenses from standard reimbursements?
A. What is your idea?1) ClassificationChoose ONE: keep the applicable option and delete the rest.Opportunity for improvement2) Brief descriptionWhat happened, what is missing, or what could be better? Focus on the problem or opportunity (not the solution).Write here: The Equipment Object Navigator has the option to create and view different object structures. Besides the functional view it is also possible to set up and view a locational , from/to , process, pipe, and electrical structures. This is set up in the Structures section, and users can select which view they want to see in the tree structure on the Equipment Object Navigator. This provides a lot of flexibility in setting up asset structures, allowing users to see the connection between different assets in multiple ways and easily seeing affected assets in multiple views.All of this is not available on the Service Object and Service Object 360 screens, which is only providing the the Functional Structure. This limits the way t
Hi Guys,In IFS cloud versions since there are no database end users what’s the workaround to update end users manually?Use case is we have a customer who has recently upgraded to IFS cloud 22R1 and they are having 1000+ users who need to access the environment. Instead of changing passwords from the application user window one by one wondering is there an easy method of doing this.TIA
Are there any practical use cases from any customers for the FMEA function in IFS. I am trying to understand how the output from the FMEA flows into rest of the application and how customers are actually using it.
Hi,There are 4 input values sources to supplier evaluation KPIs and workflow is one. I tried to find a place in the system to connect a workflow to the KPI but is not visible. When we generated automated KPI values, how does a workflow get triggered?Thank you
Hello,Brief description of our problem:our company recently migrated from IFS9 (Oracle 12) to IFS Cloud (Oracle 19c). Both databases run on Oracle RAC. IFS9 worked well with Oracle RAC, but IFS Cloud can only function properly on one Oracle RAC instance. When we run the application on two nodes, we start receiving errors like: ORA-20113: JtTaskTransaction.FND_LOCKED: Update could not be fetched because the work task transaction record is currently locked. Retry the operation.JtTaskTransaction - is one of several tasks, provided only as an example.Our DBA analyzed the database logs and found that there are no RAC waits at the top, but a lot of TX row lock contention, waits event in Oracle databases that occurs when multiple sessions attempt to modify the same row(s) simultaneously.Have you encountered similar problem in your practice? If so, could you please share some advice on how we can solve it or what we can try to find a solution? Currently we have service update 24.2.1. Thank you
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.