This will include questions related to document management.
Recently active
Hello Community, I aim for users to use DocMan actively. But there are some questions and problems that I can't find the answer to. I will try to explain them to you step by step and with screenshots. If it is not clear, please write to me. I have a document as you can see in ss-01. There is a pdf file reference to it. And it's connected to a parts catalog object. In ss-02, the document class default values. For PDM-001 document class;1- All users can view this document. Let it download the linked file.2- You cannot make any changes other than viewing and downloading.3- Nobody can do the object connect detach process if it is not authorized. (Lock/Unlock) End user;It can only add it to the document class for which it is authorized and change its own document. Another question I have is:A document class can only bind to allowed objects. E.g; The PDM-001 document class can only be connect to the part catalog object. (I think it should be the default without adding db trigger) I would be
So my company is on apps 10 upd 18 and we are migrating to Cloud here very soon. I have an open ticket right now about an issue that we discovered in Aurena apps 10. We have enabled attachments on the Payment tab of the supplier. We attach various payment information about the vendor here for reference. This said, what we discovered is that once we moved our accounting department over to Aurena, that the attachments weren’t showing up. The reason for this, we’ve discovered is that the attachments pane is only showing “header” level attachments and is no longer contextual to what you’re clicked on. In my ticket, I was told that this is a “limitation of the Aurena interface” and that a work around was to go to “document object connection” to view attached documents. I was also told that this community post was “already opened” but this is a different issue. We have been using attachments on the supplier payment tab for 4 years. Is this a known issue? If so, is there another community pos
Hi,I have received a case from a customer. They have applied the IFS Cloud 22R2 LTU permission set (EMP_AND_MGR_SELF_SERVICE_LTU_22R2.xml), and they are using the Approval Process functionality in Document Management.They have enabled Approval Routing for Logical Unit “PersonnelRequisition” in the Object Connections screen so that they can see the Approval Process option in Human Capital Management/HCM Services/ Recruitment/Recruitment Requisition Details – Admin screen/Attachment Panel Image 01They want only HCM personnel to be able to add "New Approval Step" or use "Copy Approval Template". Normal users shouldn’t be able to use these buttons.However, they are not able to remove these buttons using Configuration Context (As the approval steps are coming in Attachment Panel) and since normal users are having access, there is a risk of users modifying the approval steps.Is there any method to enable access only for a limited user group for these two buttons "New Approval Step" & "Co
Dear community,I get an error message while creating a new document. Which API or Activities are affacted?
When I try to upload a file with activated Arena Agent in Chrome, I am getting the following error: When I disable the plugin and do the upload without Aurena Agent, it works fine. I observed this issue in IFS Cloud 23.2.1. In older versions it worked fine as far as I can remember.I can reproduce the issue also on other PCs. Is this a known issue or can I fix it by myself?Best RegardsStefan
I’m curious … Can anyone shed any light why Document Approvals ‘requiring attention/needing sign-off’ come under the heading “Unattended”, please? Feels like an odd word to use. Thanks!
Community,When checked in the new document, IFS will name the document like “B100-R000026GEN-1-A1-1.TXT”. it is composed of document class+ document no+ Revision+ ….my question is, is possible to have it appended with document title? Thank you.
Hi I have noticed that another two new document classes have been introduced in Document Basic. I am receiving inquiries from customers who are curious about what these are and why this change is happening. Could someone please provide some information on the new document classes and the reasons behind their introduction?FML DOC Attachments related to faults MM DOC Attachments related to faultsI found a solved question regarding document class DISCO DOC. Maybe these are related to it.?BrLinda
The default action opens the following New Document window when a document needs to attached(ex: Shop Order page).However if more information needs to be added at the time of attaching the document, the Create Document Assistant can be used.It is possible to set the default action to open the Create Document Assistant instead of the New Document pop-up.Set the values accordingly in Document Management > Basic Data > Document Default ValuesDefault action to open Create DocumentDB Column = ATTACH_CREATE_NEW_FORMDocument Default Values = Create New DocumentDefault action to open Create Document AssistantDB Column = ATTACH_CREATE_NEW_FORMDocument Default Values = Create Document Assistant
Web ChromeClient unable to access file chooser - 23R1 SU09 Clear Browser CacheRe Started the ChromeEnable the 3rd Party CookiesCleared the User Profile Nothing Helps 😥
Hi all, There is a customer who is having Application Message Errors when trying to move documents from DB to FTP.Customer has recently installed UPD20 patch on 20/01/2024. The automated process to move documents from database to FTP is not working. They have got over five thousand errored application messages with this eror: Target exception in method call : EJB Exception: Caused by: ifs.fnd.base.SystemException: Target exception in method call : EJB Exception: Caused by: java.lang.reflect.InvocationTargetException: null Caused by: javax.ejb.EJBTransactionRolledbackException: EJB Exception: Caused by: java.lang.NullPointerException: null Product Version: UPD20This is how their process have worked so far. They have had a procedure custom package called Z_Bel_Tech_API.Move_Docs_To_Ftp. This procedure is calling IFS's standard procedure Edm_File_API.Batch_Process and that's when the error appears. The procedure Move_Docs_To_Ftp is set to run as scheduled task every day at 17:00. Sch
Hi,I have added documents on the Work List tab on Work Task Template and then created a work Order and added Work Task Template to the Work Order, then all Work List Lines will be copied from Work Task Template to the Work Order Work Task tab, but connected documents are not copied.So, I tried to use the Object Transformation connection, but I couldn’t get it working.Do you know how to set up a Transformation method for this requirement?(Please see the attached pictures) Target LU : Work Task : JtTaskSource LU : Work List : TaskTemplateRole
In an incident, there will be attachments added.Imagine there are images attached as the attachments of an incident.Is there a way we can get the link to the location where the images are being stored? /Upulka
Hi all,I tried to create an FTP repository for saving attachment files following the steps below:Step 1: Create a Repository Address using the FTP server.Step 2: Create a Repository using the Repository Address created in Step 1.When I clicked "Test Repository," I encountered the error "unable to set connection information." Did I miss anything? I can access the FTP server from the Management server or Middle server, but I am unable to set up a connection with the Repository. Do you have any ideas? Thanks!Best regards,Feng
Hello, Is there an option to “lock” document classes, so people need a password to open and view specific documents? As example, sick-leave documents in My Absense Calendar or medical expeses in Expense Sheets?Besides the “Restriction” which have in place on some documents, but if you are in that group, you can see all the documents, we need to limit that further. So person A can see document 1, 2, 3 and 4. But Person B can only see 3, 4 and 5 Thanks,Michael
While attaching media through MWO app to a work task, the photos are appearing as thumbnail, not full-size photo in IFS APPS10 IEE. Is there any settings to set up in media manager?
Someone tested using azure smb fileshare on the IFS remote solution for files file storage of media item or documents in document management? We get a strange fault when configuring it and testing with media items. Is it a bug ?The file is created on the file share but it fails on setting some extended attribute on the file? Is that really necessary or is it an bug? Caused by: java.nio.file.FileSystemException: /fss-storage/mediaitem/1000: Error writing extended attribute 'filename': Invalid argument Entire java stack on the error we get.2024-01-04 12:47:55.613 ERROR b057f6ec-39ac-4e1a-b24f-0b0840f59abd com.ifsworld.storage.service.FileStorageService.upload() : Failed to upload the file to storage location: com.ifsworld.storage.service.exceptions.FileOperationException: Failed to upload the file to storage location at com.ifsworld.storage.service.providers.ContainerPathStorageProvider.uploadFileToStorage(ContainerPathStorageProvider.java:90) at com.ifsworld.storage.servic
When you create a document attachment and link it to a business object of the inventory item type, for example, you want to display it in a list view. Next, we limit the number of displayed columns. We write the whole thing down. When you want to open this view again, the settings are not saved, because the default view is displayed.
We have attached documents to vouchers that are saved as PDF’s and some are 24 pages but they are taking ~10 minutes or more to open. Is there anything that can be done to make opening pdf’s quicker?
Many of my users are experiencing a problem where it takes several minutes or more to attach a document. Documents are stored in the database, and these are local users to the server so not a network issue. They are in chrome with the appropriate plug in’s and are browsing to the documents. Running 23R1 Update 7
Hi, why is the advanced number generator banned if the document is available on the B2B web portal? Can the blocking be edited off?
Hi all,I have a problem setting up test users for our B2B portal. I have created a permission set which contains the FND_WEBENDUSER_B2B and custom functional role which has granted the projections EquipmentObjects, OrderServiceEndCustomer and ServiceRequest.I log into B2B and “order service” via the service center lobby (<baseurl>/b2b/ifsapplications/web/assistant/OrderServiceEndCustomer/OrderAService;$action=LobbyPageName...). I fill in the form with all necessary data and attach a document (14KB PDF file). When sending the form the portal tries to do some action and then show the following error message:I have checked the log but I can not identify a specific issue to fix.Application - CMD(1): action({"name":"CreateServiceOrder","projection":"OrderServiceEndCustomer","bound":false,"params":{"ErrDescr":"${ErrDescr}","ErrCauseLo":"${ErrCauseLo}","PriorityId":"${PriorityId}","LocationId":"${LocationId}","MchCode":"${MchCode}","MchCodeSite":"${MchCodeSite}","Symptom":"${Symptom}","
Hi allHas anyone been in a similar position to us & found a better solution ? ScenarioAll our raw material safety data sheets (SDS) are in IFS (APPS10 UPD18), stored in the db as PDF files.If there was an incident, eg someone spills a potentially hazardous product, the first aiders will need quick & easy access to the relevant SDS. Where are we now ?We have a custom shortcut that launches the general search function, with DocumentContent pre-selected as a search domain This works fine. You can search for, say “acid” and IFS will provide sensible results. the only snag is that when you click on a result, you go to the document revision page.There’s a further click required to actually get to the document itself.While this works, the objective from the start was to make this process as easy and intuitive as possible. It feels like we haven’t achieved that goal. Is there a trick we’ve missed ? Thanks
Hello,We are currently on Apps 10 Update 18, and have been using FTP as the repository type for document management since we implemented IFS with Apps 8.We have just started the IFS Cloud upgrade project, and have taken 23R2, and just been made aware that FTP repository will no longer be supported and we need to use a different repository method.We are a Remote deployment, and believe the only option we now have is to setup an external SMB storage. Also read database is to be removed in the future, plus this is not preferred due to the sizing issues this would cause by hosting our all historical and future files.I have been pointed in the direction of the Technical Documentation already, but in order to request our IT to setup the SMB Storage I need some information. Typically when you setup a SMB share, you need to grant specific users with permissions to access it. Therefore, we need guidance on what user(s) need access on the SMB share, and whether we need to be creating an active d
Is there a way I can add a document to a folder at Craete Document? Otherwise, I have to start from a folder or add a document later to a folder.
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.