This will include questions related to document management.
Recently active
Hi,I would like to change the document revision from A1 to simply A without any numeric character.Is it possibly to modify in Page Designer or in IFS Dev ?Regards
A user has added a document to a Work Order, that we need to have removed. The user added it through the Mobile Work Order system. Error when trying to remove it from Document Revision > Objects is: Only Users with Admin Rights have access to this operation.Doc Class = FS TECH SCANDoc Basic details on this Doc ClassDefault Object Access Levels was only set to View Access. I changed it to both Admin & Edit access, this did not allow me (an Admin) to delete the document FS TECH SCAN’s only Access Group assigned does not include my group. When I tried to add another group, I get the same error.Can someone point me in the direction of steps needed to be updated so an admin can delete this document by a user.ThanksHayley
Archive media items is available in 21R2, but no longer in 22R2?@Mathias Dahl would you know about this?( I know Media items are not part of DocMan, but I couldn't find any “Enterprise” topic ...)
I would like to know, how I can create a new shop order to rework on defect delivered parts.but I only need to report the supplier about the time I spent on rework, and not the material cost.but when I print the NCR, I show the cost like= material cost + extra time cost! whereas I did not have any material costs.how can I separate the costs in IFS and in the report?thank you for the help
Hi Everyone, :-) getting the following error while viewing the document “Forbidden ”. this error occurs only in some of the PO not in all the POs.permission sets are good doc class is good person group is goodany suggestions what on I could be missing here? dost have anything to do with a file type? thanks in advance :-)
When we originally installed IFS, all document classes were left to the default database. Since then we have set up a group of shared network folder for the classes. I am trying to move the original documents off the database to the shared folders. The Change Document Repository does not seem to function for this as it only shows 2 repositories in Usable status, but not the default DB repository. I have read through the steps in the Online documentation, but the default repository is not in the drop down list. Is there a way to move those documents?
Hi,we would like to release documents of a certain document class automatically after the document is created so that it is passed in the arichvsystem. For this purpose I have created an event which executes a SQL script when a new record is created in the EDM_FILE_STORAGE_TAB table. This works for many documents, but for some the error "Document with status Operation In Progress cannot be approved: ORA-20105: DocIssue.APPROVECHECKEDOUT1" output.I then already put a break in the script and also attached the event to table EDM_FILE_TAB. All unfortunately without success.What am I doing wrong?Regards André
The "Default Document Class" field on the "File Import" screen is blank when the screen is opened, but is it possible to set a default value?We know it is possible by setting "DOC_CLASS" in the "Document Default" setting, but this will set the same value for all users.We want to set the value for each user.
Is it possible to register data with the same document number but different document class in the document title in IFSAPP10 ?When I tried to register the following data, I got an error message that the document number was duplicated.Document Class Document NoCLASS1 DOC1CLASS2 DOC1
I want to register a record with LU name "*" and service list "FndNoteBook^" in the Object Connection screen.However, when I try to register it on the screen, the error message ""*" is a logical unit that does not exist. is displayed.Is this record with LU name "*" automatically registered by some trigger?If so, what is the trigger?(in version IFS10) <Reference Information>Object Connections: Object ConnectionsLU NameService List*" is a non-existing logical unit. The "*" is a non-existing logical unit.
https://chrome.google.com/webstore/detail/ifs-aurena-extension/lnpjlfpkfacbbmmbfjkclpfliinekkhc returns error 404. Is there a new place to download this?
With the type 'Check In To Document Management' in the report rules it is possible to create a document revision with the report when printing a report. If I configure the Document No in the property list as follows 'DocumentNo=[@CUSTOMER_ORDER_IVC_REP/INVOICE_NO];' the revision is not created. If I omit the DocumentNo property, a new Document No is created each time the report is printed. How can I implement in the report rules that a document revision is created which is revised when the report is printed again?
Hi All,I have a requirement of Printing the IFS Logged in User ID & the Timestamp into the Word Document while user trying to click on ‘View’ Operation at any of Word Document in IFS. This is to Track who and all have tried viewing the Document along with Time. I understand, it could be done using VB Script at Document Macro. But, I am unable to print the value into Word Document during View Operation. My Need is:Need of VB Script for Printing Values into Word Document during View operation IFS Line of Code to retrieve values of User name and Time stamp during run timeExample:User Viewed: xxxxxxxTime: dd-mm-yyyy hh:mm:ss Thanks for your Support
Hopefully an easy question to save me (and others) having to test this: Does CreateAndImportDocument.svc work with FTP repository or only database?
Greetings, IFS Community Hope all is well with you.What is the process for enabling the ability to view documents in "Document Package"?Document revisions contain a copy of the documents For example: 1-This is the Document Package. From this page, I would like the user to be able to see it In the Document Revisions section, there is an actual copy of the document. In order to enable the Object Connection Transformation, I follow these steps:Are there any suggestions? Thanks,JL
Is it possible to disallow the addition of an approval step when the status of the document revision is "in the approval process" ? (in Version IFS10)
Hi, where can I find the full Service List options for object connections?
Hello everyone,Any idea whether IFS has rolled back Document File (to use new file or existing file) option in IFS cloud. I am unable to find this option while creating document through Create Document Assistant process in IFS cloud.RegardsAbdul Rehman
Getting Error “Invalid file name” when trying to save document using “Copy File To…”It is working when using another option “Original File Name” to download the file.Normally this happens when file name includes invalid characters, but in this it is not the case. Even changing file name to a simple one does no resolve the issue.Any advice on how to resolve this?
Hi everyone!I’m using POSTMAN to upload documents to IFS Cloud 21R2 and have successfully uploaded to the document manager with many thanks to the people who provided the detailed information in this topic: My requirement is to upload to the media library rather than the docman so I’ve also looked at this topic (again, many thanks to the contributors):I’ve used MediaLibraryAttachmentHandling.svc/CreateAndConnectMedia to get the ItemId and then I’ve tried to patch with MediaLibraryAttachmentHandling.svc/MediaLibrarySet(LibraryId='1013') and also MediaItemHandling.svc/MediaItemSet(ItemId=1013). Whatever I try to upload fails with unsupported content type.I tried just providing a png or a jpg file and let POSTMAN set the headers: Following the instructions in the above post I then specifically set the content type, if-match and X-IFS-Content-Disposition I can successfully upload both png and jpg as media files as a user.Thanks in advance for any suggestions!
From the right-click menu on the document revision screen, execute "File Operations" - "Print Document" to download the target file in the following directory The directory set in the local checkout path + \tempIs there a way to print this file without downloading it?Or is there a way to delete the file immediately after printing?(The downloaded file is not needed since it is running for the purpose of printing. It would be difficult to manually delete the file each time it is printed.)
I have exhausted my searching and research into document management and cannot resolve this issue.I have a user setup that can attach and view their own attachments but not other user’s attachments.Both users are part of the document class group. All documents have been approved.When I assign the user DOCMAN_ADMINISTRATOR, they can view the documents. I have read the Document Access help page and it did not help.
My customer has the following idea: prepare a sales contract in IFS, maybe prepare a base document revision using a macro in DocMan and next export the document to Teams. This allows a multitude of persons that have no access to IFS to update the document, expand it etc.Once ready the document will be checked in into IFS again.What would an efficient process be for this? Or maybe something automatic?
Repository is defined as shared and the status is set as generating. Now, when I try to manually check-in a document using document revision, I would get the following error. Yet, if I set the status as usable, files get checked-in to document revision without any error. Shouldn’t the status generating correct value rather than usable? Are there any configuration to make? Further, when even files get check-in, they are not available on the file location. Yet I could view the document without any issue. Could someone elaborate this behavior as well? Thank you!
Dear IFS Community,To set up an interface we need to download the documents associated with a business object.No problem to do this with an End User , however, when we try to download a document with a Service User (user type = Service User) it does not work.Here is the message displayed :{"error":{"code":"ODATA_PROVIDER_ERROR","message":"An internal server error occurred. Contact administrator.","details":[{"code":"PROJECTION_IMPL_EXCEPTION","message":"Error when reading the file: You do not have view access to download this document."}]}}'The service user has all the accesses, like the end user with whom everything was ok.Did somebody have you ever seen this problem?
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.