Q&A Discussion of IFS Solutions for our IFS Employees, Partners and Customers
Recently active
When attempting to use standard projections instead of integration projections in Crosser I receive a 401 Unauthorized response. I can successfully make these requests in Postman with the same IAM client and credential flow.In this crosser, we were able to use their standard connector/module "IFS Observation Publisher" using the OAuth Client Credentials and associated IFS IAM client. I recreated the observation publisher module as a test, and I am able to successfully authenticate. However, any standard projection used in these universal connectors gives me the Auth error during execution in the flow.I think the main difference between my original attempts and this recreation test is the projection types that are being used (Standard Projection vs Integration Projection). Does, anyone have any experience or advice in this area? Relevant Documentation/Post:https://crosser.io/knowledgebase/authenticating-with-ifs/https://docs.ifs.com/techdocs/23r2/030_administration/030_integration/330_
Hi Expert’sOur company wants to stop stock movements earlier and earlier because of monthly closures.Our stock operators don't want to wait until the 1st of the following month to make their receipts and various stock movements.For example, we are financially closing our stocks on 15 June 2025, with the intention of not opening them until 1 July 2025.Can stock receipts on 20 June be made on 1 July without waiting for the actual 1 July?Thank you in advance.Charles
HiI have a client who is moving away from Paypal. Has anyone used a different payment processing company?
One of the customer is facing an issue where in IFS Developer Studio 18 in the created project the components below 'person' are not visible as shown in the below image. After updating the Target Version to 24R1 GA, components up to 'wrksch' are visible but still cannot see the component 'wscope'. Product Version: 24.1.0Developer Studio Version: IFS Developer Studio 18 (Build 24.1.0142 2024-05-31) I have checked in IFS Developer Studio 18 (Build 24.1.0142 2024-05-31) and (Build 24.1.0169 2024-06-24) and couldn't recreate this issue since all the components until 'wscope' were visible as shown in the below image. Is there any explanation for the behavior?
Hi Team,Could you please advise on the way to add an additional book for fixed assets that have already been imported? We have tried the following way as described in the below post, but it does not work in IFS Cloud. Importing Depreciation for an Existing Object/Asset | IFS Community Please see below our migration error message: Thank you in advance for your support. Regards,Yentl
Hi all In IFS Cloud, edit all feature in multiple line selection help in various screens like bulk supplier update in PR lines, bulk quantity update in start rentals etc [shown like below] However, I couldn't help wondering that's its not available when we want to update same location for bulk purchase receipts. Why do you think its missing? Do you think its an enhancement / idea for future versions? Thanks,Asela
Is there an option to flag a part/inventory part as a Non-Quantity Bearing Part? In Aurena 23I’m defining non-quantity bearing as:Can be included on BOMs (product structures) Does NOT affect inventory balances: No stock quantity is recorded No stock transactions are performed (Receive, Issue, Count, Move, Scrap do not apply)
Just a question for my learning curve. This time about AI. It is there for some time now, but hits IFS Cloud massively from IFS25R1.In this community thread, I read multiple cases such as:'...creating work orders from scanned documents. This is recognising that a lot of customers employ to third parties to generate reports, go and do inspection work. Those reports are often really, really fantastic sources of great data and often in those reports you'll find things like, we recommend you change this philtre in three months time. Or we recommend you do an inspection in five months time. And quite often that those kind of recommendations get missed. So basically, we've bought a capability where we'll scan those reports in through PDF format. Look those keywords, look for key phrases, and AI will generate a list of recommended work orders to be created. And you can choose, say AI goes ahead and create the work orders for you, or you can just present it as, here's a list of things that we
Hi.I have a doubt related to Valuations in SubContract (IFSCloud 24R1)I have an item with a Quantity, Item Rate, Value and Value Adjusted (the Calculation Method is Rate Only and the Valuation Method is Quantity) When I going to certificate I introduce the quantity, not the value in euros, and the system multiply this Quantity by the Item Rate. In the following screenshot I show the contract qty, contract item rate and Value field, but this Value field is the Value Adjusted of my subcontract, so the ‘new’ Item Rate should be equals: Value / Contract Qty.So, as you can see, if I enter 1 unit in Valuation Value field the Work Value field (Calculted by system) is bigger than the total value for this item. And this is so because the system multiply de qty I entered by the Contract Item Rate, and in this case, only with 1, unit the Work Value fiels exceeds the total for that item.I think this is an IFS error, but I’m sure. How can I do this? Thanks in advance. Sergio
Hi Experts. We plan to use Data Migration Manager.We would like to import data from the legacy system in JSON format.Is there any way to do this?
We have migrated our IFS production database (Oracle 12c) to our client’s AWS cloud environment. The was migrated to Oracle 19c.We are encountering issues similar to what occurred when our DEV environment was migrated, where the FND roles were missing supporting sub-role grants. We have fixed most of them manually, but there are a few new issues where we are getting errors like ORA-20105: "FND_WEBRUNTIME" is non existing grantee. There are others that have similar errors: BA_ADMINISTRATOR, BA_BARS_ADMIN, BI_VIEW_ACCESS, BR_FULL_IS_VIEW_ACCESS, FNDSCH_RUNTIME, and CUSTOM_OBJECTS_ADMIN.We tried to export/import the roles from our on-prem database and importing them, but still get the above error.What happened during the migration? How do we correct it?
Hi,We have set-up a new company and copied across document basic data templates, but when we create a proposal and RMB Send to HMRC, we are not getting the following screen:And the message goes in error, with the following:Have we missed part of the set-up for the new company?Thanks,
Hi Team Greetings We have 2 MCPR transactions on which we are unable to transfer cost to customer company. When we create new transactions and transfer the cost on that projects everthing works fine.Only 2 transactions are stuck. We compared with other transactions which are working fine, everything looks fine with transactions in error. Still it gives error in background job as “Notice the background job has ended with an Error “No transactions to create cost accounting for ORA-20110: PrelInvoicePosting.NOACCTRANS” What can be the reason for it? Is it a bug?
Hi,We have an employee who previously left the company and was listed as an invoice posting authoriser. The employee has since returned and is now required to authorise invoices for the same company. However, he has been assigned a new employee ID and person ID, although he is using the same user ID as before.We have configured the appropriate "Valid From" and "Valid To" dates, but when the user attempts to authorise an invoice, the following error appears:The screenshot below shows the employee listed on the Invoice Posting Authoriser screen. As you can see, the same user ID is being used, but the authoriser ID is different due to the new employee and person IDs assigned upon rehire.I'm unable to delete the old authoriser record (2165) as it is linked to existing objects, which is why we’ve set a "Valid Until" date on that entry.In our test environment, I was able to change the user ID on the old record (authoriser ID 2165) to IFSAPP—as this field cannot be left blank—which then allow
Hope one of you might be able to direct me on where to configure Azure Authentication prompt instead of SSO.Currently IAM Identity Provider the configured and IFS Cloud is registered in Azure as an App for authentication.When a user goes to the landing page the following options are visible. When the user clicks “Log In with IFS Cloud CFG” (the above highlighted) the system automatically logs in. Is there a way to enable the prompt so that user can select the Microsoft365 account to use… such as the one shown below…
HiI am trying to test employee termination by using Terminate Employment functionBut when I click employee status (after termination), system did not show LOV. Kindly help Rungtip M.
We have received a Support case from a customer who has a user that works on 8 different companies at a given time on IFS Cloud. (ie. UK Company on browser tab 1, US Company in browser tab 2, Italian Company on browser tab 3, Swedish Company on browser tab 4, and so on)They have recently upgraded from 24R1 to 24R2, and the user claims that the ability to move between different pages (within a tab) without reverting to default company is no longer available in the new version. (ie. Default Company for the user is UK Company and has Manual Supplier Invoice screen for US company on browser tab 1. When they navigate to Mixed Payment screen, the Company reverts to UK company)Generally, when you navigate to a new screen/window in IFS, the Company defaults to the global setting, and it has the same behavior in App10 too.What workaround or advice can other users of IFS share with us, in terms of navigating between different pages and how the Company selector works, so that this user could find
Business Impact/concern: End user experience in remote locations may be severely degraded without proper WAN connectivity. We have Cisco SD-WAN implemented in all our sites, which provides greatly improved user experience for IFS 10 users in e.g. Asia. We are extending the SD-WAN to Azure (implementing Cisco SD-WAN virtual appliances) in the coming weeks, and want to secure that IFS Cloud user experience gains from this implementation.Does anybody have any suggestions?
Hello Community, I am getting the following error while creating creating sub contract valuation.After investigation i found out when the application value is same “This certification net value” field comes as 0 and this error appears. What the way to overcome this error.
I read the following article in Community.https://community.ifs.com/framework-experience-infrastructure-cloud-integration-dev-tools-50/long-running-call-getcountattachments-33137Could you please tell me if the fix for the above article is already released ?My customer notice some slow response on Attachment IFS10UPD8, so they hope patch the issue. Best regards.
Are other MWM users having issues with the Control Click or Shift Click function? I wanted to verify it was a common issue before submitting a Defect. The function is spotty at best.
How do we handle Milestone based payment in Sub Contracts?
We currently have the Test Data Management feature enabled in our Build Place.We have a Dev-01 Environment up and in “Running” status.We recently delivered a delivery into our Dev Use Place (We ordered a sanity build with a QA environment then ordered a delivery and installed it successfully).We tried to to order a Dev-02 Environment but we received this error:We ordered a QA environment and approved it as per the error message. Note - we kept Dev-01 running.We tried to order Dev-02 environment again but we received the same error.How do I resolve this error? Does this have anything to do with Dev-01 existing because it is based off of an older snapshot of our Dev Use Place?
Greetings!How do I add more options to my Configuration Structure Rules in IFS Apps 10?
In App9 from the transfer of work order lines to customer order screen, user selects the line to transfer, RMB to create customer order line and receives an error message: Payer has expired. Check expire date. I cannot find what is causing the issue and have verified that the customer number on the work order is not expired in the customer screen / order tab / misc customer info subtab. Also checked the invoice tab / general subtab and customer number is not inactive. Also verified that in all companies setup for the customer number. Also confirmed the same was true for the parent customer id. We are stuck and cannot proceed with the customer order. Also checked the Customer screen / Payment Tab / Misc Payment Info tab and no payer is entered.
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.