Q&A Discussion of IFS Solutions for our IFS Employees, Partners and Customers
Recently active
Hi,I’m trying to see if there is a way that I can compare all the modules and sub-modules in the local enviroment vs the complete set of modules and sub-modules available. We’re on 23R2. I can get a listing of installed components in Installed Components. This is a high level view, though, and doesn’t have a sub module listing. How do I compare with the available components listing to see what we are missing out on and possibly items we need to purchase? TIA
Hello Everyone, I want to fetch data based on the part id lookup of one miscellaneous adjustment screenbased on the From place(Place for Stock) selection.Means in part id lookup I want to populate the parts that is only available from that place.not all parts. When I am giving From PLACE as (TECH_39991021), I should only be able to see the part ids available in the TECH_399102(Place for stock) stock screen. Do I need to write client scripts or I can do this by lookup configuration in UI level.Please suggest. Regards,Pinmaya .
We are experiencing the cursor dropping out of a comment field and sometimes deleting any text in that field. Has anyone experienced this issue? Is there a fix?
HiI have a customer in APPS10 who is using SSO for client authentication (Azure AD). they can login in with SSO with no issues. Now they are doing some integrations from external system and they want to call IFS REST API using OAuth2. When they try to get access token (using ROPC) with their SSO credentials (i.e. email address of user and password), they get error: credentials rejected.Then they created new user not registered in Azure AD (not SSO user) and now they can get the access token successfully with this user/password. But when they try to use this access token to invoke REST API they get error 401 (Unauthorized) --- this user was granted all needed projections.Any ideas would be appreciated Thanks
Hi, We are entering a new account to the Revaluation Accounts (Financials\Period Routines\Currency Revaluation\Revaluation Accounts) get this error message Field [LEDGER_ID] is mandatory for Reval Account and requires a valueAny thoughts on what could be missing here (APP10 UPD16)
Dear Community, I’m looking for suggestions on how to automatically block future register arrivals of specific part numbers from being used in manufacturing.Specifically, I need a solution where, upon receiving a part number into our system, subsequent register arrivals for this part number would be automatically blocked from being used (for example, through availability control). The key requirement is that this process should be fully automated, without manual intervention. Thanks,Ada
23.2.3When editing the Person on a step in the Approval Process on a Change Request, there are two shortcomings.In the drop-down list, the only attribute to select by is the Person ID (first image below), which for some customers may not be obvious to whom this refers. Can the Name column be added here or would this need an Idea request? When using Find in this drop-down list, the only attribute to select by is the Person ID (second image below). Can the Name column be added here or would this need an Idea request?
Hello, I was trying to create new tabular model based off the existing sales one. I was trying to add a new IAL to the tabular model and was able to create the data source and add the data source to the tabular model. I did set up some relationships between my newly created IAL data source and one of the existing tables in the tabular model However, When I get deploy the tabular model, I’ve been running into this error: REQUEST: 25203 SSISERROR: Analysis Services Execute DDL Task - SSAS:Error: Execution of DDL failed. I was wondering if anyone else has seen this error and if anyone was able to get around this? I was wondering maybe I missed a step in the process? Thank you.
We have CLD instances that are not in production yet. But our certificates have expired. I am not sure how we got these on here in the first place. (Some team members are on vacation right now)We have a new .pfx wildcard cert that is good until 12/2025 that I need to upload.Can someone point me in the right direction?Thanks!
Hello,In IFS Cloud 24R1 ‘Request Work Task’ screen, when a technician enters the expenses or updates the status (i.e., Travel, Arrived, Start Work, Completed) from mobile, it gets reflected in Cloud under the Costs tab.Expense line can be identified by the type ‘Expenses’ but for the Travel and Labor time, it is linked to a single cost type as ‘Personnel’. Is there a way or screen in Cloud to differentiate between travel and labor time separately as we have in IFS FSM? Please let me know.Kind RegardsPriyanka Cecilia
We’re working with a client for whom certain Product Structures which contain a specified components specify a quantity of “As Needed” for it. This appears to be due to the fact that they always know they’re going to need this component but the quantity cannot be determined until the Manufacturing Process has actually started. Once this has happened the Manufacturing staff simply go and take what they need for the order that is in progress. However in other Product Structures this same component can appear with both a specified quantity and Unit Of Measure so there is no consistencyThis particular component has no unit of measure defined for it (we can manage this using the * No Unit defined) UoM when creating the Part Master and when including it in a Product Structure it is added as 1*, but how can we manage this component both from a UoM (as it needs to have an * UoM in some cases and an oz UoM in others) and also an MRP perspective.
Hello, While trying to upload the document either in PC or mobile app, the screen gets stuck while syncing and the uploading of document is not happening. When i remove the document and sync again it gets synced with cloud but when I attach the document, it gets stuck in the screen which i attached and the sync doesn’t happen. Please help me regarding how to fix this. Attaching the stuck screen image for your reference. RegardsMani
There is a purchase order authorization rule with two steps Step 01- Authorizer A with a limit of 500Step 02- Authorizer B with a limit of 1000Expected resultsWhen a purchase order is created for a amount of 300 only Step 01 will be valid for the original authorization.- Works fineNo authorization within the order amount in change order - - Works fineA change order will be created and the amount will be changed to 700 , Here I need both the steps A and B to be included for authorization of the change order.- Does not work as expected. When I use the below set up on company level , it does not pick any authorization for the change order when the amount is changed to 700.If I do not use this tick it will just pick the step 01 considering the delta amounts.Can anyone explain how to use this set up properly to achieve the expected results? Summary of the question
Hi Community, We are getting below error when trying to install K8s on Linux box. Does anyone have an idea to resolve this?.\main.ps1 -resource 'KUBERNETES' New-SSHSession : Session operation has timed outAt D:\ifs\UGP\23.2.3\ifsroot\utils\common.psm1:43 char:23+ ... LOBAL:ssh = New-SSHSession -Computer $NodeName -Credential $cred -Key ...+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : OperationTimeout: (Renci.SshNet.SshClient:SshClient) [New-SSHSession], SshOperationTimeo utException + FullyQualifiedErrorId : SSH.NewSshSessionException Occured While Opening Connection with the Linux Box.2024-05-15 08:09:59.01 068077 Stop Open-ConnectionsWithLinuxBoxD:\ifs\UGP\23.2.3\ifsroot\main.ps1 : Error found in ScriptHalted. Please check logs for details.At line:1 char:1+ .\main.ps1 -resource 'KUBERNETES'+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : NotSpecified: (:) [Write-Error], WriteErrorException + FullyQu
Hi,We’re using Cloud 23R2 and have a problem using the schedule option under Order Report for any SQL report. It works fine from the Quick Reports page, just not from Order Report.Nothing happens if the Schedule Report option is selected. The log shows only this:09:00:25 DEBUG - CMD(1): Execute ReportOverviewList_ScheduleReportCommand for 1 record(s).09:00:25 DEBUG - CMD(1): if({"expression":{"==":[{"var":"record.ReportType"},"SQL"]}})09:00:25 DEBUG - CMD(1): > "TRUE"09:00:25 DEBUG - CMD(1): navigate({"url":"assistant/${ClientName}/ScheduleSqlReport"})09:00:26 DEBUG - CMD(1): > "OK"09:00:26 DEBUG - CMD(1): if({"expression":{"==":[{"var":"record.ReportType"},"QUERY_DESIGNER"]}})09:00:26 DEBUG - CMD(1): > "FALSE"09:00:26 DEBUG - CMD(1): navigate({"url":"assistant/${ClientName}/ScheduleReport"})09:00:26 DEBUG - CMD(1): > "OK"09:00:26 DEBUG - CMD(1): Done ReportOverviewList_ScheduleReportCommand.There is no subsequent GET request. It looks like it’s trying to navigate to an
Dear IFS Technical Experts,I am having difficulty setting up a 2 print agent configuration properly.We have 2 sites and each site has it's own print server. On both servers we have print agents with different logical printer - physical printer mapping. However, they both listen on the same REST port, which causes problems: the faster agent grabs the job and if it wasn't addressed to its printers, it reports an error. We are on APPS10 and our system is hosted in the cloud so I do not have access to the middleware. Is there any routing configured there regarding the agents? Or how could I assign different ports to the different agents? If we change the port only on the agent side, printing will not work.Thanks in advance, Roland
Hi,Currently we are facing an issue, a schedule xml has been added to run on daily basis to send email notification, but the excel file is not attached in the email, only the content in the message body is getting printed in the mail.
I've encountered a problem and need some help understanding the workflow architecture, specifically when a workflow is invoked by an event. I'm focusing on synchronous workflow invocation only. Diagram from documentation Problem: I've noticed a difference in behavior between using Error_SYS.Record_General() in an Execute Online SQL event action and IFS Failure in a workflow event action (in my experiment, both are exclusively called by the same event). It seems Error_SYS stops the process, while IFS Failure in the workflow doesn't stop the process, and I can see more activities (Server Trace) in the DevTool log. Additionally, some data are changed despite the validation error message appearing.This issue is connected to the functionality: Report Picking of Pick List Lines -> Report Picking of one line with serial number. Report_Picking_Of_Pick_List_Lines_SVC.Do_Pick_Selected(...).Context: For every event, a database trigger is created, and it invokes the workflow if I understand cor
What is the best way to prepare for the above exam? What to expect? Has anyone taken the exam recently? Is the IFS academy study material and knowledge checks enough to prepare for the exam?
Hi, we are in the process of trying to upgrade from 6.9.0.22 to 6.13.0.56 and one of our software developers has a query regarding the RESTful gateway:When using the restful gateway where can we get the schema from to use the dsScheduleData class? When we used soap we could import the Service Reference and would have the imported reference, but we wont have that ability on the new Rest only servers.
In Apps10 IEE, I want to use the visualizer in the Labor Load Details screen, specifically the Labor Load Summary graphic, to view the scheduled operation hours in a work center for a given day against that work center’s capacity hours. What I get instead for capacity is the sum of labor capacity for the entire labor class. Take for example the below:The work center ELRPR has 9.32 hours loaded on the date 12/10/24. The work center capacity on any given day is 9.56 hours.Therefore I expect the visual to show that the work center is near fully loaded for that day. Instead, the capacity that is considered in the visual is 434 hours (for every work center), which comes from the labor class’s total capacity for any given day. This causes the visual to show that every work center is near 0% loaded for any given day. The visual therefore is not helpful for viewing work center loads. What do you use to view work center loads?
When you run the 'Create Absence Next day' in the background, it checks for any 'existing absences or clockings'. If such records exist, the ongoing absence process will get terminated.In a reported issue, the database background job 'recalculated days for calculation formula' results to stop the ongoing absence as it results in a calculation for Sundays and Sunday get completed. Unfortunately, this leads to the ongoing absence process being stopped.The customer is looking for a solution that allows the ongoing absence process to continue without being terminated or disrupted by such recalculation/background job tasks.
Hello,We are having problems with our Business Reporter installation. When installed on a computer with Win10 and Office Version 2411 Build 16.0.18227.20082 it works without issues.!--endfragment>!--startfragment>But on Win11 with the same office version the addin failes to load. The COM-addin loads fine, but the “ifs.application.baformula.bafunctions” gets blocked.The error message is “Trusted document settings have changed”Trusted document settings have changed - Microsoft SupportAny tips or ideas welcome.
Hi Team,How can i identify SLA details on resources screen easily without clicking any options like activity screen.In activity screen we have options as below: So can you please check & Confirm. In legends its shows as we can easily identify like below, so where i need to do the configuration for this. Or is there any way in Resources screen i can easily find the SLA details without any click, please suggest. Regards,Shiyaz
Where to go find a fix for this error while processing payment proposal?There are items in the selected proposal(s) for which different/no cash account is specified and these will therefore not be included. Thanks.Shah
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.