Q&A Discussion of IFS Solutions for our IFS Employees, Partners and Customers
Recently active
Hello All, I am looking at connecting a part to a production line so I can use the unscheduled receipts function to convert unsterile manufactured parts into sterile parts with minimal admin. The steriliser is run several times a day, with multiple parts, so using Shop Orders would create a lot of admin work. The Sterile parts have a forecast and are Master Scheduled. The production receipts for the sterile parts are created manually, as are the Shop Orders for the unsterile parts, but I want MRP to generate the Purchase Requisitions for the components based off the forecast. I’ve set up a stucture like below, and tested out and all seems to be working as I hoped. However, the help function for the Production Line is confusing me - it suggests MRP is cancelled when it reaches a Production Line part, but this is not what I am seeing.@Björn Hultgren I think we have spoken about Production Schedules previously, so I hope you don’t mind me tagging you. From Help Page:“Demand for parts ma
Hello, IFS Test environment “IFS10 Update 25”, Active Directory synchronization job started to give error message after data refresh and IFS upgrade Error "ORA-20110: FndUser.WEBUSEREXISTS2: The Fnd User with Directory ID ""username@domain.com"" already exists. Here’s what was done before error.Oracle database was copied from Production environment to Test environment IFS10 was updated from Update 8 → Update 25 This error is in Test environmentI tried to recreate Active Directory Integration Configuration but it gives same error Here’s complete error message from logAD_Integration 1767 13.12.2024 17:21 Error "ORA-20110: FndUser.WEBUSEREXISTS2: The Fnd User with Directory ID ""username@domain.com"" already exists.ORA-06512: at ""IFSAPP.FND_USER_API"", line 2247ORA-06512: at ""IFSAPP.ERROR_SYS"", line 140ORA-06512: at ""IFSAPP.ERROR_SYS"", line 356ORA-06512: at ""IFSAPP.FND_USER_API"", line 1922ORA-06512: at ""IFSAPP.FND_USER_API"", line 1931ORA-06512: at ""IFSAPP.FND_USE
Hi,The issue we have is that a part is normally purchased. (Part type = Purchased in Inventory Part => cost template P-140 Planned purchased cost template ). But occasionally it is required to manufacture the part locally. When manufacturing locally the shop order also need outside operations.But with this setup the Shop Order is missing cost buckets to collect the outside operation costs and therefor we are unable do arrival for outside operation related purchase order. Currently we are solving the issue by temporarily changing the part type to Manufactured at the time of arrival of the outside operation related purchase order and then immediately change it back. (because we want to ensure that the MRP generated SO-req and not PO-req)I suppose that one solution could be to add manufacturing related cost buckets into cost template P-140 but I don’t believe that is the recommended way to handle this. If so why should we have different cost templated for manufactured and purchased par
Hello IFS Community, In the "Customer Statement of Account" (Screenshot 2), there are parameters named Period1, Period2, and Period3 (Screenshot1). I can auto-populate them using Page Designer by navigating to Groups > Days of Ageing Param Group and entering the values in the Base Date, assigning the desired values to each period parameter.Is there any other method to auto-populate these parameters besides the approach presented via Page Designer?The problem I found is when default the value via page designer, the first time the page populate the values Screenshot 1,Screenshot 2, Thank you for your insights!JL
Hello, I have came accros the following topics of @durette Script ACP deployment without downtime: PATCH to AppConfigPackageHandling.svc/AppConfigPackageVirtualSet()/ImportFile | IFS Communityand i would like to implement it using AURENA REST API.Unfortunalty, no documentation is available. Has anyone tried to add ACP threw REST API? if so, my i have some guidance please? I have started by creating a virtual empty set to get an objkey : The set is well created : and then i’m blocked on using the importfile action.There is no documentation and the body of the call is empty to analysis 1- Any idea how to upload the ACP via REST API?2- In the virutal i have a trace file set to : "LogFilename": "ACP Import Log - - 2024-12-15 11-48-36.txt".Any idea where to find that file please? Kind regards
I'm facing some issues with the synchronization of FSM Mobile.Mobile Replication from Scheduled process is activated.I just reduced the time to make it easier to check. After solving this issue we will update it to 1 hour.Let's analyse first the Sync rule Attribute:The XML Poster result just to check if there is any problem with the XML: Converting XML to SQL: Total amount of rows from Attribute sync ruleThe Mobile should receive 217.691 attributes.After synching the Mobile database returns:Mobile database result from Table AttributeFrom server database: 217.691From the mobile database: 200.000Difference: 217.691-200.000 = 17.691 Sync Rules concept investigation:From the beginning, I thought by selecting Batch-Delta the system would divide the total amount of rows int packages of max_rows from XML initial query. But If I do it and limite the max_row = 50000 as the advice: Doing this the maximum of received amount of data became 50.000. The system was only updating the data from the IN
Hi, "IFS Notify Me" requires frequent re-login prompts (typically every 2-3 hours). Is it possible to stay logged in to IFS Notify Me by adjusting certain parameters? Thanks! Best regards,Feng
How can we remove the permission to create new project transactions from a permission set?
IFSAPPS v10 (though the technology hasn’t changed much since at least v7)We’re having problem uploading files to a remote SFTP server using IFS Connect. When we try to connect with FileZilla to that same remote FTP server from the (same) middleware server as that on which IFS is running, we can connect just fine.Moreover, this isn’t the first time we’ve used FTP on IFS Connect. Sending file to other remote FTPs is working fine. So we’re confident that we know how to configure IFS correctly.Here’s the error we get when we try to “Test” our routing rule.By contrast, one of our working SFTP connections gives us this output: We have a slight inkling that despite entering the correct port number on the SFTP-connect-sender page, IFS is really still using port 22 behind the scenes. This is a theory only at this stage, and we’re unable to prove it.But herein lies my question.How can I prove it? I can’t find any logs or trace files of what is going on behind the scenes, except in a file ca
Below error message is given when trying to upload file to FTP server via IFS App 8. Can anyone help on this please.
My employee is trying to save his travel request but receives the below message.
Hello, So I want to create a workflow which does come verification and then sends a stream message so that the user can check the message here:Does anybody know what is the IFS Rest API that i need to call or if i need to make some configurations to then call the method that will send the notification? And if i need to configure some URL so the message can be sent? With best Regards,Francisco Lopes
Hi,We attempted to perform a DR test this morning of our IFS infrastructure.1 - We failed over our Windows VMs which host the MW Server.2- Updated DNS on Domain controller3 - Oracle Dataguard used to fail over to separate DR Linux server. Current PROD DB set to standby and DR database set as primary.4- Start IFS Nodes on MW Server and attempted to access Admin console to change the host for Oracle database server but get this each time: This effectively stopped us progressing.Would anyone have any ideas to the cause of this and why we were unable to access admin console correctly?Thanks
Hi All,The customer is deploying FSconnect AWS URL ( FTP to SFTP migration) by year end & currently it's in UAT & this clarification is related to SFTP development work which is on critical path.Whether the FSconnect application needs to use two separate ports for document transfer? (Port 20 & 21) Is there anything we should know about changing IFS Connect (FS Connect) from FTP to SFTP in Apps8?Thanks & Best Regards,Nipun
We are using LDAP to sync accounts from AD to IFS.We have limited number of user licenses, this means we want the users to be created in IFS autmatically but for new users we want them to be inactive, and will activate manually whenever needed.
Hi All,We see few pods are restarting so many times in our instance. and found the below error in hostpath-provisioner pods in the kube-system. I1128 08:18:28.901804 1 leaderelection.go:248] attempting to acquire leader lease kube-system/microk8s.io-hostpath...I1128 08:19:01.716190 1 leaderelection.go:258] successfully acquired lease kube-system/microk8s.io-hostpathI1128 08:19:01.734941 1 event.go:285] Event(v1.ObjectReference{Kind:"Endpoints", Namespace:"kube-system", Name:"microk8s.io-hostpath", UID:"c78c2716-8ea7-4a14-af83-5e53b7aa866a", APIVersion:"v1", ResourceVersion:"492052", FieldPath:""}): type: 'Normal' reason: 'LeaderElection' hostpath-provisioner-7df77bc496-js5zf_0f88d79c-fec8-4b74-bef5-b5f107295c29 became leaderI1128 08:19:01.771083 1 controller.go:810] Starting provisioner controller microk8s.io/hostpath_hostpath-provisioner-7df77bc496-js5zf_0f88d79c-fec8-4b74-bef5-b5f107295c29!I1128 08:19:02.974741 1 controller.go:859] Started provisioner co
There is a new system parameter SERVER_TIME_ZONE from 24r1 , How can we change this parameter global.serverTimeZone ?
When reading the documentation about preparing a migration job that uses procedure Output File, the text shows:Write data to a server fileWhen File Location = OnServer File Path must be a valid directory object. The column has a List-Of-Value with valid directory objects.So logged in as IFSAPP in the database an Oracle directory MIGOUTFILES was created with C:\MigOutFiles as path on the server (I have created it on the database server).Let's take the company as view to export. I select MIGOUTFILES as output path. File name is Companies.txt and File location is set to OnServer.To make this as simple as possible, in the File Mapping only one field/row is created with field COMPANY.All rules are inactive.When starting this migration job online the system reports: Failed to open file Companies.txt on MIGOUTFILES.The windows directory exist, so why do I get this message?
Good day fellow forum members. We have been experiencing latency issues with our reverse proxy setup since we installed it in 2020, (using NGINX and Apps 10). On the debugger our average ping response is around 240 ms. In the environments not on reverse proxy it is around 25ms.If anyone has a similar installation, what is your experience of response times? and if possible can you provide a dump of the NGINX config? (obviously deleting IPs)?From the Network layer the response times are 2-3 ms. between DB MWS and Proxy. All are hosted in the same DC and through the years our technical team swapped environments on and off the reverse proxy and it keeps on coming back as the most likely bottleneck.Regards
Hi, This is my first post here so also wanted to say hello :) I have problem with ngnix confguration (maybe not only). The general idea is to have TAS application working from the outside of the internal network on mobile devices. General idea of the connection:INTERNET ------> gateway (ngnix reverse proxy) ------ MWS server with TAS application I was able to redirect connections to TAS service (or at least it’s web service): location /mwo/ { proxy_pass https://<interal_IP>:<PORT>/; proxy_redirect off; proxy_pass_request_headers on; proxy_buffering off; proxy_set_header host $http_host; proxy_set_header X-Real-IP $remote_addr; proxy_set_header Upgrade $http_upgrade; proxy_set_header Connection "upgrade"; proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; proxy_set_header X-Forwarded-Proto $scheme;
Hello, Has anyone more detailed information on the full setup of the financial connector? I have done the setup to transfer Customer Invoices. I got to the point that the application messages are generated and xml files written to SFTP. What I don’t see is data in Transferred Customer Invoices Analysis screen. This makes me think the setup I did is not complete. I’d appreciate any feedback from anyone that worked with the Financial Connector before. What I was able to do thus far regarding Transfer of Customer Invoices via Financial Connector:Make sure Send_Customer_Invoice is enabled + correct Receiver/Sender is set Define for which companies the transfer process should be executedDefined Routing Address:Defined Routing Rule” Run Transfer Customer InvoicesApplication Messages are generated and files transferred to SFTP:Invoices also appear in Customer Invoices in TransferHowever they don’t appear in Transferred Customer Invoices Analysis screen. This makes me think the process is no
HI,Is there a way to set a slider to default as being turned ‘on’ or ‘off’ using the Page Designer? Example: when creating a revision on a Business Opportunity, would like for the ‘Obsolete’ slide to be defaulted to ‘on’ when creating a new opportunity revision. Right now it defaults to ‘off’. Thanks, Jo
If I upload a document with the aim to throw paper copy away, what are the chances of the document not being backed up?What if it crashes? How often do we do backup?
This post is related to : Subsidies / Discount for customer orders | IFS Community Some of our customers receive subsidies from organizations.If the subsidy covers, for example, 20% of the order amount (tax are not included), we need to invoice 20% of the item's price (tax not included) to the funding organization. We are trying to proceed as follow : Creating the Customer Order for the right customer. Creating invoices : First invoice wich is a regular for the customer himself Second Invoice is an instance invoice for the other entity We are having deficulties on how we should affect the right price to the right invoice.After saving the instant invoice we a “More Information” option on the header.We have referenced the original invoice (Ref Invoice No with Ref Invoice Series ID)And we have defined a deduction group hoping that the group will automaticly calculate the invoice amount We have defined a deduction group and rule The instant invoice is still with no amount. Any idea h
Hello,the Inventory Part is created/connected for Site B2251in PO we bought 40l but this qty results from gathering all our demands of all sites (here 15l for site B2251 + 25l for site B2252)we didn't want to create two PRs for two different Sites because then we should create two POs while we want optimize our number of POs and our costs and we have better price depending on the qty (the more you buy the less you pay).after delivery we made receipt according to the PO to Site B2251.now, we would like to split qty of 40l to sites B2251 and B2252 - to clarify: on stock B2251 we have 40l and 25l we would like to transfer/relocate/issue to stock B2252.is it possible to do that in IFS, if so, what we should do. Regards, Kruthika
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.