Q&A Discussion of IFS Solutions for our IFS Employees, Partners and Customers
Recently active
Hi all,We use IFS Applications 10 and schedule shop orders using APB.I’m trying to model a finite physical constraint: we have a limited number of trolleys, which we call banks, that carry material between operations.Example routing:Operation 10 — Work centre A01, fixed 2 hours Operation 20 — Work centre A02, 1 minute per unitMaterial is loaded onto a bank at Operation 10. The same bank then moves with the material to Operation 20 and is only free again once Operation 20 is complete.So the bank should be constrained from:Operation 10 start → Operation 20 finishnot just during each individual operation.For example, if we only have two banks, APB should not allow a third order to start Operation 10 until one of the first two banks has completed Operation 20.I tried modelling this as a tool:Tool ID: BANKInstances: B01, B02Required on Operation 10 and Operation 20But APB releases the tool after Operation 10, then allocates a tool again for Operation 20. It does not appear to hold the same
Hello,We encounter an error when running the Execute step of the rental transfer between 2 different projects.At the "Execute" step, an error message appears: "Only Receive into Arrival and Inspect at Arrival are allowed for non-inventory parts." The item used in the test is an inventory item.The error doesn't seem to correspond to the situation.Have you encountered this situation before?Thanks for your help
Error in retriving the saved pdf reports in crystal web service in APP8
We are facing an Issue where activities coming in to PSO are getting an Override Duration of 99 Hours by Default.The field is not part of the order in IFS cloud.Can anyone help with how this field is getting set, This seems to be only there for a partivular activity type,so is this inherited from an Activity type or somewhere else.
I’ve been trying to find an option to add a discount amount for a purchase requisition line. All I can find is the discount percentage, but this is not a valid option. My client is entering after the fact purchase reqs for things like hospitality and a discount amount is often given for a total amount, say $360. I can have the users manually calculate the discount percentage at the line level but this is not user friendly and often doesn’t add up to the correct net amount. I tried to create a 200% discount and it allows me on the Purchase Req line, however, there is a blocking message when attempting to convert to a PO, since the PO line would have a negative amount. I can do the discount total on a PO by using charges and entering a negative amount, however, I’m struggling to find any options to enter a discount amount for a purchase requisition line.Any thoughts or ideas? Thank you.
Is it advisable to change the PO price (by using a PO change order) to match the invoice once the Inventory has been issued to shop orders or should we un-receive the PO and change the price and then re-receive. We use average costing.
Hi!I would like to know if there is a specific path or flow where we can connect 2 Functional objects of the same level.One is a major equipment/asset and the other one is also the same but can be installed on the first equipment and be transferred between different objects of same asset class.Is there a way we can follow e.g.Asset B breaks down under asset A, and we replace it with another asset like asset B again under asset A.Brekadown is on asset A, but following CM is on asset B. Because once we replace the asset B asset A is operational again.While asset B is on asset A cost goes on asset A but it needs to have history recorded on asset B as well.It may be complicated to explain but hopefully we can make this clear together.Thank you!
The core issue is the failure of IFS Cloud to communicate with the Aurena Agent, resulting in errors such as "This operation requires the AurenaAgent to be enabled." The problem appears linked to environment-specific OS or configuration differences rather than a product defect. When the customer is trying to export a document in the window below (custom page), the following error will pop up. This Aurena agent is installed on only 2 machines. One is working (though it sometimes doesn't work), and the other is completely not working. Investigations done so far.Reinstalled the aurena agent a few times. Still getting an error as below. Checked Anti-virus software like ESET blocks this Aurena Agent installation and followed the below article: https://community.ifs.com/framework-and-experience-101/error-from-aurena-agent-security-error-reque Customer hasn’t performed an update to the SSL/TLS certificate on this environment recently. Disabled the antivirus and installed the Aurena agent
Could someone please provide the Supported Platforms for IFS10 UPD27 ?Technical documentation link not working
Dear communityI created a user interface workflow for training purposes only. It prompts the user to fill in the "Customer RF" field for a specific customer.But I get the following error message: Here is my workflow:Where am I going wrong?
We are in the process of upgrading IFS Cloud from 24R1 to 25R2 and noticed all of our lobbies (standard or custom) are impacted negatively when zooming the lobby over 100%. The elements will get “cut off” with no ability to zoom.Has anyone else been experiencing this? I couldn’t find any posts or knowedgbase articles on it.
Good morning,How can I configure file imports from a specific location, e.g., a network directory, using external file transactions in the IFS CLOUD system?I assume that I have a .csv file in a specific directory and the system has a schedule for reading the file from that directory.I am considering this in the context of currency imports and wondering whether it would be reasonable to use the file reader mechanism in this case.
Hi all,Here’s how you can download a CSV file by using a Command in IFS Cloud.We can easily achieve this by doing few adjustments in .client, .projection, .plsvc and .plsql files.(change in the .plsql file can be done in the .plsvc file too) It’ll look like thisAdd the command into the page that you want and click on it.It’ll get downloaded to your default download folder Here’s that downloaded CSV file Steps to achieve the above functionality .PLSQL File changeHere you’ll add a method.Basically you have to create a CLOB file > convert it to a BLOB file > return it.PROCEDURE Convert_to_Csv( csv_data_blob_ OUT BLOB)IS csv_clob_ CLOB;BEGIN csv_clob_ := 'Header 1' || ',' || 'Header 2' || ',' || 'Header 3' || ',' || 'Header 4'|| CHR(10); FOR rec_ IN 1..20 LOOP csv_clob_ := csv_clob_ || 'THRULK'||rec_ || ',' || 'THRULK'||rec_ || ',' || 'THRULK'||rec_ || ',' || 'THRULK'||rec_ || CHR(10); END LOOP; csv_data_blob_ := Utility_sys.Clob_To_Blob(cs
Hello, We got the error “ The sub project does not exist” when launching the calculate value on Schedule of Work Estimating by WBS.See attached document. Can anybody help ? Thank you. Christophe
Hi, How can I use datepicker for quick report parameter in IFS Enterprise Explorer 10?
Hi, I’m exporting lobby pages from one environment to import into another (Cloud 23.1.3). Several of the lobby pages have link list elements that use datasources on the links. When exporting the lobby page, some of the datasources make it into the export file but not all (typically more are left out than included). I have not found anything to let me know why it’s not including all datasources in the export file. The result is that the lobby page is incomplete when imported into the other environment. Has anyone else experienced this issue? Thanks!
hi, Can IFS below setting could be configured for no-part PO line only? We are in APP10
We are on IFS Cloud 25R1 and the Condition Generation is creating new PM work orders before the accumulated quantity meets the interval specified on the PM Action.Anybody know what might be causing this?
Hi Is there any official recommendation how to apply OOB? Just as it is? How to next follow when applying new SU/RU? Make then obsolete/delete it?
We are currently in IFS CLOUD 25R1. We successfully migrated all of our documents from our on prem non-IFS system to IFS CLOUD (600k files). Then we migrated the documents from database storage to our BLOB. However, we need to now migrate to the production environment. As we were only in UAT. To avoid migrating all the documents again. Could we clone the file storage from our UAT environment to our PROD environment. Then populate all of the needed tables that reference these files? If this is possible does anybody know what all tables would need populated. I know of EDM_FILE_TAB, DOC_ISSUE_TAB, but I wasn’t sure if there was another table I was missing. Any help on this would be useful. Thank you. *NOTE we cannot clone the database from UAT to production because we need our PROD environment to be a blank slate for our data migration.
We have run into an issue where shop order operations were accidentally over reported and then subsequently cancelled. However after cancelling the reports, the Operation Qty has become negative, the remaining open operations were closed, and the outside operation purchase order was cancelled. I was able to recreate this in our test environment. This issue occurs when the Adjust for Op Qty Deviation toggle is enabled and the over reported operation reports are cancelled in the incorrect order. Essentially what happened in the above screen shot was 141pc were completed through op 160. Then, 500pc were accidentally over reported on the same first 4 operations. Operator brought this to a supervisor to correct their mistake. The supervisor cancelled the operation reports, however they cancelled the report on op 50, then 75, then 110 and finally 160 which caused this compounding Deviation Qty, which in turn drove the Operation Quantities negative. If the reports get cancelled in the revers
Dears, can anyone of you point me what might cause this error when I’m trying to load Shop Orders to APB ? IFS10 App
Hello everyone,We recently migrated to IFS Cloud 25R2 (SU6) and noticed a change in the format of the "ActualShipDate" field in the Dispatch Advice messages (DESADV) we send.Before migration:"ActualShipDate": "2026-07-17T16:04:55" (local timestamp, no timezone indicator)Since the migration to 25R2:"ActualShipDate": "2026-07-20T10:29:20Z" (UTC timestamp, with "Z" suffix) This is causing issues on the receiving side, which expects the previous format without the UTC indicator.Has anyone else run into this on Dispatch Advice (DESADV), or on other outbound messages? Is this an intentional/documented change, and if so, is there a way to keep the previous format?For reference, we have also opened an official support case on this topic: CS0542209.Thanks in advance for any insight! Soumia
The following is stated in 25R2 release notes, I believe. But what does in mine in practice? Where can I do this configuration?Improved Integration with Custom Attributes in Outbound MessagesCustom attributes on business entities can now be included in outbound messages (e.g., Freight Booking, Dispatch Advice).Uses configuration over customization.Benefits:Enhanced flexibility.Cost savings.
Hi,I am working on the Build Place project. I downloaded the certificate from the Dev environment and used it in Report Designer, but I got the below error. I already added certificate to certificate folder under report designer.
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.