This will include questions related to FSM and PSO.
Recently active
I want to update user_def13 with attachment_name. user_def13 is in the escalation table, but there is no direct relationship between the escalation and attachment tables. So, I created another table named c_escalation_extension.I have written a business rule to insert esc_id, attachment_id, and attachment_name into c_escalation_extension. The insertion is working correctly. Update operation is not working. User_def13 is not updating with attachment_nameBelow is the configuration I did for the update operation in business rule and custom process 1- Primary table = ESCALATION 2-execution type = all rule all value match 3-execution point = after commit insert 4- rule input table = c_escalation_extension column = esc_id c_escalation_extension column = attachment_id5-input parameter c_escalation_extension.esc_id(new) operator = equal value = blank c_escalation_extension.attacment_id(new) operator=equal value = blank 6- XML Query<perform_exec_db_edit> <par
Hello everyone,First of all, I apologise if there is already an entry on this and I have overlooked it. Maybe one of you has an idea how I could solve the following task:I am looking for a way to run certain SQL queries on a daily basis and then send the results of these as a PDF by email, as part of my daily monitoring, so to speak.I use the Smart Client for Windows in the following version:Release: 6 Update 25Build: 8597My idea would have been to do this with the menu item ‘Monitor Schedules’ as a daily job, but I haven't quite figured out how to do this, or whether there might be a simpler solution to my problem.Best regardsLars
Hi ALl, Doing a project in 24R1 where I see some strange behaviour and wondering if we are dealing with a bug. Situation:I have a Work Task where I need to assign a person to the Work Task using a Resource group (Resource Type = ‘Person). Standard allocation against the Resource demand works as expected, but I am also trying to use ‘Direct Allocation’. And I noticed that not all of my Resources are showing in the drop down list. Initially I didn’t even see any. So I’ve been trying to debug and investigate and I’ve found the cause of the issue but now I am wondering if this is a bug or ‘functionality as intended’. And if it is ‘functionality as intended’ - what would be the idea behind that way of working because I can’t imagine why this would work like this. So what I have found out is:Direct Allocation does not take into account persons belonging to the top Resource Group, only from subgroups. And I have no idea why this would work like that. I am trying to make sense out of this but
Hello, Our client is working with PSO integrated with Cloud. They have this scenario: An task is cancelled, but must be in some cases opened again. They don’t want to create a new task instead of the old one, since it takes too much time and they have many requirements in a day.Did anyone have a similar requirement or do you have any ideas? As far as I know and have tested, a cancelled task cannot be reponed. Thank you very much,Iulia
When the ‘Team inheritable’ is enabled, the DSE continues to assign activities to the Team even if the only skilled team member is unavailable (private activity during the specified time).Disabling the ‘Team inheritable’ is also not a viable solution, as it prevents the activity from being allocated, even if the skilled team member is available.This occurs because if the ‘Team inheritable’ is enabled, the Team will inherit any team members’ skills during the membership period, regardless of any unavailability of members.To ensure unavailabilities are considered during allocation, the membership period of the skilled member must be adjusted, each time an unavailability is added for that member.Therefore, we have received a customer request (discussed with R&D team as well) to enable the DSE to consider member unavailabilities during the membership period when the ‘Team inheritable’ is enabled.
When the ‘Team inheritable’ is enabled, the DSE continues to assign activities to the Team even if the only skilled team member is unavailable (private activity during the specified time).Disabling the ‘Team inheritable’ is also not a viable solution, as it prevents the activity from being allocated, even if the skilled team member is available.This occurs because if the ‘Team inheritable’ is enabled, the Team will inherit any team members’ skills during the membership period, regardless of any unavailability of members.To ensure unavailabilities are considered during allocation, the membership period of the skilled member must be adjusted, each time an unavailability is added for that member. Therefore, we have received a customer request to enable the DSE to consider member unavailabilities during the membership period when the ‘Team inheritable’ is enabled.
Hi Experts,Could you please advise, if the customer is not using HCM module is there any way that we can capture time and attendance only using NGSM.Are there any existing functionality for that?Regards,Heshala.
A couple of releases back, IFS introduced Next-Generation Service Management (a.k.a. Request Management or NGSM). While the primary focus of Enterprise Service Management (“ESM”, which was already available in Apps 8/9/10) was the service of company-owned equipment, NGSM was developed to better support customer service processes, remove unneeded complexity, and address additional scenarios (such as offering a service for a generic model, not a serialized asset, which is often required in B2C scenarios).To help the community better understand NGSM and how it compares to ESM, I have created the below document. Just like IFS Cloud - Scheduling demystified (23R1) | IFS Community this is NOT an official IFS document, however it was created in collaboration with R&D.If you have corrections, feedback, ideas - please do share so we can incorporate them.
Hi,Is there a method to book or block a tool, ensuring that it is not simultaneously used for another task? From my understanding, it is currently not possible to automatically schedule and reserve a tool from the PSO since tool/equipment resources are not considered Scheduling Resources.However, within the Standard Task, it is feasible to insert a demand line of type Tool/Equipment, although this must be manually allocated.How can I view the calendar of these tools to determine their usage, and how can I ensure that no other task utilizes the tool on the same time?Thanks,Stefania
I need to know where is the VLOOKUP COUNTERPROOF screen?
Hello, We have the following scenario in PSO. Normally, all activities are fixed to a planned start time and to a resource.When I want to change the resource per Drag and Drop, I always have to fix the start time. For example, in the screenshot below, it should be 10:00 (this is the planned time coming from IFS Cloud) and I have to correct the 10:07. I know this can be solved by using the “Edit” option instead of Drag and Drop, but the dispatcher would like to use the Drag and Drop functionality and in the same time avoid correcting the hour, since they will have to do a lot of manual changes in a day and they have to be very quick.Is there any way to make this process easier and faster for the dispatcher? Thank you very much,Iulia
Hi, I would like to ask what should be done to see training action in dispatch console calendar.It should look like this: Thank you Romana
Hi Team,The task resource is not being created when I assign a technician.Note: App param ENABLE_TASK_RESOURCES = Y.Please note this is working in lower instance.ThanksVenkat
Release: 6 Update 26 : FSM_6_U26_D0Build: 8690I had a report that was working but needed to be tweaked. I opened the the rdl in Report Builder, made a tiny tweak saved the rdl .resaved it as an rdlc in Notepad upload the Report into Report Admin in the UI I refreshed cacheWhen I run the report I get “An error occurred during local report processing.” This is happening on any report that is updated and reloaded in report admin.Any guidance would be greatly appreciated.
Hi, On the Resource Planning Database and the RAM_Resource_Skill_Availability table is there a way of getting the dates for the availability window i.e. a Start and End. Looking at the table there is a just a pattern id so i’m unable to to use that. Just wondering if the times are stored elsewhere?Cheers Ady
I would like to know if It’s possible to use a dynamic URL as an endpoint of an outgoing message. For example, doing the configuration of the message using the ‘Message Routing’ (next image), I need to use a URL that will change depending on same variables (in a ideal scenario this variables would be defined on the same XML type Business Rule, that call this outgoing message). I am trying to call a URL that has a service and it has this format => “http//URLHOST /field1=X,field2 = Y” do you know if I can achieve this by using the XML maps and Routing Message Rules ?
Hello,Twice a year we execute a user account security audit to ensure that access to all systems is valid and appropriate. During the most recent audit, the auditors identified 2 accounts that were inactivated in our Active Directory but had a ‘Last Logged In’ date event recorded on the PERSON record several months after the AD account was inactivated. Both of these users were configured for OIDC authentication so theoretically once the AD account was inactivated these person records should not have have any Log In/Log Out activity recorded. The question is whether or not there are any other activities in the system that would have resulted in an incorrect Log In/Out event to be recorded? Thanks,Richard
Hi All,Facing an issue with dataset we have loading datasets from FSM to pso every 30 min interval datasets will be loading today we are facing issue like datasets is not loading on schedule board when we select dataset its always showing waiting for dataset popup we restarted servers but no luck . Kindly suggest what could be the issue? Thanks,Durga
Hi All,we are receiving request time out error for all datasets verified fsm is communicating with port 8744 and also verified DB space but no issue in the db side not sure always getting request timed out error. Error:The request channel timed out while waiting for a reply after 00:00:59.9844121. Increase the timeout value passed to the call to Request or increase the SendTimeout value on the Binding. The time allotted to this operation may have been a portion of a longer timeout.Kindly suggest any solution for request timed out. Thanks,Durga
Hi I have upgraded FSM625 V to FSM630 after upgrade i could not able to install smart client application i am getting below error during installation i did not see any error during upgrade and web client and mobile applications are working fine. Kindly suggest how to fix this issue.Error Message:ERROR SUMMARY Below is a summary of the errors, details of these errors are listed later in the log. * Activation of C:\Users\durgabhavani\Downloads\FSM6Test (16).application resulted in exception. Following failure messages were detected: + Exception reading manifest from file:///C:/Users/durgabhavani/Downloads/FSM6Test%20(16).application: the manifest may not be valid or the file could not be opened. + Manifest XML signature is not valid. + The digital signature of the object did not verify.COMPONENT STORE TRANSACTION FAILURE SUMMARY No transaction error was detected.WARNINGS There were no warnings during this operation.OPERATION PROGRESS STATUS * [25-11-2
Hello,Our DBA was running diagnostics on our production database server using sql-constanctcare and it identified the following db tables that would benefit from having the indexes identified below created. Because these are PSO databases, I wanted to get confirmation that this would be a recommended action to take.Please advise.Tool Used:https://www.brentozar.com/sql-constantcare/USE [SchedulingSystem]; CREATE NONCLUSTERED INDEX [message_group_id] ON [dbo].[Message] ([message_group_id]);USE [ResourcePlanning]; CREATE NONCLUSTERED INDEX [organisation_id_dataset_id_ram_update_type_id] ON [dbo].[RAM_Update] ([organisation_id], [dataset_id], [ram_update_type_id]);USE [Scheduling]; CREATE NONCLUSTERED INDEX [organisation_id_dataset_id_delete_flag_activity_id_input_reference_internal_id] ON [dbo].[Activity_Custom_URL] ([organisation_id], [dataset_id], [delete_flag], [activity_id], [input_reference_internal_id]);USE [Scheduling]; CREATE NONCLUSTERED INDEX [organisation_id_dataset_id_delete_
I created a query in Query Designer in IFS CLOUD 24 R1.I’m trying to use it in Element Designer as datasource. However my query does not appear as an available datasource. ANy idea how to get it usable in Element Designer ?
In FSM mobile how do I prevent engineers from entering a newline/carriage return in a text field?The below works for other undesired characters…var myField = getControlValue('CUSTOM', 'TEST_TEXT');var isInvalidChar = getDBValue(stringFormat("SELECT CASE WHEN '" + myField + "' REGEXP '^[A-Za-z0-9\-\\\/]+$' THEN 'FALSE' ELSE 'TRUE' END AS isInvalidChar;"));Essentially we are capturing a serial id which can contain 0-9, a-z, A-Z, hypen, backslash and forwardslash. Anything else should fail.
Is there a way in aurena to view/print the work report page (service report)I have been looking everywhere and cannot find how to pull up the report...or reprint it once it is returned from the mobile device.
Hi,We use the below perform definition for modelling and scheduling data set load <perform_initialize_ram_threesixty><perform_initialize_ds_threesixty>We have a requirement when we do update resource skill availability, the change should not go as a part of modelling load in <perform_initialize_ram_threesixty>The resource skill availability change must go as part of <perform_send_rota_data_to_dse>Do we have any possibility to restrict that from load
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.