Q&A Discussion of IFS Solutions for our IFS Employees, Partners and Customers
Recently active
The below client error occurs when opening a lobby page. The customer is on 24R1-Su2Url (parameters included) = https://<SERVER_URL>/main/ifsapplications/web/lobby/4849f18a-ca01-4d91-9d6c-2cd8d1cc727b;path=0.1656053651.1188772997.671078522.963475138.eyJmIjoiL0xvYmJ5IiwiZyI6IjQ4NDlmMThhLWNhMDEtNGQ5MS05ZDZjLTJjZDhkMWNjNzI3YiIsImkiOiI0ODQ5ZjE4YS1jYTAxLTRkOTEtOWQ2Yy0yY2Q4ZDFjYzcyN2IiLCJhIjoidmlydHVhbC0xIiwiYiI6Ijk2MzQ3NTEzOCIsImUiOiJQUk9KRUNUIiwiZCI6dHJ1ZSwiYyI6ZmFsc2V9Error stack:Cannot read properties of undefined (reading '0')Error at R.run (https://<SERVER_URL>/main/ifsapplications/web/main.c21b8b30e2e5025f.js:242:772645) at l.processResultSet (https://<SERVER_URL>/main/ifsapplications/web/main.c21b8b30e2e5025f.js:242:7195033) at set resultSet (https://<SERVER_URL>/main/ifsapplications/web/main.c21b8b30e2e5025f.js:242:6409593) at eK (https://<SERVER_URL>/main/ifsapplications/web/main.c21b8b30e2e5025f.js:242:38766908) at Dj (https://<SERVE
Hello, In IFS Cloud, is there a way to pre-populate the next system-generated Person ID on the New Employee wizard? From my understanding, you can use workflows to pre-populate fields and was going to see if that could do what I need. The ultimate goal with filling that field is so we won’t have to fill that field when creating a new employee based off a new person employment. I was trying to see if this can be done via workflow or would this have to be a customization? Thank you.
Hi all,We are in the process of deploying the 24R2 (IFS CLOUD). Our current solution is in 22R2.We currently have 32 permissions sets, and many of them are “CUSTOM”.With 24R2, a lot of projections have been added, and I realize how difficult it is to analyze.So, is there a way to quickly compare permissions sets (entity action Grants & projection action Grants) between 2 environnements (22R2 vs 24R2).Thanks!! Soumia
Hello everyone,On the “Recurring Service Programs” page, there is a selector sorted by the Start Time (custom attribute) field. When the start time of an entry is changed, the entry remains in its original position rather than being automatically re-sorted. It only appears in the correct position after the page is manually refreshed.Is this the expected behavior, or is there a way to trigger automatic sorting without a manualrefresh? Thank you in advance!
Hello everyone,Our customer would like the “Show Associated Notes” option in the Service Notes tab of the Request screen to be enabled by default, so that they don’t have to manually check the box each time.I wasn’t able to configure this in the Page Designer — does anyone have an idea on how this could be achieved, or is it simply not possible within the current setup? Thank you!
ERRINV: Instance of entity JT_TASK_CLOCKING with primary key [-54.0] not found in database. Some issues have been identified in CLOCK-OUT. When I checked the Time report in the Work order, 'Work Time' was not captured for this user since a failed transaction was logged. Please advise. Can anyone help me troubleshoot this issue?
Dear all,we have integrated our IFS Cloud with e-days using restAPI and IFS Connect. There are outbound restApi calls with callback function stored in API package in IFS.The integration works fine, however from time to time we need to re-deploy the API package with the callback function to deploy bug corrections or improvements.After re-deployment of the API we are always refreshing all server caches, but despite that restApi messages start to fail with the following error:“Caused by: java.sql.SQLException: ORA-04068: existing state of packages has been discardedORA-04061: existing state of has been invalidatedORA-04061: existing state of package body "IFSAPP.ORI_HCM_EDAYS_API" has been invalidatedORA-04065: not executed, altered or dropped package body "IFSAPP.ORI_HCM_EDAYS_API"ORA-06508: PL/SQL: could not find program unit being called: "IFSAPP.ORI_HCM_EDAYS_API" I would also like to mention that our MTS server is running 1 pod for connect and 4 odata pods.Is there any tip what
Hi, When using the Availability Check for Customer Orders in IFS Cloud, is there a way to have it consider incoming supply for Purchase Requisitions? Thank you,Alex
EMBEDDED WEB PAGES IN WEB CLIENT using iframe was introduced in Patch 5 of FSM update 6. However this MetrixBrowser implementation on the Webclient is not consistent with the behavior from the smart client.In smart client the iframe url is able to resolve the substitution variable however the webclient is unable to do it. See example belowEx using the URL -> https://www.google.com/webhp?igu=1&q={{address.geocode_lat}}&output=svembed on the address screen we see that the webclient is unable to resolve the substitution variable {{address.geocode_lat}} like the smart client Smart client – The URL is able to substitute {{address.geocode_lat}} with the value of address.latitude which is 43.0333862305Webclient - The URL is unable to substitute {{address.geocode_lat}} with the value of address.latitude which is 43.0333862305 and just passes the tag as it is.
Hi All,I’m in the process of moving from ADFS to Azure AD for SSO, I’ve followed the instructions in the wiki, but have had no success, can someone please give me the exact settings they’ve configured in Azure, and in the Assyst Installer to get SSO working with Entra/Azure? Obviously removing personal details, but I want to compare the setup we have with a working one. I get redirected back to assystweb or assystnet, and it states “Saml Authentication error”, but the logs in Azure state success, and I can’t find logs on the server that reflect saml failures. Thank you.
Hello, When I try to enter a broken number in the Qty per assembly field, it is not accepting rounded numbers.In the example, I try to enter a value of 2.8 kg, when I press the tab key it automatically changes to 28 kg, ignoring the decimal place.Has anyone seen this before?
Hi, I'm using IFS Cloud version 22.2.2.Does anyone use the capabilities of IFS for data exchange using HTTP SOAP or HTTP REST?I received a communication certificate from the service provider, which allows me to access their service. I installed the certificate in Windows as Personal. With the certificate, I can open the service page (fictional address) https://connect.xxxxxx.com/xxxx-cdc/cdc00101?wsdl with the service directory. The page doesn't open without the certificate. I'm doing the same in IFS. I defined the Routing address as REST with the endpoint https://connect.xxxxxx.com/xxxx-cdc/cdc00101?wsdl. I pasted the key into the Keystore. I placed a reference to the key in the Additional Headers of the Routing address. ssl:KeyStoreId = xxxxxxx and ssl:KeyStorePwd = xxxxxxxx. The key's password is the same as the Keystore's. Authentication Method: None. (Other Routing addresses with a REST definition pointing to the https page are working, and the page data is displayed.)The service
Has anyone dealt with this error “The Inventory Transaction Cost already exists” ?We have seen this pop-up when trying to produce a part (production schedule receipt) in IFS Cloud. The transaction fails to execute (produce the FG part).We’re on AST2 (testing) of IFS Cloud 24R1 and scheduled to go-live in about 5 weeks.We have made this exact same test in Apps8 (our current production environment) and do not have this error message.
Hello Community,We are currently working with IFS Cloud 24R2 and are trying to configure a navigation URL for a lobby element. Specifically, we would like to pass multiple values (an array of values) to a page parameter.Our current use case involves navigating to the following URL:page/SvcschScheduledWorkTasks/List?$filter= startswith(tolower(ResourceId),$[Employee ID])This works fine when passing a single value for the Employee ID parameter. However, we need to pass multiple values (an array of Employee IDs) and are looking for a way to achieve this within the navigation URL.Is there a supported way in IFS Cloud to pass multiple values for the same parameter in such scenarios? Any guidance or best practices would be greatly appreciated.Thank you in advance!
Hello All,In the purchase order (PO) process, we perform an approval workflow and then release the PO. However, when a change order is created later, if the price or quantity is reduced—or if both remain the same as in the original PO—then the change order should not require re-approval. In such cases, we should be able to release the change order directly and update the purchase order accordingly.Could you please guide me on what system setup is required to enable this process, and from which screen these configurations can be made? Your help is much appreciated.Thank you.
Hi Currently working in IFS Cloud 24R2Currently the Refill All Putaway Zones report doesn’t error when there is no stock and no transport task is created. I know there has been talk in the communcity and funcationality has changed to allow for shipment orders.However, if we would like to use transport tasks, (for the simplicity, different users of create and execute and also the drop off location funcationality), is there any further update / or plan to include an error for this background job? Or has anyone managed this another way? We need the ability to manage the execution of the transport tasks via the mobile app Scan It Many thanksMaria
Hi Team, I have a Customer that is replenishing Remote Warehouses with Shipment Orders. IPAP is showing an offsetting Supply and Demand, as shown below. Ideally, we would like to run MRP and then see a Shop Order/Purchase Order created, but MRP is not creating any supply. How do you make a Remote WH create Demand on the Site that MRP can see??Notice below, the Shipment Order Demand of “15”, The Available and On Hand Qty is “0”, ideally this would create a Shop Req.
We have tested creating 1 Invoice for multiple Work Tasks (Reported) and it works.If we create 2x Service Quotation->Work Order->Work Task, set it to Reported and try and create Generate Invoice Preview, we get an error “No Invoice Preview(s) created for given criteria.” Although when creating separate Invoice Preview from Conclude Work Order for these 2 Work tasks, the individual invoice Previews are created.Is it that Generate Invoice Preview does not work for Works that come from Service Quote? Or is it that there might be a setting missing to allow this?This would be a critical win for one of our customers if it would work.Any suggestions are welcome and much appreciated.Thanks,Rita
We have an issue where a shop order with an outside operation has a requisition that has been converted to a purchase order BUT the PO has been cancelled. Even though the PO is cancelled, IFS won’t generate another requisition for this outside operation step. Ship WIP to Supplier is Visible because we’ve reversed the Ship WIP. Purchase requisition is still the cancelled PO.Line in status “PO Created”PO CancelledMRP won't generate another requisition for this order. I just ran it and did a search for my order ref 1 and this is the only requisition that shows up. The only way I can see to fix this is to uncancel the order in the DB.
Hi Experts,In ‘Installed app details’ there are two Felds(non editable) available as per screen shot below. Tool tip description are also available. Could not find any details in tech docs as well. Can someone please shed some light on these two fields and explain its use case?.Thank you,Roshan
I have used the Absence section to view absences within a rang, but employees that have overlapping dates will not be shown. Example, if an employee (Barry) is off from the 26th of April to the 7th of June, if I run a report in May for employees that are absent in May, Barry will not be shown as their absence started in April and ends in June. Is there a way to see Absences for employees that are absent for today (the day the request was ran) or absent in the region that I selected (regardless of their start date but the fact that they have a absence in that period)?
When we have a lot shop order pick lists to do picking and delivery of material to shop floor, we were used to prioritize shop order picking to warehouse using column “Operation Start Date” from “Shop Order Pick Lists” page in Apps 10, since we reserve and create shop order picking list by operations to deliver material to shop floor in same order that our processes need to be assembled. For instance.Operation 100 Shop Order Start Date 2025-05-02Operation 110 Shop Order Start Date 2025-05-15Operation 120 Shop Order Start Date 2025-05-30But since we moved it to IFS Cloud, that column is missing. Is there any other way to warehouse staff can prioritize shop order picking sorting by oldest to newest Operation Start Date in IFS Cloud to support and see where to focus?If not, it would be great have that column “Operation Start Date” back to IFS Cloud. We really appreciate your inputs.
Hi, I am exploring the possibilties in Business Reporter to get a view on how a project forecast is spread per year and month (preferably by sub project and activity too). I’ve trying to get these values by using the datasources that are available, but can’t seem to get the desired result.Does anyone has experience with this, and point me in the right direction? (I’m using product version 22.1.1)
Hi Team, We are using RAC in IFS Cloud 24R1.What is the connection string format to be used for failover in yaml file?
Is there any company in Europe that actually use IFS Business Planning? I work with a company that wants to implement it, but they want contact with an IFS customer that use IFS Business Planning.
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.