Q&A Discussion of IFS Solutions for our IFS Employees, Partners and Customers
Recently active
In product update “24R2 - News in Supply Chain” it says that is possible to load handling units with non-inventory parts. But I just can’t figure out how i can connect a non-inventory part from a shipment to a handling unit. Can anyone help?
Hello,After migration from 21R2 to 23R1, following issue encountered :Solution Manager\Configuration\Page Configurations→ exists some rows with Baseline status = Rebate RMB on row : “Open Designer”→ error message “Client error : Sorry, there was an unexpected application error.”Error stack:Reducer action failed (METADATA_SET_DATA)TypeError: Cannot read properties of undefined (reading 'content') at https://.../main/ifsapplications/web/main… at Array.forEach (<anonymous>)Same message when trying to access Page Designer from related window.Page configuration done in 21R2 (before migration) : screen = PurchaseRequisitionModified elements = Lists Requisition Line Nopart List Requisition Line Part ListModification done in each List Content :added some custom fields some (standard) fields setted to “Required”Is this a bug ?Is there a way to remove this error ?Thanks best regards Jean-Luc
Hi, I’m running 25R1 and getting an error message when trying to add a material line on a Request Work Task with the Supply Code Project Inventory - it seems to be doing a check for a Work Order - which is wrong because there is no Work Order in NGSM - is this a known bug?
Hello, I'm running into an issue when previewing a layout in Report Designer. I'm using version 200.2.0000 of report designer, but also tried a few older versions. When I connect to our customer IFS Cloud environment and develop or load an existing layout I cannot use the online preview functionality from the server. It says the PDF is rendering but then nothing happens. When I preview the layout using a local stored .XML file it is working just fine. Does anyone have an idea what might cause this issue?
We have some problem in Docman and code behind it is in Java.Where can I find the actual message that was created during runtime?Where are these logs?Is anything to be enabled regarded logging in order to see this? It is 24.1.4, Remote deployment.
In a MRO Shop order, we define the quantity of a material demand in the “Qty Per Assembly’ field. when we try to reserve the material , the system allows to reserve more than the qty mentioned in the Qty per Assembly field. at this moment system only throws an information message. after the first issuance of material, system allows to directly issue any quantity of material ( based on the availability in inventory ) to the shop order. at this point of time, system doesn't throw any error. Is there any way to configure the system to stop this behaviour such as site level setting to control it for MRO flow.As my understanding this is a standard functionality required for Batch Process Manufacturing. Any insight would be appreciated.
Hi IFS community/MRO specialists,In IFSAPP 10,MRO work scope is released, MRO interim order released, and disassembly work orders are automatically disassembled.MRO assembly orders are not reserved or started, if assembly routing revision changes for the assembly part and relevant maintenance level routing is updated and activated.How can the current routing revision (phased in and old revision phased out) to be updated in existing MRO assembly shop order?I have tried re-releasing of define work scope and recalculating the maintenance levels, but the routing revision did not get updated.
Hi, I am trying to post Json data to a Rest web service. I couldn’t send the Bearer authorization token to the routing address. I set Authentication Method as None on the Routing Address. I sent the authorization token by a header parameter. However, the header parameter is not seen on the Application Message. Then, the response message returned the “401: Unauthorized access” message. What is the problem? Routing AddressApplication Message The ScriptDECLARE access_token_ VARCHAR2(5000) := ifsapp.sfn_bt_variable_api.get_degisken_degeri('MEDITEK_WS_TOKEN'); options_ VARCHAR2(5000); bxml_ CLOB;BEGIN options_ := 'Authorization: Bearer ' || access_token_; dbms_output.put_line(options_); bxml_ := '{ "TCKIMLIKNO": "12345678910", "ADI": "HASAN HÜSEYİN", "SOYADI": "YÜCEL PLSQL", "CINSIYETI": "ERKEK", "DOGUMTARIHI": "2000-01-21T00:00", "DOGUMYERI": "KOCASINAN", "MEDENIHALI": "BEKAR", "KANGRUBU": "ZZRH+", "OGRENIMDURUMU": "LISANS", "I
Hi,We’ve been having problems recently with the IFS PrintAgent, which is perplexing and causing us operational issues as we need a reliable print service to run some of our Depot operations. The behaviour we are seeing is that the PrintAgent will periodically crash. When we see the crash, we normally have this error in the PrintAgent log (sometimes there is no error logged):[016] 30/05/2025 06:25:54: Error: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.Any print jobs that were submitted at the time of the error get stuck in “Remote Working” state, and have to be restarted.We see the following Windows Event log error at the same time as the crash events:Faulting application name: IFSPrintAgent.exe, version: 1.0.3.0, time stamp: 0x609183ecFaulting module name: ntdll.dll, version: 10.0.17763.7240, time stamp: 0xd2a47020Exception code: 0xc0000374Fault offset: 0x00000000000fb199Faulting process id: 0x2a20Faulting application start time
Is there a way to change the session expiration value in 24R2? In 24R2, the default is 1800 seconds (30 minutes). This is incredibly frustrating and far too short.
Hello IFS community,I dont see the difference between tardy orders and passed due orders in MSO. (illustation attached)I looked at the start, finish and need dates but i dont see a logical conclusion.Can someone help me pleaseThanks in advance
I have 3 Preventative Maintenance Actions on one object. On a new measurement the Plans have gone out of sync. 1 PM action shows the correct latest reading, 2400hrs. The other 2 have the previous reading 2100hrs. I tried regenerating the PM plans from all 3 PM and they remain out of sync. What causes the Out of Sync condition and how can this be fixed?
Hi guys, Is there a way of change the promise delivery date for all lines at once? For example, when we update the WANTED DELIVERY DATE on CUSTOMER ORDER, it ask us if we want to change all CUSTOMER ORDER LINE WANTED DELIVERY DATE.Thanks, Gianni Neves
This is an interesting one, and I’m curious if anyone else is experiencing something similar. For reference, we're on IFS Apps 10 UPD17.We run the daily aggregation job just after midnight. A couple of years ago, it would finish before 9 a.m. By last year, it was running until 11 a.m., and this year it's progressively pushed out to around 2 p.m.Perhaps it's just how the algorithm scales with data volume, but has anyone else seen this kind of trend? If so, how did you address or resolve it?
Is anyone experiencing problems saving shortcuts in project time posting after the 24R2 update in cloud? Our user saves the shortcut, but it disappears the next day.
Receiving below error msgCode string combination "740100/701000/-/R001/P000154.01/PT02/-/C999/-/-/-/" is not included in any one of the allowed combination rules for user group in company B022. ORA-20110: CustomerOrderInvItem. AccountingCodestrComb.INVCOMB2
In IFS Cloud 23R2, I created a fixed asset and posted an acquisition value using the Acquisition Value Adjustment per Book screen. The transaction posted successfully, a voucher was created, and the accounting period is open. The asset has a depreciation method assigned with start year and period entered.When I attempt to run a depreciation proposal for this asset and period, I receive the error:“Not possible to post an empty depreciation proposal”I need help identifying what is preventing the system from calculating depreciation.
Hello,I have a question about sold fixed assets and the FA balances analysis.We sold a fixed asset on February 21st, as you can see in the screenshot below.This fixed asset can be found in the balance for Period 1 (the period before the sale) with the status "Sold."However, when I try to obtain a balance for Period 2, I cannot find this sold fixed asset.I have noticed that this problem occurs for all fixed assets.The accountants need a report of fixed assets to compare it to the balance sheet, which we cannot obtain at the moment.Is there a way to set up this screen to include all fixed assets with all statuses?Best regards.
Hi, Please help me understand why the system is behaving like this. Raise a No Part Material Line on a Released Request Task: Quantities: I process the Pur Req and Release it and then convert it into a Purchase Order.Purchase Order is Released and Receipt command was actioned against the No Part Purchase Order Line - Closing the Purchase Order. As below: However, back on the Request Task Material Tab: my Consumed Quantity is now sitting at 1 and i also have the command button available to Issue Manually. See below: When clicking on the Issue Manually button I can see that there’s “1 Item Remaining” I can’t issue because it’s a No Part. I click OK after this (nothing happens)I try to Close the Material Line but I’m met with a warning message re. not having issued the required materials. There’s nothing to issue with a No Part Purchase so why is this warning message appearing when I’m trying to close the Line? ThanksTom
We are using App 9 with Avalara AvaTax connector for tax calculation. Florida has a discretionary surtax rule, where they have a cap of $5000 for county tax. This applies to the most Florida counties. The problem we are facing is the customer order tax amount is inaccurate, but the associated customer invoice has the correct tax amount. This is caused by the way IFS is sending the data to AvaTax.That is:Customer order sends each line item to be calculated.As for FL discretionary tax, any amount over $5000 is exempt from the county tax.For instance, when a line item amount is over $5000, the correct tax amount is calculated. Majority of line items are under $5000, so the sum of the tax on the customer order is inaccurate.Whereas the customer invoice tax amount is calculated with total net amount, instead of each line item. Therefore, it is creating a discrepancy between the customer order amount and the customer invoice amount. Has anyone experienced the same issue, and did you find an
hi,I’m implementing customer schedules routine in a customer, we’ll use DELSCH message to receive it.does anybody knows where can I find a XML example file for DELSCH ? i was able to have a XML file/example in version 10, at this place here: thanks,
Hi,We have several people can modify the configurations and implement new UI or workflow. But here is one issue about merge the change. How to make sure one person publishes his new change (From ACP, e.g. Developed from dev environment and imported to test environment) won’t affect the other changes which were published in test environment already? There are several scenarios.A changes CO page in test environment and B imported CO from an Application Configuration Package. After B imported CO page, then C wanted to import his change using another ACP.We tried this, sometimes the changes got lost by over written. So we would like to know a good way to mantain the page configurations.
Hi Everyone, We have noticed the recently created KB article from IFS (KB0085167) state that the Removal of Basic Auth Support by Microsoft on Exchange Online.This states "If you are using the Basic Authentication to connect IFS Connect Mail Sender or Mail Reader to Exchange Online, these connections will stop working in September 2025" and the fixed UPD29 will be released in August.Practically, this time period would not be sufficient to build and install UPD29 by September.When we checked the provided link to Microsoft Tech community it states that the change would be starting from 1st of March 2026.https://techcommunity.microsoft.com/blog/exchange/exchange-online-to-retire-basic-auth-for-client-submission-smtp-auth/4114750Quoted from the MS link:We will be making this change beginning March 1st 2026 and completing April 30th 2026, (previously September 2025). Is there any new updates for the planned date for this Basuc Auth support removal according to IFS?
Can I get the IFS IOT based EAM with FSM & PSO solution - KPI, Out-of-Box Dashboard & Reports. It will be great help if the solution - KPI, Out-of-Box Dashboard & Reports will be specific to Mining Industry
I’m trying to determine how to set up the discretionary sales surtax, as we have customers located in Florida. Most of these customers are also subject to a surtax cap, which typically applies only to the first $5,000 of the taxable amount. Each county has a different surtax rate and cap as well. Any guidance on this topic?
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.