Q&A Discussion of IFS Solutions for our IFS Employees, Partners and Customers
Recently active
When attempting to run APB, the application crashes. Administrative assistance has already been taken.Kindly see the attached imagesSteps:1. Navigate to APB > ok2. open window3. APB crashes Has anyone else experienced this issue?If so, could you please advise on the possible cause and the next steps to resolve it? Prabashwari
Hi,We are trying to figure out how to go about batch sending ‘E-Invoices’ from IFS (24r2). Below are the steps we currently have setup:Create customer invoice for customer setup with E-Invoicing. Run ‘Batch Print Customer Invoices’ job and selecting the ‘Print/Send’ option. After running this, the E-Invoice is sent and invoice remains in a ‘Preliminary’ status. If we run the ‘’Batch Print Customer Invoices’ job again, the E-Invoices that have already been sent, are updated to a ‘Posted Auth’ status. This doesn’t make sense as the E-Invoices have yet to be accepted or rejected by the Authorizer we sent these to.Does anyone know how to set this up so that the only way E-Invoices are ‘Posted’ is if the E-Invoice is accepted? Also, are there things that can be done to prevent E-Invoices from ‘Posting’ E-Invoices that have not been accepted? Thanks for the help,Kevin
Hi all,Is there any way to add ASSOCATION_NO field to Supplier Search Box referred to Manual Supplier Invoice?
We are trying to migrate Approved suppliers but the default status after the data migrated is set to not approved , I am trying to change the status to “ Approved “ using the below method name but getting the error saying this list doesn’t exist ,is there a source to show valid “method name” for API’s please to make this sort of changes
Hello,I am trying to create a WORKING_TIME rule in PSO Standalone (version 6.16) that limits the maximum working time within a specific reference period.To do this, I have defined the following elements in my XML:<DsModelling xmlns="http://360Scheduling.com/Schema/DsModelling.xsd"> <RAM_Rule_Type_Parameter> <parameter_id>MaximumTotalWorkingTime</parameter_id> <ram_rule_type_id>WORKING_TIME</ram_rule_type_id> <ram_data_type_id>TIMESPAN</ram_data_type_id> <default_value>PT8H30M</default_value> </RAM_Rule_Type_Parameter> <RAM_Rule_Type_Parameter> <parameter_id>ReferencePeriod</parameter_id> <ram_rule_type_id>WORKING_TIME</ram_rule_type_id> <ram_data_type_id>TIMESPAN</ram_data_type_id> <default_value>PT8H30M</default_value> </RAM_Rule_Type_Parameter> <RAM_Rule> <ram_rule_type_id&g
Hello Everyone, we want to change the order of list elements on the page PartCost.client These list elements are inside of a tab. I already learned that i can not do an Overtake like in the PL/SQL files. So i tried it this way: But the result was, that the tab was now duplicated in the Client on with the original order and one with my custom order. Is it even possible to change the order without using the PageDesigner? Greetings Daniel
Hi, About this functionality:https://docs.ifs.com/ifsclouddocs/24r1/lang/en/default.htm?openpage=https://docs.ifs.com/ifsclouddocs/24r1/lang/en/Manufacturing/ActivityUpdateStructRevAndAlt.htm When doing so, at least by default it doesn’t leave any trace in the shop order history. Can this be changed from settings, so that it would show what has been added/removed, or at least leave a record that this action has been run? Thanks alreadyVille
Hello,If I create a button in a Request order in cloud itself an it opens google and searches for the customer name. Example:https://www.google.com/search?q=${CustomerId} But, when I try to add a ExternalNavigationLink in the “Apps for Page Designer” page to add a Button in MWO that in this case searches the LocationName in google I get a Null value as result. I tried it with different ${values} but without succes. Does someone have an idea why this is happening ? (pictures below) The final idea is to create a button in mobile to that navigates to a sharepoint website and get directly to the customer folder. So if the LocationName = Customer1 on the worktask they can press the button and go to Sharepoint.com/Customer1 Many thanks in advance ! Versions tested in 25R1 and 25R2EA ${LocationName}https://www.google.com/search?q=${LocationName}https://www.google.com/search?q=Null
Hello, I want to insert new part_no in view ENG_PART_REVISION through excel data migration, but it retrieves error: ORA-20111: EngPartMaster.FND_RECORD_NOT_EXIST: The Engineering Part Master does not exist. How can I solve it?
What is the real world use of price Break? Give me a real world example .
As part of the Supply Chain Management – Sales Order virtual blended academy course, I would like to know where I can find the complete Sales Order document flow for better understanding. I also want to practice the full process in the IFS Cloud demo environment.Could anyone guide me to the correct resources or documentation?
I'd like to know how to register new customer order headers and line items in the same migration job.I have tried this and confirmed that adding CUSTOMER_ORDER and CUSTOMER_ORDER_LINE to the "Method List" tab allows me to update them all at once. However, when I try to insert both the header and line items, I get the error "DEVELOPER_ERROR_03: Most likely a usage definition is wrongly defined for LU: [CustomerOrder] in table RM_ACC_USAGE_TAB, internal exception: [Ex_Get_Id]."
Hello Everybody, we are trying to run a fairly simple Mig Job, we are getting the following error message Start time - 24-OCT-2025 09:26:59 HFI_ENG_PART_ACTIVEError in select - ORA-01445: cannot select ROWID from, or sample, a join view without a key-preserved table End time - 24-OCT-2025 09:27:00 HFI_ENG_PART_ACTIVE Here is the Query we are running: SELECT OBJID, OBJVERSION, 'DO', ROWID FROM ENG_PART_REVISION_REFERENCE WHERE State='Preliminary' ORA-01445: cannot select ROWID from, or sample, a join view without a key-preserved tableLength of statement : 121 characters Here below you will find a few screenshots of the Job itself, im fairly new at Mig Jobs and overall IFS, i have not been able to figure this out out. any help would be appreciated.
We are working on the IFS Cloud Service Order Management (Virtual Blended Course) and, since we don't know the version of IFS Cloud being used, could someone please tell us which version is shown in the videos?
Hello,is there an integrated mail client in IFS Cloud CRM or do I have to sent out emails with outlook planel?
Hello,I'm trying to create a workflow to add a Document Text to a shipment. The process works in Postman but fails to have the desired effect when used in the workflow, despite no errors occurring during debugging.Workflow Steps Get shipment data Retrieve ShipmentId and NoteId. Create a NoteText POST to:XXX.de/main/ifsapplications/projection/v1/ShipmentHandling.svc/NoteTexts → This returns an objkey. Create DetailNote using objkey POST to:XXX.de/main/ifsapplications/projection/v1/ShipmentHandling.svc/NoteTexts(Objkey='43C5E76DC0AF433FE0632A81A8C0B66A')/DetailNotes Payload: { "OutputType": "FUSS", "NoteId": 33593601, "NoteText": "It is a Text" } ProblemThe workflow runs without any error, but no document text appears in the shipment.Interestingly, if I manually create a document text with the same OutputType, I get a message in the debugger that a document text already exists. This suggests the request is targeting the right resource, but the document text isn’t being created as ex
Hi, We are on Cloud 25.1.5. Getting the below when changing the wanted del date of the customer order line (bring it forward by 3 days). This part is set up for MRP spare part forecast. I can set the Wanted date after 27/11 but not before (sales qty =1). But as you can see from inventory availability planning, there is plenty of stock on hand for any date. Why is it fussing about the forecast not being sufficient? Thank you in advance.
We have an issue with inbound messages failing due to bad timing. We need to set an automatic retry on a failed inbound message just as the Outbound, but I am not finding that config setting.
We upgraded from 24.1.9 to 25.1.3 and have noticed that you can only have 5 opened tabs at the same time in IFS.If you open a 6th tab, then all tabs stops working until you close one of them.Where is this controlled? Is this a hardcoded limitation or possible to override somewhere?I can’t find any information about this in the news documentation for 24.2 and 25.1.
Hi guys, I would like to understand how the SU and GA versions works. So the specific question is: When I have for example 25R1, is it coming with all fixes release before this version? And the SU, if I install SU1 and SU3, Will I lose the fixes from SU2?Thanks,Gianni Neves
In IFS Cloud 24R1, we want to restrict an HR folder in Document Management so that only certain users can access it.What is the correct way to set this up? For example, we have a few departments in the folder structure, and each folder should only be visible to its assigned users.
Do I need a separate License for the B2B-Supplier Portal?I don’t see this permission sets.ConfirmB2bPurchaseOrder ConfirmB2bSuppConsigmnt CreateB2bOrderQuotation DisplayB2bVmi PlannedB2bPurchase
Where to get latest document for the latest application with specific version? . Some fields are not visible in the demo environment as shown in the course videos. Can you point to some resources which defines industry terminology for field service organization?
Does anyone (I am looking at @Mathias Dahl 😁 here) know whether files in the app server are deleted / cleaned up on a regular basis. The app server file path is defined under DOCUMENT_TICKET_TEMP_PATH of “document default values” Reason for questioning this is, I’ve written an event action based on PDF_REPORT_CREATED job to unpack documents connected to a Purchase Order / Line and email it as an attachment to along with the purchase order. I don’t want the system to clog up by storing temp files in the App Server.Thanks in Advance! Malik
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.