Q&A Discussion of IFS Solutions for our IFS Employees, Partners and Customers
Recently active
We have Java-based Print Agents on IFS Applications 9 UPD 13. When they crash, like during a Windows update, they produce files like $ROOT\agents\$ID\crash_logs\crashlog_0.csv.Is there a setting I can change somewhere to stop this from happening? End users resubmit their jobs that don't come out right away, so if a job dies, I want it to stay dead.As a workaround, we could remove the crashlog_0.csv file with a startup script, but it would be nice to avoid unnecessary complexity in our total solution.
We are migrating from APP9 to Cloud. In APP9 we use prepare work order quotation and create the work order. When these migrate to Cloud, a work order is created with an attached service quotation. Migration also creates 1 work task per tool line on tools and facilities tab and a final work task which has all planning, materials, time reports lines. When I add new planning, materials or time reports line, go to Conclude Work Order, and create invoice preview I do not see any of the new sales or cost lines in the preview. This is an issue because our process will be to transfer all cost and sales lines (they are invoiceable on work task sales tab) to the customer order eventually so they can be recognized in financials. Does anyone have suggestions? This problem doesn’t exist when I create a new work order and work task. Creation of a new work task to overcome the issue will come with a lot of additional work because those planning, time report and materials lines will be needed on the w
Hi Experts,In work task time reporting, is there a way we can round the Reproted time bases on some increment setup.Ex:Technician report 1hr and 7 Minutes but we need to charge the customer in 15Min interval. so the invoice hours should be 1hr 15 Min?If Time Increment is 30 Min then it should be rounded to the next 30 min! Ex: 2.25 hr reported then Invoice Hour should be 2.5 hr This setup is there in Customer old system but I could not find any similar function in IFS Cloud?Thank you,KM
In IFS Cloud, PL/SQL event actions ("Execute Online PLSQL Block") have a character limit. While the system allows up to 4000 characters (and this limit can be bypassed via direct edit), the effective limit for exporting Application Configuration Packages (ACPs) containing these actions is approximately 3980 characters. Exceeding this limit during ACP export results in the following error: JSON{ "error": { "code": "DATABASE_ERROR", "message": "Database error occurred. Contact administrator.", "details": [ { "code": 19202, "message": "ORA-19202: Error occurred in XML processing" } ] }} This issue is specific to ACP exports. If the event action logic is not delivered via ACPs, this character limit does not apply, as the underlying database column is a CLOB, which can handle significantly larger text blocks. Therefore, the problem only arises when exporting ACPs containing PL/SQL event actions that approa
I want to skip an error if any for single csv file row and log the error in the log file.Current behavior if an error raised from a row executing entire file is halted. There is a keyword called catch error but seems only works with test files.Is there any way to achieve this?
Hi Allcommitting activity through schedule information tab when I change the status of an activity in PSO from Allocated to Committed, the change is being made, but after a few seconds the status changes automatically to Allocated again.Has anyone encountered something like this?
Hi,I wanted to check if it's possible to uncommit bulk tasks at the PSO UI level. Could anyone please confirm?
Dear PSO Experts,We are experiencing very high values on Avg DTU percentage usage. Please see first screenshot.Yesterday the peak started at around midday and remained above 90% until the new automated load at 3:30 am today.Please see second screensthot for the current levels of exceptions. We have loaded 4,872 Activities in PSO with a dynamic window of 5D and an Appointment window of 21D. We are on PSO 6.13.Could the high levels of Exceptions have such a significant impact on the Avg DTU percentage usage?We are looking into the indexing of the database.I will appreciate any feedback from you if you have experience a similar scenario.Many thanksMiguel
Hi,Is there any page or report in IFS that shows full traceability for lot/batch-tracked parts?Our top-level part is serial tracked, and all components/subassemblies are lot/batch tracked, including raw materials. Lot/batch tracking is order-based.The main goal is to have something that shows the full path from finished goods (serial tracked) to the raw materials used (lot/batch tracked). Many thanks
How to change/edit “Send to Colleague ID” in app9
Hello,I’m trying to create an IFS Business Planning structure with multiple entities.We have numerous companies, each with different reporting currencies.I would like to create a planning unit for each company. (e.g., plan in local currency for each company, and consolidated to reporting currency USD)How do I best structure this? 1) Do I create a planning unit in each company? or2) Do I create planning units in one company and link them to the Business Plan? (But can’t import General ledger from each company)Any help is appreciated.Thank you!
Hello IFS Community, I’m running into an issue with a custom PDF_REPORT_CREATED event action that needs to use a specific sender. I’m sending the email with this procedure: COMMAND_SYS.Mail( sender_ => 'YY_MAIL_PU', from_ => 'IFS@noreply',to_list_ => to_email_, cc_list_ => to_buyer_email, subject_ => 'PO ' || order_no_, text_ => mail_body_, attachments_ => attachments_ ); When I trigger an Event Action of type E-Mail, the message sends and the specified sender is used correctly.However, when I use Execute Online SQL (calling COMMAND_SYS.Mail as above) the email fails to send with the desired sender.Any ideas why sending via COMMAND_SYS.Mail would fail or ignore the sender, while the E-Mail event action works? If there is a default sender it will user the default one but it is not the correct sender to be used. Thanks in advance!
Hello Community, I’m trying to find a solution for a “Saturday Paid Lunch” (0.5 Hr.) when the employee(s) are not present. Every Saturday, I need 0.5 Hr. of “Normal” on the Time Cards, workers or not. My solution at the moment, … I’m treating (and testing) the lunch time as PHC event, every Saturday. Is there any other way to do this without weekly “trigging” for each time card?? Thanks!Cheers, Troy
Hello.I have a dependent drop down on a field (req_type) where if a certain value is selected, it will display options. The issue is that when a French user selects a req_type, the values default to English (see below 1.0). How do I get the message translation to work in my client script? 1.0 showProgressIndicator();var reqType = getControlValue('request','req_type');var emptyOptions = [];var options = createCodeTableOption('','');arrayPush(emptyOptions, options);setControlOptions('request', 'user_def22', emptyOptions);if(reqType == 'EMERGENCY') { var opt1 = []; arrayPush(opt1, createCodeTableOption('EXPLOSION','Explosion')); arrayPush(opt1, createCodeTableOption('FIRE','Fire')); arrayPush(opt1, createCodeTableOption('LEAK','Leak')); arrayPush(opt1, createCodeTableOption('OTHER','Other')); arrayPush(opt1, createCodeTableOption('SMELL','Smell')); setControlOptions('request', 'user_def22', opt1);} else if(reqType == 'PICKUP_TANK' || reqType == 'CYL_RECERT_PU' || reqT
When scheduling report below error appears. Does anyone know which type of security permission is required? This error also appears when scheduling report via IFSAPP user. Error (ID: 315a5654-e668-4120-8f76-fff01489fdf1) while invoking opertion: Insufficient privileges to export the quick report to Excel. Caused by: ifs.fnd.base.SystemException: Insufficient privileges to export the quick report to Excel.
I added a new group to our Customer Order page by customizing the Customer Order Client through Developer Studio. After saving and deploying, the new group is now located all the way at the bottom of the page.How can I move the new group to a specific spot using Developer Studio? (it needs to be between two groups. These two groups are located in the core file)I’m guessing it’s going to be an Override but I can’t seem to find the documentation on how to rearrange a mix of custom elements and core elements on a page.
I’m trying to close out a purchase order but can’t close out two of its lines due to a quantity change. Both received lines need to be updated from a quantity of 2 to 1.Specifically: The affected purchase order lines should be changed to: Qty Required: 1 Qty Pegged: 0 Qty Issued: 1 I tried unpegging and updating the quantities, but that didn’t work. I also looked into unreceiving the items, cancelling the PO lines, re opening the requisitions, and reducing the quantity on the work task itself but this also didn’t resolve the issue.All materials for this job are on hand, but the related work order can’t be closed until the purchase order is fully closed. Has anyone run into this issue before or have suggestions for how to resolve it?
Dear All, IFS version: IFS Cloud. I have an issue with Supplier payment. The payment has been done to the supplier and it is been reconciled with Bank statement. The invoice stands Paid Posted. After about 10 days the bank informs us that the supplier payment has been failed due to their bank account closure. Upon reaching out to the supplier we were advised to pay to a different bank accuount. Now I would like to know the process of cancelling the previous payment so that my invoices status would put back to Posted Auth and repay the supplier to correct bank account. We have corrected the bank details at suppier level, now we want to proceed with repayment. Appreciate your valuble time and suggestion. Kindly note that the payment order has multiple supplier payments, we do not want to cancel the entire payment order in Mixed payment.
Hi All,My requirement is to update the total accumulated depreciation up to the cutoff date during the import process and set the cutoff date as the Thru_Date. Then, when running depreciation using the Depreciation Proposal, depreciation should be calculated correctly only for the period after the cutoff date.
No column available for ‘Unit Cost’ in Purchase Requisition lines. Version 23.2.8
Hi, When i create a Purchasing control plan with all basic data set up correctly (compared with IFS Cloud) and then create a purchase order, register this purchase order at arrival, the arrival can still be registered without filling in the mandatory control plan analysis filled in. Sample frequency trigger is: At ArrivalInspection percentage is 100%Receive case is: Receive into arrival and inspect at ArrivalControl plan is mandatory for site and part. My experience with IFS cloud is with the manufacturing control plans, where clearly an operation cannot be approved without giving in these analysis results and where the option is available (button) to fill in these results. That`s what i`m missing in Apps10 Purchasing control plans. So, 2 issues:The purchasing control plan that is mandatory can easily be ignored when registering for arrival. It can also not be added afterwards (to a separate purchase order) No clear option to fill in the control plan analysis, Or how to fill in the re
Hi Experts,Could someone help me set up the Account ID app param in FSM in a localhost environment? I currently have it set to localhost, which directs to the localhost PSO, but I’m getting the error: "Organization not recognized." What value should I use for localhost? Best Regards,Suvini
Hi community,in IFSAPP10 I am trying to create new configuration for quotation line with migration job.I checked the configuration form and found these two tables: CONFIGURATION_SPEC and CONFIG_SPEC_VALUE.I used the table CONFIG_SPEC_VALUE as many times as I have parameters in my configuration revision. I am able to create new configuration with this migration job. I can see records in both tabels with new configuration ID, but I am not able to create the record regarding the connection between the new configuration and particular "Order Quotation Line".I found table CONFIG_SPEC_USAGE where you can see the records, that connect configuration ID with another object, but I am not able to use the table/method CONFIG_SPEC_USAGE in migration job. Could anybody provide any suggestions? How to solve the connection between new configuration and other object?Thanks a lot.IFSAPP10
We’re implementing a Remote deployment of Cloud. The server requirements are very large. How would I go about deploying the Kubernetes cluster across multiple servers, not for fail-over purposes or for user-based load balancing but rather for load balancing the different pods?
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.