Q&A Discussion of IFS Solutions for our IFS Employees, Partners and Customers
Recently active
For planners and buyer/procurement teams. The inventory part availbitly planning overview, shows the status “Arrived” for materials that have been returned to the supplier.I think it should have a Status “RETWORK” like in Transcation History In this example, parts have been returned to the supplier using the following process steps. Generated a Return, by entering a “Qty to inspect” in the Receipt IFS opens the orginal Purchase Order Register Inspection Results Print a Return Note.Transaction History show the items as, RETWORKHowever for planners and buyer/procurement teams it is not clear that the parts have been returned to the supplier, even if they then check Purchase Order Lines History, is has status arrived which can then cause warehouse teams to look for the materials. I think that this will help many IFS users worldwide.
Hi All, I saw below description about shift utilization in the help documents. I created a shift utilization in the system. However, I cannot see a place connect this shift utilization to resource or related thing. Can anyone suggest how we we can use this? TIA.
Hello everyone,We’ve recently upgraded to IFS Cloud 25R1 and noticed that the API ReceiveCamtFileService used previously for importing bank statements is no longer available.Could someone please advise what is the new recommended approach for importing CAMT.053 (or similar) bank statement files in 25R1?Specifically: Which external file type or template should we use now (e.g. ExtMixedPayment, BankStatement, etc.)? Is there an out-of-the-box replacement for ReceiveCamtFileService, or do we need to set up a custom External File Template for CAMT files? Any documentation or example configuration (template name, file structure) for the new process would be greatly appreciated. Thanks in advance for your help!Best regards,
Greetings!I am in the process of adding serial numbers in the DOP Header in IFS apps 10 However, when I get down to the last 2 this error comes up I am already in DOP 14905 so I don't now why this error is coming up
Hi!I’m trying to understand the shipment process in IFS8. On the customer order, I added a package material called QW-CW-02-PKG. I reserved one of the components inside this package and then created a shipment. In the Shipment screen, I added the related customer order line to Connected Shipment Lines.What I can’t figure out is how to place the material into a specific package or pallet. In the Package Structure tab, I created a Handling Unit and a Package under it. How do I add the connected material into this package?
I cannot really find a clear simple answer as to the difference between By-Product and Disassembly Components and when to use each one. It would be helpful if there was a matrix with checkboxes on each describing what they can do. In general vocabulary terms, By-Product is usually an unitnentional secondary product where disassembly would be parts… but in IFS terms, what is the difference? Are there limitations of one vs the other? Labor / part cost differences? Other?
Hi All,Could you please confirm when the PO is with the 'Pending Changes' tag, is it allowed to proceed with the Register Arrival and do the receipt?I created a PO which is in Confirmed status and then created a Change Order, and now it is in Released status. With that open Change Order, the system allows proceeding with the PO via Register Arrival and performing the receipt.I think if there is any open Change Order available for a particular PO, then the system shouldn't allow proceeding with that PO with those pending changes. Is this the correct behavior?Or is there any basic data setup that we can use to prevent proceeding with the PO which has open Change Orders?
Hi All, I have setup a non-inventory purchase part and created a PO for it. I have included PO charges as well. When I receive the PO, I am unable to find the charge amount in INVETORY TRANSACTIONS HISTORY or Purchase Transaction History . Is this a system limitation or Posting control related Issue? ThanksKind regardsChanaka
For some parts we get error when creating transport task so it is not possible to move parts between stocks. Some parts can be added to transport task without problem but some always get this error eventhough user can see the part at his stock and the quantity is even shows in the transport task form.Does someone have any idea what could cause this issue? Error message: Failed to read expression value from PartInStock.QtyAvailable
Hello,In production processes, after 5-6 operations, the finished product is produced. Depending on the company's requirements, each operation is managed as a new repair work order in IFS setups. The manufacturing material number does not change. In these production runs, the materials to be produced are tracked manually based on the assigned lot. This lot number remains the same throughout product production. In most cases, after a shop order has been partially received based on the lot size (the shop order has not been closed), production is attempted with the same lot number on a new shop order. In this case, while reserving a lot in IFS, a history record associated with the lot exists in another shop order, or when receiving it for production, but you cannot perform any operations, I receive errors. How can I provide a solution? Best Regards,
Hello, For a shop order with an outside operation, when it is released, a PR/PO is created! For a reason, the purchasing team delayed the receipt date on PO or the supplier confirmed a different delivery date. I have done some tests and the modification on PO have no impact on shop order scheduling. It does not modify Start/finish date of the following operations. Do you have an idea about please? and is there a solution? thanks
HiI recently started with the course “IFS Cloud - Human Capital Management - Employee & Organization Management (Virtual Blended Course)”, ID: SOCLDBEOM202303I completed the course, but without training in the specific environment for it. So now that I got access to the environment, I can’t seem to re-launch the learning videos anymore.For context: Registered for the course on 29/10/2025, finished the course on 30/10/2025. Normally the videos should stay available for 1 month isn’t it? As you can see below, there doesn’t seem to be the option to re-launch any of the videos. Does anyone know what’s wrong? Any help is welcome.
Once a PO is released and we want to add another PR using purchase order change order, even though PR is connected to a project, it’s giving error that line needs to be connected to projects and in POCo there is no project number, there is sub project etc. in iFS. What could be the issue. Original PO is connected to the same project as is in the PR that we using to o do POCO.
Hello,I’m on ifs cloud 24R1 environnement.I’m working on unballasting automatization flow and I use workflow BPA for this.In the flow, I have at some point the need to close a price line from the supplier for purchase part entityI checked the network logs (chrome inspector) to see what the close button call : So it call a function named PurchaseQuantityPrice_CancelWhen I check the documentation of the projection SupplierForPurchasePartHandling I can not find the function.But I can use it into my API Call in the workflow : I set the parameters I found in the URL Call, but it doesn’t work, I got the following error : Projection call with name PurchaseQuantityPrice_Cancel does not have the expected parameters. I Activated the “log errors” option into the API Call, but as you can see on the screenshot above, there is no eyes after the call in error, the log error option doesn’t seems to work.It’s the first time I see this behaviour, I don’t know how to set parameters as there is no docu
https://docs.ifs.com/techdocs/25r2/060_development/027_base_server_dev/225_reduced_downtime_delivery/#pipeline_improvements1.Are the only code changes that Uptime Maximizer customers need to make the code changes to the INS file, as described at the following URL?https://docs.ifs.com/techdocs/25r2/060_development/027_base_server_dev/225_reduced_downtime_delivery/020_code_changes/020_uptime_changes/#additional_code_changes_for_uptime_maximizer_customers2.The installation process will likely differ depending on whether or not you use Uptime Maximizer. Are there any additional steps involved during installation, and could you please provide specific instructions?3.When applying 25R2, is it acceptable to simultaneously correct the customizations present in Customer Solution and the upgrades required for Uptime Maximizer support, and then perform a sanity build?4.Regarding the changes in handling background jobs, do we need to make any changes to our customer's source code?https://docs.ifs.
Hi experts, Update 11 installation has partly failed with below _deploy errors. Framework: CINT :Error : Method, added or modified before this refresh, ignored as package name is longer than the allowed limit in the IFS Dictionary. Maximum allowed is 30 characters.Framework: Lu Name=CReceiveQuotationActionUtil,Framework: Package Name=C_RECEIVE_QUOTATION_ACTION_UTIL_API,Framework: Method Name=Init ----- ERROR!!! ------ Framework: The following database objects are longer than the allowed length (30 chars).Framework: Included are also objects detected as added or modified before this refresh.Framework: This can cause the Dictionary cache refresh to fail.Framework: Correct the following and refresh dictionary again. This C_RECEIVE_QUOTATION_ACTION_UTIL_API package name contains more than 30 characters.Could you please let me know whether is it possible to ignore this as generic error or how to extend this IFS Dictionary package name limit?
Hi,I am trying to import the Service Resources (SERVICE_RESOURCE_DETAIL) through Migration Jobs, Import working successfully, but I am unable to see the resources in the Service Resource Details screen and PSO but the resources are available in Resource Details?Any idea what needs to checked?Thanks in advance!!
Hi everyone,I’m facing an issue while Creating a new item in ProjectSetupParametersHandling/Projects/ProjectRoleAssignmentArray via an IFS API call in a workflow. The request fails with the following error message:"Failed to create the entity as it would be unreachable from the current path.” Workflow looks like this:There is also strange error when I don’t provide AssignSeqNo variable:“Please add value for key AssignSeqNo of nested entity ProjectRoleAssignmentArray.”Shouldn't it create this ID automatically? What am I missing?
Hi all,Do you use Employee Selection Groups ?How to update the employees assigned to them ?It is possible to create Employee Selection Groups on the page: /main/ifsapplications/web/page/EmployeeSelectionGroup/List;path=0.985058153.1320681539.1213741080.78114610.836883027.277183867It is possible to assign an employee to an Employee Selection Group when creating the employee.The Employee Selection Groups can be used in the filters on the HR projections.But, it's impossible to assign an existing employee to an Employee Selection Group.Just as it's impossible to modify the employees assigned to an Employee Selection Group.Which projection allows modifying the employees assigned to Employee Selection Groups?Which view accessible via DataMig contains this information?Regards,Mickaël
Hello,I’ve created a Migration job for importing new service resources in Cloud. By baseline, while creating a New Service Resource, it automatically creates a Maintenance Employee record and assigns it to the Service Resource created.But while creating a Migration job, the Maintenance Employee record is not created. Also the Resource Connection with the Company and Site are not setup properly.Below is the Method List used to create Service Resources and Connections. What could be the possible reasons? Any inputs would be appreciated.Kind RegardsPriyanka Cecilia
I'd like to know how to register new customer order headers and line items in the same migration job.I have tried this and confirmed that adding CUSTOMER_ORDER and CUSTOMER_ORDER_LINE to the "Method List" tab allows me to update them all at once. However, when I try to insert both the header and line items, I get the error "DEVELOPER_ERROR_03: Most likely a usage definition is wrongly defined for LU: [CustomerOrder] in table RM_ACC_USAGE_TAB, internal exception: [Ex_Get_Id]."
I am looking for a way to update Safety Stock, Planner, or any parameters in the inventory part screen. I would like to enter these changes in Excel and mass upload them to IFS 7.5 for now. We migrating to the cloud in January but, I would like to make this mass change in IFS 7.5 for now. Thanks in advance.
Hello there!I have been struggling with this problem in the past few days. While creating a quick search group (table ps_quick_search), I am able to create it but this message keeps showing up in the Web Client.Through investigation, I believe it is because only 3 of 6 required fields are sent to the data base but as this is OOTB thing, I don’t know how to change it. The problem is this only happens for a certain role because if I perform this action with others, the message doesn’t show up.I have also performed the test with two versions of the same screen (same role for both) and for one of them the message doesn’t show up, so I don’t believe it is a role problem.Has this happened to anyone?
I want to know how to get the Sales Price List by API. When registering a Customer Orders in the migration job, I want to use the API to retrieve the sales price from the sales price list. Because the migration job does not appear to be referencing the sales price list.
Hi,I have created a custom field in IFSAPP10 but it is not displayed in IFS Report Designer.Enabled On Reports tick box is ticked as well. Can anyone help me to get the custom field to the IFS Report Designer.
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.