Solved

Numeric keypad dot interpreted as comma

  • 26 May 2020
  • 6 replies
  • 8776 views

Userlevel 1
Badge +2

When entering text fields (like Part numbers) using the numeric keypad, the dot is shown as a comma. The regional and keyboard settings in Windows are set to keyboard layout en-US, which in every other application results in a dot. 

Changing regional settings or numeric format in the IFS options gives no result. 

Is there a way to influence the behavior of this? 

icon

Best answer by brammarissink 2 July 2020, 13:28

View original

6 replies

Userlevel 6
Badge +14

You mentioned that ‘changing regional settings’ in IFS resulted in no change, but can you confirm if that included changing the User’s default language, then logging off/on and retesting as that user?  I’m not sure if this is what you tried already - perhaps you have, but maybe this will help.

Just a thought...

Nick

Userlevel 1
Badge +2

Hi @NickPorter , thanks for replying.

We set in IFS the Regional settings Language to English, IFS Currency Format to 0.00 (tried several options) and restarted IFS after every change. 

Windows settings have been set to default keyboard layout nl-US(international). Regional settings are set to Dutch. And, of course, restarted Windows several times. 

I think this is an IFS issue, because every other application shows a dot. 

Reinier

Badge +1

Hi Renier,
The behavior of what is shown when you use dot key at numeric keypad in IFS is like how it behaves in Excel. It is following the decimal symbol setting at Regional Setting (Windows Control Panel). Have you tested this as well?
I believe if you are using Region Format Dutch (Netherlands) then it will use comma as decimal separator, that's why it is showing comma instead of dot.

/Togar

Userlevel 1
Badge +2

Hi Togar,

You are right that Excel is also following the Regional Settings.
Other applications, like Microsoft (!) Word however show a dot when using the numeric keypad.

It seems that other systems like our former Baan ERP, and even webpages, show a behavior depending on the type of field the numeric dot is used in. In an alphanumeric field, a dot is shown, and in a numeric field it is showing the decimal sign as defined in the Regional Settings. 

So the question remains whether there is a workaround for this. 

Reinier

Userlevel 1
Badge +4

Hi Togar,

 

We also have the same problem. Is there already a workaround known for this problem?

 

Bram

Userlevel 1
Badge +4

Hi Togar,

 

We also have the same problem. Is there already a workaround known for this problem?

 

Bram

Just found a workaround. https://superuser.com/questions/747250/dot-instead-of-comma-on-numerical-keyboard

Reply