ESRI integration | IFS Community
Question

ESRI integration


Userlevel 2
Badge +6

Hi Community,

Our customer need to connect ESRI Arcgis with IFS 21R2 (Manager Cloud).

Do you have informations about how to do technical connection between IFS and ESRI ?

Do you have informations about functionnalities ?

Do we need specifics ESRI version ?

 

Best Regards,

Christophe


29 replies

Userlevel 6
Badge +11

@Christophe BUSSI 

 

Can you check the below link if this provided any guidance.

https://docs.ifs.com/ifsclouddocs/21r1/ProcessModels/Process_Model/GISMapObjectConnection.htm

Badge +1

Hi @Mathias Dahl, can you confirm that ESRI integration works properly with IFS cloud on Managed cloud ? Maybe you can share with @Christophe BUSSI documentation on how to do the setup ? 

Thanks in advance. 

Regards.
Sebastien 

Userlevel 7
Badge +17

> Hi @Mathias Dahl, can you confirm that ESRI integration works properly with IFS cloud on Managed cloud ?

I can confirm that it works. That being said, how do you define "properly"? We would need to know more about what the customer wants, how they want to use GIS, etc. 

Does the customer use ArcGIS from before? If yes, then they probably have people that knows a lot about it, and they will be a good resource for you. If not, you need to be prepared to learn some ArcGIS in the implementation team. And there is no way around that. It’s not hard, but you cannot just guess how it works.

> Maybe you can share with @Christophe BUSSI documentation on how to do the setup ?

Sahan already linked to a good entry point above. From that page you can access very detailed information on the various concepts of the GIS integration. I would recommend that you read through all of it, but especially "GIS Concepts" which is linked from the page.

There are a number of ongoing GIS implementations, do you know about them? I would recommend you reach out to the people working with them as well as reading the documentation, for knowledge sharing. I’ll ping some people I know has worked or is working with the GIS integration here:

@Sean Ingram @Frank Sveen @dadude @sajithmendis @Kulunu Abeysinghe 

Good luck!

 

Userlevel 7
Badge +17

PS. Apart from this forum, there is also an internal Workplace group about GIS: https://oneifs.workplace.com/groups/gismapsbim 

It does not help Christophe, of course, but it's a place where you can discuss with other people who knows GIS at IFS.

 

Badge +1

Many Thanks @Mathias Dahl for your support. @Christophe BUSSI can you take on with the team. I’m sure the people tagged in the discussion will be gladful to help you managing you request.

regards.

Sebastien

Userlevel 2
Badge +6

Hi @Mathias Dahl , Our customer use arcgis.com to manage forest project. Currently I only have a login and password and can connect to arcgis.com

I tried to configure PROOXY_CONFIGURATION but how to be sure about configuration. Where is the log file ?

Userlevel 7
Badge +17

Do they want their users to have to log in when the GIS Map opens in IFS or do they want the users to be logged in automatically? The GIS proxy configuration needs to be configured differently depending on how they want to run it. The documentation describes both scenarios:

https://docs.ifs.com/ifsclouddocs/22r1/ObjectPositioningGISMap/AboutGISConcepts.htm#gisproxy?StandAlone=true

Also, can you show the configuration you did? (leave out the username and password or any sensitive part of the URLs)

The best way to know if it works is to open IFS and log in as one of their users and see of the map layers loads in GIS Map. Did you do that? If yes, what happened?

 

Userlevel 2
Badge +6

Hi @Mathias Dahl , To be sure about the connection, I prefer to log in when the GIS map open. I attach de proxy_configuration file. On GIS map screen, I haven’t error but nothing load.

 

Userlevel 7
Badge +17

Thanks!

I am confused. From how it looks, you have the default proxy configuration right now, but you said you tried to change/configure it earlier. Which is it?

Also, can you give an example of a map service URL they want to use?

 

Userlevel 7
Badge +17

Copying from our private conversation:

> We want no connection so I will keep the last entry.

Sorry, I did not get that. What do you mean with "no connection"?

> Concerning the second point, it is normal, our customer created this ervice without security access.

Then there is no need to configure the proxy unless they also want to use that link/connect feature in GIS Map. Do they want to do that?

> Now GIS Map ask me to connect, we progress :-)

Do you mean log in? If you configured the proxy with a username and password, plus set "Use Proxy" to True in Layer Mapping, you should not be asked to log in.

That being said, again, no need for a username and password if the map layers are public.

> I created a Layer, I see it ont GIS Map but notking appear.

Can you share a screenshot with us?

Thanks!
 

Userlevel 2
Badge +6

Hi @Mathias Dahl

Hi Evevybody

We continued tests et configuration.

Now, it is possible to connect to GIS MAP using ESRI login

We create some map positions

We create GIS connections

In ESRI we added IFSID and add value 10,20,30 on “Points”.

We configure GIS Object  Configuration but we don’t konw how to configure Relations

Do you have information about this step ?

And we didn’t find ESRI points on GIS MAP.

Regards,

Christophe

Userlevel 2
Badge +6

Hi

We succedded to open an esri map with object. But we don’t find how to connect an esri object to an IFS object.

if somebody have idea.

IFS object informationdon’t appear in GIS Map.

Regards,

Christophe

Badge +1

Hi Christophe first steps achieved. ;-) it looks very promising for the needs of operations at our customer.

There is still stuff to do to have it work properly. 

@Mathias Dahl can you give a hand in solving the issue encountered by Christophe ? 

Thanks very much.

BR 

Sebastien

Userlevel 7
Badge +17

Hi, what's the status here? Is it about how to connect IFS and Esri? Technically it happens when the IFS ID (the number 10, 20 and 30 as per above) is saved in the IFSID field in the feature layer in Esri. This data can be migrated by automated means or the user can connect/link the objects by clicking on the map and using the LOV that should appear.
 

Userlevel 7
Badge +17

Did you add the data in GIS Connections manually? If you did, then it you might not get the “connection dialog” that you should. You should only add data there manually or by migration/scripts if you also add the IFS ID in Esri. The connection/link dialog should do both for you.

 

Userlevel 2
Badge +6

Hi, I added data manually in GIS Connections because it is the only one screen where I found IFSID field. So I have to configure GIS Object Connection, right ? But how to configure it ? do you have print screen ? Regards, Christophe

Userlevel 7
Badge +17

Does the Esri layers contain a IFSID column yet? They must, or the “integration” will not work.

Setting up the object information dialog is not hard. Is it order quotations you want to show on the map?

 

Userlevel 2
Badge +6

Yes, Esri layers contain IFSID. Yes I want to show Order Quotations informations and others  with Project informations.

 

Userlevel 7
Badge +17

You need to add some GIS object configuration:

Before you do that, you need to enable the OrderQuotation for GisintConnections:

If it is not there, click New to create it:

Then, on your layer, you need to set the LU Name to OrderQuatation such that the map knows how to get the configuration.

 

Userlevel 2
Badge +6

Hi,

Find my configuration below : 

 

How to  link IFSID 10 with a order quotation ?

Regards, Christophe

Userlevel 7
Badge +17

Delete the GIS connection you made manually and then click the object on the map. A dialog should open to let you link the IFS object with the GIS object.

Or, add the value of the IFSID in the object in Esri from Esri's own map viewer. That's what we do behind the scenes when we link the two objects.

By the way, it looks really strange to have the layer ID (0, in all three URLs) be part of the URL. It should be set in the Layer ID field. Still it looks like the layers are showing for you, really strange... What are those numbers in the Layer ID field that you added? And were you allowed to save the URL with the layer ID included?

 

 

 

 

Userlevel 2
Badge +6

Hi,

I deleted all GIS connections and when I click the object on the map nothing happen.I haven’t a dialog box to link GIS Object and IFS Object. (IFS Managed Cloud, 21.2.10)

Shoud I to configure something more ? 

 

For Layer ID, I chose numbers like 100,110 and 120 to call my 3 layers.

 

Regards, Christophe

Userlevel 7
Badge +17

I deleted all GIS connections and when I click the object on the map nothing happen.I haven’t a dialog box to link GIS Object and IFS Object. (IFS Managed Cloud, 21.2.10)

 

I realized I told you information there that does not apply to the Aurena client. In our old client (IEE) you could just left-click an object to get the dialog to open. Now you right-click and chose the option there to connect/link (I don't remember the exact words) the object. Try that.

As for the layer IDs, those are the numbers after the slash in the layer URL. They should be kept in the Layer ID field. Not sure how you could even save those URLs to be honest 🙂 (I tested now and I can also keep the layer ID in the URL field, some validation must be broken there) And I also don't understand how it can work.

I suggest you "move" the layer IDs to where they should be.

Here is a screen shot of how it should look:

Here is where you find the layer IDs (it’s the numbers in brackets to the right):

Hope this helps.

 

Userlevel 2
Badge +6

Object link is unavailable. 

Do you have an idea about what ?

 

Userlevel 7
Badge +17

Not sure. The only idea I have is that the map thinks the layer is read-only/not editable and decides to hide the connect/link command.

Did you remove the layer IDs from the URL and put it in the Layer ID field instead?

 

Reply