Solved

Custom Fields not displaying IEE


Userlevel 2
Badge +2

Hi,

I have created a new customized screen, and now i have added custom fields to the screen, i can see these columns in CFV but I am unable to reload configuration in Page. hence Custom Fields are not displaying in the screen.

Thanks in Advance.

Regards,

shravan.

 

icon

Best answer by Sangeetha Jayamaha 5 August 2021, 15:29

View original

20 replies

Userlevel 5
Badge +5

@Shravan 

After adding the custom fields to the form, hope you published the fields.

 

Once you publish it make sure that all the below check boxes are checked.

 

Then you can go back to your window and Reload configuration.

 

Then RMB on the Form and go to properties and make sure that the following check box is checked.

 

 

Then From the Layout tab, You can add the custom filed to the form.

 

Now if you close the window and open it again, You will see the newly added custom field as below.

 

 

Hope you will try this and get back.

Regards,

Sangeetha Jayamaha.

/

Userlevel 2
Badge +2

Hi Sangeetha,

Thank you for your quick response.

I have published all the fields, but when i do reload configuration nothing happens. did i miss anything after publishing.

 

 

Regards,

Shravan

Userlevel 5
Badge +5

@Shravan Did you follow all the above mentioned steps after publishing and reloading configuration ? 

Do you get the custom fields to the layout tab as mentioned above ? 

/Sangeetha

Userlevel 2
Badge +2

@Shravan Did you follow all the above mentioned steps after publishing and reloading configuration ? 

Do you get the custom fields to the layout tab as mentioned above ? 

/Sangeetha

Hi Sangeetha,

After publishing the custom fields i tried to reload the configuration after that screen is not getting refreshed hence the custom fields are not available in layout.

Regards,

Shravan

Userlevel 5
Badge +5

@Shravan RMB on the form and go to properties.  Then take screen shots of “window tab” and the “layout tab” and add them here. Let’s see if we can figure out what has happened

/Sangeetha

Userlevel 2
Badge +2

@Shravan RMB on the form and go to properties.  Then take screen shots of “window tab” and the “layout tab” and add them here. Let’s see if we can figure out what has happened

/Sangeetha

Hi Sangeetha,

please find below for reference, after reload configuration nothing has updated in the screen.

 

Regards,

shravan

Userlevel 5
Badge +5

@Shravan You have to check the “Use customized screen layout” check box as per above screenshot. Seems you have not checked it. 

 

Also attach the “Window tab” screenshot.

/Sangeetha

Userlevel 2
Badge +2

@Shravan You have to check the “Use customized screen layout” check box as per above screenshot. Seems you have not checked it. 

 

Also attach the “Window tab” screenshot.

/Sangeetha

Hi Sangeetha,

Please find below for reference.

Regards,

Shravan

Userlevel 5
Badge +5

@Shravan now it’s fine now. Press ok and close the window. Then open the window again and you should be able to see the custom fields.

/Sangeetha

Userlevel 2
Badge +2

@Shravan now it’s fine now. Press ok and close the window. Then open the window again and you should be able to see the custom fields.

/Sangeetha

Hi Sangeetha,

I have followed all the general procedure for custom fields, but custom fields are not appearing in the form, but i can find them in the CFP’s and CFV’s, only i have problem with reload configuration as it is not refreshing the screen.

both screen and entity’s are newly introduced..

Regards,

Shravan

 

Userlevel 4
Badge +9

Hi  Shravan,

 

I’ve had this in Apps9, you may need to go into the “None (of totally3)” on the approved step and manually approve views to get the field to display, can’t guarantee that this will solve your issue but worth a try. You will need to synchronize again and reload config - hope that helps you.

 

 

Userlevel 2
Badge +2

Hi  Shravan,

 

I’ve had this in Apps9, you may need to go into the “None (of totally3)” on the approved step and manually approve views to get the field to display, can’t guarantee that this will solve your issue but worth a try. You will need to synchronize again and reload config - hope that helps you.

 

 

Hi Sholmes,

Thanks for your response.

I have tried the same but still i didn’t see the fields.

Regards,

Shravan

 

Userlevel 6
Badge +7

Hi,

 

Check System Parameters and see attributes related to Custom fields are set to ON.

Userlevel 6
Badge +7

System parameters for Custom Objects should be as below.

But, there should not be any issue with this, if you can see custom fields in other windows.

 

Userlevel 5
Badge +5

@Shravan Does this issue exists for all the forms in the application or is it for only this form? 

 

If it is for all the forms, you could check the following setting as well. 

 

Solution manager --> Monitoring --> Application Monitoring --> Application Monitoring console.

 

There check the indicator for “PL/SQL Access Provider configuration test”.

 

For the custom fields to work, that should be green.

Here is a screenshot of the window.

Best Regards,

Sangeetha Jayamaha.

/

Userlevel 2
Badge +2

@Shravan Does this issue exists for all the forms in the application or is it for only this form? 

 

If it is for all the forms, you could check the following setting as well. 

 

Solution manager --> Monitoring --> Application Monitoring --> Application Monitoring console.

 

There check the indicator for “PL/SQL Access Provider configuration test”.

 

For the custom fields to work, that should be green.

Here is a screenshot of the window.

Best Regards,

Sangeetha Jayamaha.

/

Hi sangeetha,

 

The issue is for only one form and it is newly added by me.

Userlevel 7
Badge +16

Hi @Shravan also refer the following which includes additional steps to verify;

 

Userlevel 5
Badge +7

hi @Shravan ,
 

I assume that you you shipment form is customized form as in above screenshot logical unit is ‘KosShipmentLine’. Could please check if you have added custom field view as an approved details view. 
Similar approach is described in below community post.
 

Nilushi - 
 

Userlevel 5
Badge +5

@Shravan 

 Also check whether you have put the view name in All Caps in the .designer.cs file.

 

eg: in frmProblemWindow.Designer.cs file it should be as follows.

 

  this.NamedProperties.Put("ViewName", "USER_ALLOWED_SITE");

 

If you have, it as follows, the custom fields does not work.

this.NamedProperties.Put("ViewName", "User_Allowed_Site");

 

Best Regards,

Sangeetha Jayamaha.

/

Userlevel 2
Badge +2

Hi Sangeetha,

This solution works, now it is working as expected.

 

Thank you. 

Regards,

Shravan

 

Reply