Solved

Serial Object - Warranty not displayed

  • 30 September 2022
  • 6 replies
  • 91 views

Userlevel 3
Badge +7

Hi all,

I’m running into an issue in which the Serial Object Warranty badge is indicated as ‘No’, however if you select the ellipsis and select Warranty, you will indeed see a Supplier and/or a Customer Warranty has been set-up.  

This behavior is visible on the Serial Object as well as the Equipment Object Navigator.

Process Steps:

  1. Receive Part with a Warranty Template defined (i.e. 1 year)
  2. Deliver this part to a Customer with SM Object creation specified on the Sales Part
  3. Navigate to either Serial Object or Equipment Object Navigator

Here is issue I see:
 

 

Is there something missing from the set-up?

Thanks.  

icon

Best answer by Nethmini Kosvinna 4 October 2022, 06:35

View original

6 replies

Userlevel 6
Badge +12

Could you please mention the version of the application here please ?

Userlevel 5
Badge +12

Hi @astfarazt ,

Please check the valid period of the Object Warranty that you have set. You have set the same date as Valid to and Valid from mistakenly. Please change the valid period and please note that, the flag ‘Warranty’ will be set to ‘Yes’ only during the active period of the warranty.

Thanks & Best Regards,

Nethmini

Userlevel 3
Badge +7

@Mayura Wasantha  It’s 22R1 UPD 6.

 

@Nethmini Kosvinna Nice catch!  Although I did not manually set the date you see in the screenshot.  The application automatically entered these dates.  

My understanding is that the Supplier Warranty will begin at time of PO Receipt.

Is there some basic data missing here or is this perhaps a bug?

Userlevel 5
Badge +12

Hi @astfarazt ,

Please check your Warranty template Min Value.

 

I tested this in 22R1.6 as below. If you have set 0 as warranty condition Min Value,  you will automatically get the PO received date as the Valid From date.

Object Warranty

But if you have kept the Min Value null, you will not get the Valid From date under object warranty. But you will get the option to edit the ‘valid from’ date if required.

Min Value null
Valid From is empty. But you can edit.

But in both above scenarios flag Warranty is set to yes in Serial Object window. Therefore, please check your warranty template condition. Please make sure you have set Min Value to 0 to get the valid from date correctly. 

Hope this information will help you to sort out your issue.

Thanks & Best Regards,

Nethmini

Userlevel 3
Badge +7

Thanks, @Nethmini Kosvinna.  It appears my Min Value and Max Value were both set as “1”, hence the Start and Expiration dates were the same.  

I appreciate you taking the time to look into this!

Userlevel 5
Badge +12

Hi @astfarazt ,
It is a pleasure to know that my answer has helped you to solve the issue 😊.

Best Regards,

Nethmini

Reply