JVM Startup parameters | IFS Community
Solved

JVM Startup parameters

  • 7 January 2020
  • 7 replies
  • 408 views

Userlevel 6
Badge +16

Hello Heroes,

I am reviewing the following IFS F1 Documentation page for Apps 10 to Configure behavior through server startup parameters:

 

As per the note, You can add/change these startup parameters from IFS Applications intaller at installation time or by using IFS Middleware Server Admin Console.

I am unable to locate these parameters in IFS MW Admin Console? Can you please point where to look specifically?

icon

Best answer by Minoshini Fonseka 7 January 2020, 14:07

View original

7 replies

Userlevel 7
Badge +16

Hi @Srikanth,

  1. Login to the MWS Admin console.
  2. Main Cluster→ Managed Servers
  3. Go to the SERVERS tab.
  4. Then you could add the arguments to the startup parameters as follows, and the Save.


Once a parameter is added or if value is changed, application server must be restarted to make the change effective

Hope this helps :slight_smile:

Userlevel 6
Badge +16

This is great to know, thanks.

The server must be in SHUTDOWN state to modify details

I stopped the Managed Server to enter the new Argument and clicked Save. I am getting this error as soon as I click Save:

Error Detail

 

Userlevel 7
Badge +16

This is great to know, thanks.

The server must be in SHUTDOWN state to modify details

I stopped the Managed Server to enter the new Argument and clicked Save. I am getting this error as soon as I click Save:

Error Detail

 

Please add the argument while the server is up and running.  because it updates the managed server and starts a edit session and update server information and activates the changes. 


So please give a try to save changes while it is running.  Once you save the changes, it would indicate to restart the servers. 

 

 

Userlevel 6
Badge +16

Still same issue:
 

 

Userlevel 7
Badge +16

Still same issue:
 

 

If you add this change from the configuration tab, would it work for you.

Userlevel 6
Badge +16

Still no luck, I will try re-configuring MWS and test again. Thank you for all your inputs!

Userlevel 7
Badge +16

May be you could try to change some other value and see whether it gives the same error. Then there should be an problem with modifying information.

 

Yeah, It's better to try a reconfiguration. 

Reply