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Unable to save lobby element

  • June 20, 2024
  • 7 replies
  • 536 views

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Hello!

Recently I’ve encountered an issue with the Lobby Element Designer. I’m trying to create a new Barchart element but started receiving “Unable to save element” errors when trying to save the new element. I’ve previously created Barchart elements, so I’m confident I have everything configured correctly in the Data and Formatting sections, but this one puzzled me enough to try duplicating an existing Barchart element. When duplicating a working element, I’m still presented with the same error when saving. This issue does not occur when working with other element types.

Does anyone know if there is a cache or some configuration that needs to be reset so that I can move forward with the development?

Regards,

Randy

Best answer by EsiRandyG

Hi all,

The weekend restart of the system resolved the issue. Curious to see if IFS has this noted as a bug or whether this has been resolved in a UPD already.

Marking this one as closed.

Regards,

Randy

7 replies

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Hello EsiRandyG, Can you please provide screenshot of the error and your data source query?


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  • Author
  • Do Gooder (Partner)
  • June 21, 2024

Hi Bhanu,

Below are the requested screen captures. The part that has me baffled is I’m unable to even save a duplication of a functioning Barchart element.

Functioning Element

 

Duplicate of Functioning Element

 

“Unable to save element” error message

 

Datasource Definition

 


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  • Author
  • Do Gooder (Partner)
  • Answer
  • June 24, 2024

Hi all,

The weekend restart of the system resolved the issue. Curious to see if IFS has this noted as a bug or whether this has been resolved in a UPD already.

Marking this one as closed.

Regards,

Randy


zuhaib
Sidekick (Customer)
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  • Sidekick (Customer)
  • June 25, 2024

Hi @EsiRandyG 

I hope this reply finds you well.

If you face issue during the duplicate element I will suggest you create new element designer and also data source. after that you try.

 

Zuhaib
IFS Consultant
https://www.linkedin.com/feed/
 

 

 


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  • Hero (Partner)
  • August 15, 2024

FYI, I’m currently experiencing the same error in a customer environment (23R2), and it’s also affecting creating a brand new and very simple element.

The response from the server indicates that the error comes from Composite_Page_Repository_API, probably the procedure Save_Element, which starts with taking the procedure input and converting to an XMLType. It kind of seems like the conversion from JSON request to XML isn’t happening properly in the middle tier. We’re trying to schedule an environment restart, but I would also like to know whether it’s possible to refresh some cache or something.


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  • Sidekick (Customer)
  • October 7, 2024

We are on 24R1 and I experienced the same issue.

Here is a workaround, find a similar element and export the xml. Then edit the xml manually (change the ID, naem etc.). After that you can import the element again into IFS and edit the rest there.


Lakshan Thiranagama
Hero (Former Employee)
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Here is the permanent solution for this problem which is already given in below knowledge article.

 

https://support.ifs.com/csm?id=kb_article_view&sys_kb_id=9ee14de6c32c3a9497e05e3ed40131c3&table=kb_knowledge&searchTerm=#Lobby%23%20Unable%20to%20save%20or%20load%20Lobby%20Elements.%20System%20displays%20errors%20and%20remains%20stuck%20in%20loading

#Lobby# Unable to save or load Lobby Elements. System displays errors and remains stuck in loading

 

 

Issue

When trying to save a new Lobby Element, the system shows the error message 'Unable to Save Element'. Additionally, when attempting to open a new element, the error 'Unable to Load Element' appears, and the page remains stuck on loading even though the 'FND_LOBBY_ADMIN' permission was granted. 

Environment

 IFS Cloud

Cause

Lobby permissions are not configured correctly.

Resolution

 This error is due to missing permissions. If we look at the error stack trace, it appears as follows:

code: "NO_PERMISSION"
errorCode: "NO_PERMISSION"
developerMessage: "Insufficient Privileges"
localizedMessage: "You do not have permission to access this lobby element."
message: "You do not have permission to access this lobby element."
resource: "Lobby Element"
status: "Forbidden"

This clearly indicates that the user you are using does not have access to the specific Lobby Element you're trying to open.

By default, a user needs to be granted the FND_LOBBY_ADMIN permission set to use the Element Designer tool. However, it's important to note that this permission set does not automatically provide access to all Lobby Elements unless those elements are explicitly granted to it.



Reference:
https://docs.ifs.com/techdocs/25r1/040_tailoring/250_lobby_configurations/060_security/#1_fnd_lobby_admin

In IFS, Lobby Element presentation object permissions are typically granted to the FND_LOBBY_ADMIN permission set via the system parameter "Permission set to be granted Lobby presentation objects by default".

Refer to the attached image: https://docs.ifs.com/techdocs/25r1/040_tailoring/250_lobby_configurations/060_security/#system_parameter_for_data_access_configurations_in_lobbies


This means that if you have been granted the FND_LOBBY_ADMIN permission set and you create a new element, you will automatically have access to it.

Note: The System parameter value is case sensitive. 

 

In some situations, we have noticed that the value of the system parameter is set to * or to a different permission set. If the value is set to *, you need to specify a permission set name as shown in the image above. If a different permission set is specified, users must also be granted access to that permission set if it cannot be changed as per the requirements.