GZip header not correct | IFS Community
Solved

GZip header not correct

  • 7 April 2021
  • 4 replies
  • 153 views

Userlevel 6
Badge +16

Has anyone come across this error in IEE (Apps 10) before?

Ifs.Fnd.FndSystemException: Error in WndProc ---> System.IO.InvalidDataException: The magic number in GZip header is not correct. Make sure you are passing in a GZip stream.
   at System.IO.Compression.GZipDecoder.ReadHeader(InputBuffer input)
   at System.IO.Compression.Inflater.Decode()
   at System.IO.Compression.Inflater.Inflate(Byte[] bytes, Int32 offset, Int32 length)
   at System.IO.Compression.DeflateStream.Read(Byte[] array, Int32 offset, Int32 count)
   at System.IO.Compression.GZipStream.Read(Byte[] array, Int32 offset, Int32 count)
   at Ifs.Fnd.Core.FndCompressionUtil.Decompress(Byte[] compressedData)
   at Ifs.Fnd.Data.FndDataRow.LoadConditionRow(String formattedCondition, FndDataRow conditionRow)
   at Ifs.Fnd.Explorer.Interfaces.SavedSearch.DeserializeFromString(String str)
   at Ifs.Fnd.Explorer.Extenders.SearchExplorerManager.SearchDialog.LoadSavedSearchesCombo()
   at Ifs.Fnd.Explorer.Extenders.SearchExplorerManager.SearchDialog.SearchDialog_Load(Object sender, EventArgs e)
   at System.EventHandler.Invoke(Object sender, EventArgs e)
   at System.Windows.Forms.Form.OnLoad(EventArgs e)
   at Ifs.Fnd.Windows.Forms.FndForm.OnLoad(EventArgs e)
   at System.Windows.Forms.Form.OnCreateControl()
   at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
   at System.Windows.Forms.Control.CreateControl()
   at System.Windows.Forms.Control.WmShowWindow(Message& m)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   at System.Windows.Forms.Form.WmShowWindow(Message& m)
   at System.Windows.Forms.Form.WndProc(Message& m)
   at Ifs.Fnd.Windows.Forms.FndForm.WndProc(Message& m)
   --- End of inner exception stack trace ---

 

The error pops up when I click the magnifying glass to search for a Permission Set in IEE. I can click Close and my search still works OK. I tried search button in few other screens but the error doesn’t show up.

icon

Best answer by Srikanth 20 May 2021, 13:33

View original

This topic has been closed for comments

4 replies

Userlevel 6
Badge +9

@Srikanth is this issue occurred after any delivery  installation ?  

Userlevel 6
Badge +16

No, this is a brand new Apps 10 instance upgraded from an older version. No deliveries or updates installed yet.

Userlevel 7
Badge +17

Hi @Srikanth,

Does this happen only for a specific user or on a specific machine? 

If it is happening on certain machines, please try clearing the ClickOnce cache by running the following command in a command line on the client machine:

rundll32 %windir%\system32\dfshim.dll CleanOnlineAppCache

Alternatively you can try deleting following two folders on the client machine:

C:\Users\<User_name>\AppData\Local\IsolatedStorage
C:\Users\<User_name>\AppData\Local\Apps\2.0

You will have to restart the IEE for the above changes to take effect.

If it is happening for a specific user, you can try disabling personal and base profiles of the user and see if that helps.

Userlevel 6
Badge +16

Update - This error went away on its own after installing UPD11 recently. 

Thank you for your tips.