Error trying to open Crystal Web Report in IFS (CWS) | IFS Community
Solved

Error trying to open Crystal Web Report in IFS (CWS)

  • 18 June 2020
  • 8 replies
  • 1043 views

Userlevel 6
Badge +16

Hi,

We configured CWS for IFS Apps 10, as per IFS documentation but running into the following error trying to View a Crystal Quick Report in IFS:

Here are the error details captured by the CWS logs:

6/18/2020 11:23:18 AM[IFSCRWebSetup]-[LoadReport] Loading report : C:\ifs\test10_reports\WC Load.rpt
6/18/2020 11:23:18 AM[IFSCRWebSetup]-[LoadReport] DBUser = ifssys ,DBPassword : ******* ,DBServerName : TEST10 ,AppOwner : IFSAPP
6/18/2020 11:23:18 AM[IFSCRWebSetup]-[ReadLogonInfo] ssss
6/18/2020 11:23:18 AM[IFSCRWebSetup]-[LoadReport] Processing 2 parameters.
6/18/2020 11:23:18 AM[IFSCRWebSetup]-[SetTableLocation] Set appropriate post-fixes for REI_WORK_CENTER_LOAD\
6/18/2020 11:23:18 AM[IFSCRWebSetup]-[SetDatabaseLocation] Generating fully qualified database object name for ABC_WORK_CENTER_LOAD\
6/18/2020 11:23:18 AM[IFSCRWebSetup]-ERROR in [ExportReportWithParametersAndlogonInfo] Error in exporting the report in rpt format.
6/18/2020 11:23:18 AM[IFSCRWebSetup]-Failed to load database information.Error in File WC Load 13156_10900_{7738544C-68CB-4EB6-89A1-8189EBC875D9}.rpt:
Failed to load database information.   at CrystalDecisions.ReportAppServer.Controllers.DatabaseControllerClass.SetTableLocation(ISCRTable CurTable, ISCRTable NewTable)
   at CrystalDecisions.CrystalReports.Engine.Table.set_Location(String value)
   at Ifs_ReportService.SetDatabaseLocation(String databaseLocation, Table table) in c:\inetpub\wwwroot\IFSCRWebSetup\App_Code\Service.cs:line 1409
   at Ifs_ReportService.SetTableLocation(Table crTable, String UserId, String AppOwner, String IALOwner) in c:\inetpub\wwwroot\IFSCRWebSetup\App_Code\Service.cs:line 1381
   at Ifs_ReportService.LoadReport(String path, String DBUser, String DBPassword, String DBServerName, String LogonInfoValues, String AppOwner, String IALOwner) in c:\inetpub\wwwroot\IFSCRWebSetup\App_Code\Service.cs:line 1284
   at Ifs_ReportService.ExportReportWithParametersAndlogonInfo(String FileName, String WebUser, String SecuredReportRequired, String ParameterValues, String LogonInfoValues, String ExportType) in c:\inetpub\wwwroot\IFSCRWebSetup\App_Code\Service.cs:line 724

 

Has anyone run into this error before?

Thank you for your help.

icon

Best answer by Sajith D 25 June 2020, 01:00

View original

8 replies

Userlevel 6
Badge +16

Hi @Srikanth ,

 

Given the error that you have the most likely issues (assuming that none of the  Quick CR’s are working) would be

  1. TNS entry “TEST10” is not setup/ incorrectly setup resolving to the database instance.
  2. There is a mismatch in the oracle client and the java runtime installed. For 64bit CWS, both the java runtime and Oracle client needs to be 64bit.
  3. hashed password for IFSSYS user is incorrect.

If the issue is specific to a single report, you would need to check whether all of the views used in the report has view grants to IFSSYS user. This wouldn’t be an issue if the views in question are standard IFS Views. 

Cheers,

Userlevel 6
Badge +16

Hi Sajith,

Thank you for your feedback. I have configured CWS several time before and can confirm all the criteria has been met. CWS is installed on the MW server itself and JAVA_HOME points to the Java Runtime under IFS_HOME.

  1. hashed password for IFSSYS user is incorrect. - Can you please elaborate? As far as I know, the IFS* user passwords haven’t been changed prior to post CWS configuration. 
Userlevel 6
Badge +16

Also, the following logon dialog box opens each time a report is run, prompting for logon credentials:

If things are working, the logon information should be passed automatically. 

The user ran the actual report using CR Designer against the database in question and saved the report file prior to copying it to the Open Reports folder.

Userlevel 1
Badge +5

Hi Srikanth,

Can you please make sure whether the views used in the report granted to IFSPRINT user?

Also regarding logon dialog every time can you try to use \ at the end of views used in Crystal Report as an alais ?

 

Thanks,

Sanjay

Userlevel 6
Badge +16

Hi @Srikanth 

If the IFS internal user passwords hasn't been changed after the initial configuration of CWS you probably don’t need to worry about a password mismatch. In case you want to double check, you can always extract the latest CRWS installation zip from the application server instance and crosscheck the XML file with the XML file available in CRWS virtual directory in IIS.

It’s interesting that you are getting the logon prompt . This usually happens when your report views are not suffixed with “\” for App owner & “\\” for IAL owner. Probably worth checking that in the RPT file together with verifying that “Oracle Server” connection method is used to build the report.

 

Cheers,

Userlevel 6
Badge +16

We suffixed the objects with \ and this suppressed the database logon problem.

However, the reports are still not running.

I reinstalled CWS on the server and I am now getting a different error:

Oddly, the CWS log isn’t showing any error like the one reported in this thread.

We are now going to log a case with IFS.

Thanks everyone!

Userlevel 6
Badge +16

Hi @Srikanth ,

 

Looks like the rendering of the report is all good now based on the CWS log. The DLL error that you see usually happen when the Crystal runtime installed in the client machine running the report through IEE has a mismatch with the expected runtime that is provided with the Add-on’s page. Quite common in machines that have Crystal developer installed as the developer libraries usually overwrite the runtime libraries. If you reinstalled the CR runtime from the add-ons page and restart your IEE, this should go away.

 

Cheers.

Userlevel 6
Badge +16

This error is displayed on the Application Server itself where I installed the CR Runtime 64-bit client. There is no Crystal related software besides CWS installed there.

But I agree with you, its now matter of getting the runtime to work as expected. 

Reply