Solved

Custom Field on tbwRepresentativeCustomer

  • 20 November 2019
  • 7 replies
  • 418 views

Userlevel 4
Badge +9

I am struggeling with creating custom fields on this page. When I enter the overview for custom fields I can see my custom fields but they are not visible to add on the tbw. I have reloaded the configuration and restarted EE but only Menu-items can be used on tbwRepresentativeCustomer and no custom fields. I have seen this behavior on other pages as well so is there any limitation on where we can see custom fields or is this a bug?

 

 

 

 

icon

Best answer by CallumW 20 November 2019, 17:48

View original

7 replies

Userlevel 6
Badge +14

Hi,

 

I translated the word ‘Ingen’ and it came back with ‘No’ so my assumption would be that you need to approve the detail view  and then do the normal steps: synchronise, reload config and column chooser etc...

 

Yours will look different to mine, but hopefully you get the idea

 

 

 

Regards, Callum

Userlevel 4
Badge +9

I get Compile error when trying to do that.

 

 

Userlevel 4
Badge +9

 

Userlevel 4
Badge +9

It failes when validating fields. If removing the readonly fields and putting a writable field I can synchronize but still no visible columns on this page.

Userlevel 5
Badge +11

Hi,

Once you select view REPRESENTATIVE_CUSTOMER from approved details views, you need to RMB and synchronize. Now you should see both Approved and Published check boxes are ticked.

Thereafter, try to validate the custom field, if the validation still fails then the problem is in the custom field you have created if not go to tbwRepresentativeCustomer and RMB Reload Configuration.

 

Now you should see the custom field created.

 

Userlevel 7
Badge +17

Hi @MattiasLindahl,

 

Could you please check if the Custom Field that you have created is hidden? You can check this by Right mouse clicking on a column and selecting Column Chooser…

  • If the custom field you’re looking for is hidden, you should see it on the left side of the popup window. 
  • If the custom field is on the left, move it to the right side and click on OK

Now you should be able to see the new column.

 

Himasha

Userlevel 4
Badge +9

The problem was mixed. When having read-only fields that worked before adding the REPRESENTATIVE_CUSTOMER view in Approved detail view these fields did not validate. I had to rebuild them with an expression that had to be built little different than before. So now it works.

 

So the thing I had missed was as the first answer showed, Approve detail view.

Reply