Configure IFS Applications 10 to use port 443 instead of standard 48080 | IFS Community
Solved

Configure IFS Applications 10 to use port 443 instead of standard 48080

  • 30 March 2021
  • 5 replies
  • 371 views

Userlevel 6
Badge +16

Has anyone successfully implemented IFS Applications 10 to use the default SSL port 443 instead of the standard port numbers?

One of my client wants to implement this configuration for couple of reasons:

  1. Suppress the port number inside the IFS URL
  2. Most firewalls are tolerant to 443 compared to other ports

Please advise, thanks!

icon

Best answer by dsj 31 March 2021, 11:59

View original

This topic has been closed for comments

5 replies

Userlevel 7
Badge +15

Hi @Srikanth,

 

It worked straight for us.

In our installations we use SSL passthrough where external load balancer setup to pass through traffic to IFS and the SSL certificate is managed in IFS. But I hope other options also work as they should.

 

Regards,

Damith

Userlevel 6
Badge +16

Hi @dsj ,

Can you please provide more details or a screenshot of your configuration?

We are using SSL Passthrough right now and it works fine as long as the port number 48080 is part of the SSL proxy URL.

Example - https://ifs.mydomain.com:48080

However the goal is to utilize the standard SSL Port - 443.

Example - https://ifs.mydomain.com

Userlevel 7
Badge +15

Hi @Srikanth,

 

Given below is example configuration.

Loadbalancer is of type TCP with listener port 443

 

Regards,

Damith

Userlevel 6
Badge +16

I did not specify the port number 443 in the Proxy URL assuming https would resolve to the default port number. Adding the port number at the end made the configuration to work and another colleague of mine confirmed this as well. 

Thank you!

Userlevel 5
Badge +9

Yes, I have used 443 default SSL port and reconfigured MWS.  that way you can use the url without 48080 as well.

e.g https://<mws_host_name>.com