Question

IFS MWO Service - New Work - Object ID

  • 10 June 2024
  • 4 replies
  • 33 views

Userlevel 5
Badge +11

Hi All,

 

I’m doing some tests on the IFS MWO Service where I start a WO - assign it and transfer to mobile. When the technician accepts the MWO and starts doing his work, he notices ‘additional work’ to be performed.

 

But I want him to enter the Object ID. But unfortunately, this seems to remain an empty list and I can’t select any object ID.

 

When I do the same through ‘Technician Portal’, it does filter my Object Id List:

 

 

So Question:

What controls the list of Object ID’s that I can select on the MWO Service? Is there a setting or how can I populate a list?

 

Best Regards

Roel


4 replies

Userlevel 7
Badge +17

@Timmermans Roel could it be that ToolsAndEquipments security group is not assigned to the user?

MWO Tools: Resource (LOV) is not displaying on selecting Resource group | IFS Community

Also please check below post on how to enable DB Viewer on MWO (kinda’ cool feature for troubleshooting)

MWO Service (23R2) New Purchase Requisition | IFS Community

 

I hope this helps.

Userlevel 5
Badge +11

Hi @Marcel.Ausan 

The ToolsandEquipment security group seems to be assigned correctly.

 

I also had a look at the link you provided, I managed to get the Database viewer enabled for my profile but the table ‘Equipment Object’ remains empty - MWO says there is no data to be displayed. Which seems strange because I have multiple Serial and Functional objects. Or does it also require some kind of sync after the Initialization?

 

 I was unsure how the refresh of Purch part/inv part is relevant for my case but the Database Schedule did not exist, so I created it and scheduled it. If it doesn’t help, at least it won’t be an issue either I guess.

 

Any additional thoughts why the equipment table would be empty on MWO?

 

Best Regards

Roel

Userlevel 7
Badge +20

If your equipment table is empty, have a look at the sync rules. If you already have work tasks, their associated equipment should also be in MWO. And starting in 23R2 MWO Service uses Batch Sync, which would allow you to specify additional include/exclude filters that get applied on top of the default filter.

Userlevel 5
Badge +11

If your equipment table is empty, have a look at the sync rules. If you already have work tasks, their associated equipment should also be in MWO. And starting in 23R2 MWO Service uses Batch Sync, which would allow you to specify additional include/exclude filters that get applied on top of the default filter.

Hi @Alexander Heinze ,

Sorry, I was not available the last 10 days. I’m not familiar with the sync rules; What should I be looking at exactly?

 

 

“If you already have work tasks, their associated equipment should also be in MWO”

That’s indeed how I remember it, but it doesn’t seem to work like that in my current version. I have created plenty of Work Tasks and assigned them to myself but none of the Object ID’s from my earlier used Work tasks are visible. 

 

Small example: I currently have 1 active work task on object 240606001-10, which is visible on the work task.

  • I click ‘Additional Work’
  • I say ‘NO’ on copy info from Work Task
  • Selecting ‘new work that I have performed’, click next, 
  • Enter a random description and click ‘next’
  • Selecting Object drop down
  • List is empty…. :-(

So shouldn’t at least the Object ID of the current Work Task be visible? Off course - when i use ‘Copy info from Work task’, the Object ID is automatically assigned to the new work task. But even then, when I would select the drop down, it is also completely empty.

Printscreens of all steps below.

Looking forward to your thoughts!

 

best Regards

Roel

 

Active Work Task on object 240606001-10

 

Create new Work - Copy information = ‘NO’
Report additional work
Added Random Description

 

Select Object ID drop down

 

Object ID drop down is empty

 

 

 

List of Objects known in MWO

 

Reply