The message says that Aurena Agent has been successfully installed - But no Agent has been installed | IFS Community
Question

The message says that Aurena Agent has been successfully installed - But no Agent has been installed


Userlevel 2
Badge +4

Hi,

This message appears when we open user settings. See attached picture.

How do we solve this? I have tried to find a solution but can not find one that fits :-)

 

/Linda


24 replies

Userlevel 7
Badge +17

Hi,

Is the “root” URL of the User Settings page the same URL you used when you installed the Aurena Agent? 

You can look in the file "C:\Users\<USER>\AppData\Local\IFS\IFSAurenaAgent\allowed_hosts.txt" if there is an entry for the URL you used in the installation program, and if there is a long random string of letter and numbers there. It should look something like this:

https://my-server.com,ABGHUJ92784HNMJHJ796JJKHHJK
 

Userlevel 2
Badge +4

Hi ,

  1. Is the “root” URL of the User Settings page the same URL you used when you installed the Aurena Agent?  Yes
  1. if there is a long random string of letter and numbers there. : it was, and these were removed. Still not working :-(

 

Do you have other suggestions?

 

/Linda

Userlevel 7
Badge +17

Hi,

 it was, and these were removed.

You should not remove those random characters (they are not really random, btw, but it looks like it). Then it will definitely not work.

What you need to do now is to remove the URL from that file, not adding any empty lines or changing any other lines in any way, then install the aurena agent again using the MSI package. Then reload Aurena again and see.

 

Badge

In this case, the computer may already be identified in the database as part of the management group. Or, the computer is listed under Pending Actions in the Operations console.

 

 

Userlevel 7
Badge +17

In this case, the computer may already be identified in the database as part of the management group. Or, the computer is listed under Pending Actions in the Operations console.

Hi Betty,

Did you mean to post this answer in another discussion? Or can you explain how it relates to this question about the Aurena Agent?

Thanks!

 

Userlevel 4
Badge +9

@Mathias Dahl  Our IT Partner has an issue distributing the Aurena Agent to all our users. If I install it manually just for me through the /add-on.html page, it works fine. But if I install it with their SCCM Package (Software Center), it doesn’t work. 

I noticed that when I install it with their SCCM package, the folder C:\Users\<USER>\AppData\Local\IFS\IFSAurenaAgent only contains two files:

IFSAurenaAgent.log
allowed_hosts.txt

The file allowed_hosts.txt has the URL and the characters as you describe above. 

 

But when I installed manually, the IFSAurenaAgent folder contains more files:
aurenaagent_manifest.json
Ifs.Application.Docman.MacroManagement.dll
Ifs.Fnd.Mail.dll
IFSAurenaAgent.exe
IFSAurenaAgent.exe.config
IFSAurenaAgent.log
Interop.MsScript.dll
Newtonsoft.Json.dll
PdfPrintingNet.dll
System.Net.Http.Formatting.dll
System.Web.Http.dll

Do you know what to do different here? They have installed it using the silent installer as “SetupAurenaAgent.msi” /quiet HOST=<my-server.com> (link to our landing page)

We use Edge as browser.

This is what shown when apparently everything is installed ok with the SCCM package. 

 

Userlevel 7
Badge +17

@SORBJAHAU 

Hi,

Did you try to install the MSI package manually from the command line as well? If that too miss including all the necessary files, then there is something wrong with the MSI package. If that works, then I'm not sure if we can help.

 

Userlevel 4
Badge +9

@Mathias Dahl When I install the MSI through command line, it generates all files in the folder. But the allowed_hosts doesn’t include the long random string of letter and numbers, only our IFS landing page and a comma.

 

It also generates an error when accessing the User Settings in Aurena

 

Userlevel 7
Badge +17

Could it be that you didn't have access to the site when you ran the MSI? The installer needs to be able to access the site at installation time, in order to save a hash of the security certificate.
 

Userlevel 4
Badge +9

Hmm, don’t think access is the case. I can install it fine manually with file explorer and provide the hostname in the dialog.

Provided here, and it works fine:

 

It’s when giving the host name via parameter it fails. Same happens if I give the parameter in a File Explorer. We have switched from standardport 48080 to 443. Could that be an issue?

Userlevel 7
Badge +17

Hi,

I also tried to install it from the command line now and I also get no certificate hash added to the file.

This looks like a bug to me and I think you should report this to our support.
 

Userlevel 4
Badge +9

@Mathias Dahl ok, thanks! Support ticket G2327984 created!

Userlevel 7
Badge +17

Thanks!

 

Badge

I have the same problem. Could you known when answer for a ticket will be ready and where to find it?

Userlevel 7
Badge +17

Hi @SORBJAHAU and @LsyPawelZ ,

 

We used to get the error Certificate is mismatching when we installed the IFS Aurena Agent but we discovered if we save the MSI file to a local directory on the C: drive like C:\Trash if we open a command window then run that command window as Administrator if you install the MSI file now we no longer get that error.   An for the most part the IFS Aurena Agent is working as you’d expect.   

 

Regards,

William Klotz

Userlevel 7
Badge +17

Hi @SORBJAHAU and @LsyPawelZ ,

 

We used to get the error Certificate is mismatching when we installed the IFS Aurena Agent but we discovered if we save the MSI file to a local directory on the C: drive like C:\Trash if we open a command window then run that command window as Administrator if you install the MSI file now we no longer get that error.   An for the most part the IFS Aurena Agent is working as you’d expect.   

Thanks for that. Is that interactive installation using the GUI or solely from the command line (so called "silent" installation)?

 

Userlevel 7
Badge +17

Hi @Mathias Dahl ,

 

We use the interactive installation using the GUI I haven’t tried the silent installation but we will be trying it as we begin to rollout Aurena to all our users.

 

Reguards,

William Klotz

Userlevel 7
Badge +17

Hi @Mathias Dahl 

I haven’t tried the silent installation but we will be trying it as we begin to rollout Aurena to all our users.

From what we have heard, silent installation is currently broken. We don't know why or when it broke but it will be fixed as soon as we can find the cause of the problem.

Just a heads-up.

 

Badge

In my case this way doesn’t work. is there any other solution?

Userlevel 7
Badge +17

In my case this way doesn’t work. is there any other solution?

Can you describe what you tried in more detail, and what happened and what did not happen?
 

Badge

I tried all the above solutions in turn. Nothing helped.

Userlevel 7
Badge +17

I tried all the above solutions in turn. Nothing helped.

Helped for what? I am not sure what problem you have here. Can you provide screenshots of your particular problem? Is it the silent install problem or the problem @LindaK reports at the top of this discussion? One can have a few different problems with the Aurena Agent.

 

Userlevel 2
Badge +2

@Mathias Dahl 

I do get this mentioned error upon installing AurenaAgent and accessing the User Setting page, but to be honest I don’t know what’s the impact of it to DocMan functionality and etc..

 

Here with I attached detailed document explain how to reproduce the error, not sure its framework issue.  May be the error we received in user settings page have no impact but of course customers doesn’t like to see such error :-)

 

Please let me know if I provide you enough information or I should ask this question in different category. 

By the way workaround mentioned by @william.klotz  didn’t work for me, that is “We used to get the error Certificate is mismatching when we installed the IFS Aurena Agent but we discovered if we save the MSI file to a local directory on the C: drive like C:\Trash if we open a command window then run that command window as Administrator if you install the MSI file now we no longer get that error.   An for the most part the IFS Aurena Agent is working as you’d expect.   

Userlevel 1

Hi Mathias,

If you are not running MSI file as Administrator, then Administrator need to go to   C:\Users\<USER>\AppData\Local\IFS\IFSAurenaAgent and select IFSAurenaAgent.exe use RMB and choose properties and do a Digital Signature.

Can a Microsoft Certificate Signature on IFSAurenaAgent.exe help us to avoid the need to be Administrator to install the MSI file correct with no error?

Best Regards,

Geir

Reply