Solved

Background jobs are not running in multiple queues

  • 11 September 2020
  • 3 replies
  • 73 views

Userlevel 3
Badge +5

We are running Apps10 UPD6

Our training environment is not running background jobs in multiple queues.  Looking for ideas on how to fix this issue. 

  1. Our default queue and other queues we setup for specific tasks do not seem to be running
  2. We have a backlog of jobs in status = Posted
  3. In these queue - the most recent jobs in status = Ready is several days (if not weeks) old
  4. Tried setting the queue to Inactive - then Active - no change
  5. Tried using the RMB Init Queue option - no change
  6. Tried restarting the environment - no change
  7. Tried deleting oldest job in Posted status - no change.

 

icon

Best answer by william.klotz 11 September 2020, 21:13

Hi @jhooperyan ,

 

Make sure you do not have any background jobs executing from default queue.  You want to make sure nothing is blocking the rest of your background jobs.  You also want to make sure the parameter JOB_QUEUE_PROCESSES is set to a value greater than zero.  We use 10 for our Development and Test environments.  If the JOB_QUEUE_PROCESSES parameter is set to zero background jobs will not execute and you’ll see everything sitting there waiting to be executed.   We ran into this during one of our IFS 8 to IFS 10 upgrade test runs where we forgot to set the JOB_QUEUE_PROCESSES to 10 and the symptom was no executing background jobs.   Below is a screenshot from our development environment.   You’ll need your Oracle DBA to check the parameter and change it if necessary.

 

 

Regards,

William Klotz

 

 

View original

3 replies

Userlevel 3
Badge +8

Hi @jhooperyan ,

 

Make sure you do not have any background jobs executing from default queue.  You want to make sure nothing is blocking the rest of your background jobs.  You also want to make sure the parameter JOB_QUEUE_PROCESSES is set to a value greater than zero.  We use 10 for our Development and Test environments.  If the JOB_QUEUE_PROCESSES parameter is set to zero background jobs will not execute and you’ll see everything sitting there waiting to be executed.   We ran into this during one of our IFS 8 to IFS 10 upgrade test runs where we forgot to set the JOB_QUEUE_PROCESSES to 10 and the symptom was no executing background jobs.   Below is a screenshot from our development environment.   You’ll need your Oracle DBA to check the parameter and change it if necessary.

 

 

Regards,

William Klotz

 

 

Userlevel 3
Badge +6

As @william.klotz has mentioned, job_queue_processes parameter would be the first thing to check. The value that needs to be set for this parameter actually depends on the number of Batch Queues you have and the number of processes assigned for each queue. 

The formula to calculate the minimum number of job_queue_processes needed is following:

“Value for JOB_QUEUE_PROCESSES” = "The sum of processes assigned for each queue” + “5 more processes for Oracle internal jobs”

Apart form this, go to Database Processes window in IEE and check whether there are processes for each queue. Initializing the queues would create these processes if they are not there.

If those check out okay, then the problem could be in the database scheduler, in which case restarting the database should work. 

Userlevel 3
Badge +5

Hi @jhooperyan ,

 

Make sure you do not have any background jobs executing from default queue.  You want to make sure nothing is blocking the rest of your background jobs.  You also want to make sure the parameter JOB_QUEUE_PROCESSES is set to a value greater than zero.  We use 10 for our Development and Test environments.  If the JOB_QUEUE_PROCESSES parameter is set to zero background jobs will not execute and you’ll see everything sitting there waiting to be executed.   We ran into this during one of our IFS 8 to IFS 10 upgrade test runs where we forgot to set the JOB_QUEUE_PROCESSES to 10 and the symptom was no executing background jobs.   Below is a screenshot from our development environment.   You’ll need your Oracle DBA to check the parameter and change it if necessary.

 

 

Regards,

William Klotz

 

 

This was the root cause.  Don't know how, but somehow this value got set to 0 in our Support environment.  I’m not waiting for IT to confirm they know how to update that parameter.  Thanks!

Reply