Solved

PLUGIN EXCEPTION:ifs.fnd.base.SystemException: PluginExecute Failed. OutputBinary falied printer is null- zebra printer label issue

  • 5 October 2022
  • 10 replies
  • 143 views

Userlevel 1
Badge +4

Hi All,

One of our customer needs to setup Zebra printer to print labels.Customer use  ifs application 10 update 14 version. Before setup physical printer, we installed clawPDF(Open Source virtual PDF printer for Windows) and tried . But we got below error every time when we print a report

 

PLUGIN EXCEPTION:ifs.fnd.base.SystemException: PluginExecute Failed. OutputBinary falied printer is null

Here i attached ifs-printagent-config file

we used both .net and java print agents. but the same error occurred for both PA.

here I attached ifs-spooler-config details as well

Can you check and kindly give me an answer

 

Thank You

Saradha

 

icon

Best answer by Shanaka Tennakoon 24 October 2022, 09:30

View original

10 replies

Userlevel 7
Badge +17

Hi @LevSupunS ,

Please attach the plugin report layout that is being used for this. 

 

Thanks,

Kasun

Userlevel 1
Badge +4

Hi @Kasun Balasooriya ,

thanks for response

here i attached it

 

 

Userlevel 1
Badge +4

Hi @Kasun Balasooriya ,

Is anything new about this issue? 😊

 

Thanks

RMS saradha

Userlevel 5
Badge +9

@LevSupunS 

Hi Saradha, 

do you need to set up the logical printer in the printer defination for the IFSPRINTER user ?
 


Best Regards, 
Kapilan 

Userlevel 1
Badge +4

Hi @Thirunavukkarasu Kapilan ,

 

yes, i already setup it, also set report printer function which shows in your picture

 

Thank You

RMS saradha

Userlevel 5
Badge +11

Hi @LevSupunS ,

 

I can see that your Socket spooler is set to OFFF in  ifs-printagent-config file

 

/Shanaka

Userlevel 5
Badge +11

Hi @LevSupunS ,

 

I assume that you have missed below configuration part in report formatter. check if  you have mapped logical printer and the print agent like this

 

 

Userlevel 1
Badge +4

 

As you mentioned here, we set up configurations in the task template and it shows print is complete in print manager.but it was not print, when i check logs it mentioned ‘Enviornment variables not defined’ error, but we already defined it 

Do you know how to troubleshoot this or what's the issue with this?

Can you kindly look this

 

Here i attached printagent config and spooler config images.

 

Thank you 

RMS Saradha

Userlevel 1
Badge +4

@Shanaka Tennakoon  Please look above comment

Thank you

Userlevel 5
Badge +11

Hi @LevSupunS ,

 

Since you already disabled the print agent it won’t start so no need to check any configuration there. The issue I can see is that the physical printer you have given in the task template is not correct. Give the ip address or the machine name(if it’s in the same network) where the socket spooler is running

 

/Shanaka

Reply