Solved

Oracle patch installation failing only in Prod Environment

  • 18 April 2021
  • 2 replies
  • 1259 views

Userlevel 2
Badge +3

We are facing issues during the Oracle patch installation in Production Database. But we have successfully installed the Oracle patches to TEST and TRNG environments.

Error in file : sqlpatch_invocation.log

SQL Patching tool version 12.2.0.1.0 Production on Thu Apr 15 20:39:23 2021
Copyright (c) 2012, 2020, Oracle. All rights reserved.

Build label: RDBMS_12.2.0.1.0WINDBBP_WINDOWS.X64_191230.3
Log file for this invocation: D:\app\cfgtoollogs\sqlpatch\sqlpatch_10136_2021_04_15_20_39_23\sqlpatch_invocation.log

SQL Patching arguments:
verbose: 1
force: 0
skip_sql_state_check: 0
prereq: 0
upgrade_mode_only:
oh:
bundle_series:
ignorable_errors:
bootstrap:
skip_bootstrap:
skip_upgrade_check:
userid:
pdbs:
noqi:
app:
binary_config:
recomp_threshold: 300

Connecting to database...OK
catcon: ALL catcon-related output will be written to [D:\app\cfgtoollogs\sqlpatch\sqlpatch_10136_2021_04_15_20_39_23/sqlpatch_catcon__catcon_10136.lst]
catcon: See [D:\app\cfgtoollogs\sqlpatch\sqlpatch_10136_2021_04_15_20_39_23/sqlpatch_catcon_*.log] files for output generated by scripts
catcon: See [D:\app\cfgtoollogs\sqlpatch\sqlpatch_10136_2021_04_15_20_39_23/sqlpatch_catcon__*.lst] files for spool files, if any
start_processes: failed to open (Resource temporarily unavailable) pipe to SQL*Plus

catconInit failed, exiting

Please refer to MOS Note 1609718.1 and/or the invocation log
D:\app\cfgtoollogs\sqlpatch\sqlpatch_10136_2021_04_15_20_39_23\sqlpatch_invocation.log
for information on how to resolve the above errors.

SQL Patching tool complete on Thu Apr 15 20:39:26 2021

Any idea on what can be the root cause and a solution for this issue?

icon

Best answer by Chathuranga Samarakoon 18 April 2021, 17:20

View original

This topic has been closed for comments

2 replies

Userlevel 6
Badge +12

@Sachinthani Wanniarachchi  Below solution will solve your issue.

 

APPLIES TO;

Oracle Database - Enterprise Edition - Version 12.1.0.2 and later
Information in this document applies to any platform.

SYMPTOMS

On : 12.1.0.2 version, Patching

datapatch -verbose fails with catconInit failed, exiting


start_processes: failed to open (Bad file descriptor) pipe to SQL*Plus

catconInit failed, exiting

 

CAUSE

The Catcon.pm will default to cpu_count*2. so this can be very high and it can exhaust process counts on the database.
 
See the following error:

start_processes: failed to open (Bad file descriptor) pipe to SQL*Plus

catconInit failed, exiting

 

SOLUTION

Validate the cpu_count via below command and put the value lower if it is high.

SQL> show parameter cpu

Temporarily set CPU_COUNT to a lower number.

ALTER SYSTEM SET CPU_COUNT = 4;

Perform datapatch and validate the status.

Once done you can set it back to the original number

ALTER SYSTEM SET CPU_COUNT = 48;


Refer this article from Oracle: https://support.oracle.com/epmos/faces/DocumentDisplay?_afrLoop=33678735976502&id=2540548.1&_afrWindowMode=0&_adf.ctrl-state=c04wiz2da_4

Userlevel 2
Badge +3

Thank You @Chathuranga_S. With this input we were able to fixed the issue and Prod is now up and running with the Oracle patch.