Crystal Report using Operational REP Error Message: No PDF report returned from Crystal Web Service | IFS Community
Solved

Crystal Report using Operational REP Error Message: No PDF report returned from Crystal Web Service


Userlevel 7
Badge +16

Report x works in Crystal Reports and other Crystal Reports work in the IFS instance.

 

However, when we run report x in the IFS instance we receive the following message:

 

 

When I went to check the Crystal Reports log for this instance there was no Crystal Reports log.

 

On noticing that there were no error logs I ran CR_Web_Log.exe that resided in folder C:\inetpub\wwwroot\IFSCRWebSetup_IFSR

 

 

After clicking on Save and Close I checked the ifs-crystal-config.xml file:

 

 

I logged out of Enterprise Explorer for the instance concerned and logged back in again and tried running the report again, same error received (as expected) but the only thing in the Log file:

 

 

 

Please note, report x works in all other IFS instances.

 

Can anyone please advise what I have missed or where I am going wrong.

 

Thank you.

 

icon

Best answer by Srikanth 1 June 2020, 21:50

View original

2 replies

Userlevel 6
Badge +16

Hi,

For CWS to start writing log entries, it needs the following Windows Permissions setup for Open Reports and inetpub directories on the server hosting CWS:

Restart IIS after adding the above permissions.

Userlevel 7
Badge +16

@Srikanth I decided to disable the logging and then enabled it again but changed the path to F:\IFS\IFSCrystal\IFSR\logs and the logging started working without any issue. 

 

Thank you very much for pointing me in the right direction.

Reply