Question

Smart client getting Object reference error

  • 4 October 2022
  • 4 replies
  • 56 views

Userlevel 1
Badge +2

The issue was, whenever the customer tried to work with smart client, the Object reference not set to an instance of an Object error was popping out intermittently.

This is not happening for a specific functionality or screen. Randomly the error get triggered. Customer only start to face this issue after upgrade the FSM from 12 to 18. Once the error triggered, the user can see the same error message in the other screen as well. After the relogin this issue is not happening for a while, and but some time later again the same error triggered.

Based on the log file investigation, I have found that issue in the authentication session token. So customer is facing this issue only login through the SSO credentials. But they didn’t get this issue whenever using FSM credentials.

What can be the possible solutions to sort out this issue?

The detail error message:-

<hierarchy_select>
  <attrs>
    <attr>ps_setting_value.screen_name</attr>
    <attr>ps_setting_value.person_id</attr>
    <attr>ps_setting_value.form_factor</attr>
    <attr>ps_setting_value.setting_name</attr>
    <attr>ps_setting_value.value</attr>
  </attrs>
  <primary_table>ps_setting_value</primary_table>
  <from>
    <table>ps_setting_value</table>
  </from>
  <authentication>
    <session_info>
      <token_id>TIELv3l+YfkXN8pdn5ISNuTi+EYuGH3UgMKXs0FSLxwPkfJqVWAqba8kmgouDh46Rt1P/nusoDhZ4CmrsbmzCYiHXb6o/Tm8D/AafQjd+bhSjUDO7y5B4AV9SQ6gtrzY</token_id>
      <session_id>2OwZYU9/fQMxHU2kPmObj0fGe73rOQdtZn3JCaPLUDT6sayelArEpjUK7F2rIx9sEuj8KG5GNzQY3I2B7Z+Ong==f4+rP3Hg3YzcyEtxtEvETw==g3YW/QTPxrpcEtJ4CMAomQ==</session_id>
      <tenant_name>
      </tenant_name>
      <workstation>
      </workstation>
    </session_info>
  </authentication>
  <where>
    <data_constraint>
      <constraint>
        <left_operand>ps_setting_value.screen_name</left_operand>
        <operator>eq</operator>
        <right_operand>STANDALONE_WINDOW</right_operand>
      </constraint>
      <constraint>
        <left_operand>ps_setting_value.person_id</left_operand>
        <operator>eq</operator>
        <right_operand>EKNOPTJ</right_operand>
      </constraint>
      <constraint>
        <left_operand>ps_setting_value.setting_name</left_operand>
        <operator>eq</operator>
        <right_operand>ABOUT</right_operand>
      </constraint>
    </data_constraint>
  </where>
</hierarchy_select>

<metrix_response>
  <result type="Exception">
    <error>
      <system_error>
        <severity>ERROR</severity>
        <message>Object reference not set to an instance of an object.</message>
      </system_error>
    </error>
  </result>
</metrix_response>


4 replies

Userlevel 7
Badge +23

Hi @Dilushkumar Vasudevan,

Sounds like there has been a timeout on the SSO token. Does this only occur after the client is left for some time?

I would first check the client timeout settings within FSM. There may also be a timeout setting on the SSO provider.

Kind regards,

Lee Pinchbeck

Userlevel 1
Badge +2

Hi @Lee Pinchbeck 

Yes, customer is getting error in one case where they opened the smart client and opened any screen to make sure the smart client is not giving error and then they left the system unused for 40-50 mins straight, then error is observed every time.

 

Thanks & Best Regards,

Dilushkumar

Userlevel 7
Badge +23

Hi @Dilushkumar Vasudevan,

This is a client timeout issue then. If you require it longer than the 40-50 mins you will need to set the client timeouts longer in FSM and in the SSO.

Kind regards,

Lee Pinchbeck

Userlevel 1
Badge +2

Hi @Lee Pinchbeck Thank you for your input.

Best Regards,

Dilushkumar

Reply