IFS Cloud Excel Add-in

  • 1 February 2022
  • 11 replies

Userlevel 7
Badge +18

Hi All,

Couple of our customers have raised a concern that they are not getting the option to upload the manifest file from the Excel desktop client. However, they are able to upload it to the Excel web client. 

Steps that were followed :

Any idea what the issue could be?


Best answer by Jens 21 February 2022, 16:03

View original

11 replies

Userlevel 4
Badge +3

This is a possible solution for installing the IFS Data Migration Excel-AddIn in the desktop app of Excel in 21R2. It only works with Excel 365 at the moment. Excel 2016/2019 are not working at the moment (you can install it in the same way but if you press the logon button nothing happens).

1. In IFS Cloud go to Solution Manager -> Data Management -> Data Migration -> Excel Migration -> Generate Manifest
2. Enter a file name, e.g. IFS Excel AddIn - - CFG, and press Generate
3. Save the file to a local Folder, e.g. C:\IFSAddIn
4. Mark the folder C:\IFSAddIn and RMB Properties
5. Go to tab Sharing and press Share
6. Select your name/user and press Share
7. Press Done, note the Network Path(!), e.g. \\DEVICENAME\IFSAddIn and then Close
8. Open Excel, choose a new Blank Workbook
9. Go to Options
10. Choose Trust Center
11. Select Trust Center Settings..
12. Select Trusted Add-in Catalogs
13. Add your shared folder to the Catalog Url. E.g. file://DEVICENAME/IFSAddIn (the slashes are now the other way around)
14. Tick on Show in Menu, OK, OK
15. Close Excel and open it again
16. Choose a new Blank Workbook
17. Go to Insert in the menu
18. Choose My Add-ins
19. Select tab Shared Folder
20. Now you should see you file, e.g. IFS Excel AddIn - - CFG.xml
21. Select and add it
22. Close Excel and open it again
23. Choose a new Blank Workbook
24. Now you should see your IFS Excel Add-in in the menu in the right corner

Userlevel 7
Badge +18

Hi @Jens,


It worked! Thanks for the guidance.

Userlevel 3
Badge +5

Hi, I have followed the above instructions and I got the Excel AddIn in the menu bar as you mentioned, but when I click on it  it gives the following error 



I am getting the same below error after following the above steps.  Any particular certificate needs to be installed? Any quick response would be greatly appreciated! Thank you.


Userlevel 5
Badge +10

This is marked as an obsolete product in the later versions of the GPL 2.5B. What is the replacement product for this functionality in 2021R2 and 2022R1?

Userlevel 7
Badge +18


It worked. You made my day better, and thus the world.

Badge +1

Hi Jens,

I have followed your process to excel add in but got stuck while clicking in login button in excel. Can you guess what will be the issue and suggest some method to resolve.



Badge +1

This is marked as an obsolete product in the later versions of the GPL 2.5B. What is the replacement product for this functionality in 2021R2 and 2022R1?

Do you have any updates on replacement product? 




Userlevel 1
Badge +2

The ADD-IN ERROR (The content is blocked...)
appears for me when there is no network connection to the IFS server.

My server is behind a VPN that needs to be opened. If the VPN is closed I get this error.
If it's open everything works fine. It is also possible that traffic is filtered, so check your network.

For this reason it was not possible to use the web excel either, since there is no connection from the public internet. It works fine now with the Excel 365 program on the local computer, but we did have to edit the hosts file since the VPN includes a NAT and addresses for the certificates were not matching at first. You might need a special permission, perhaps with a ticket to your IT to edit it.


The Login button is supposed to open the IFS Cloud window in a browser-like pop-up.
This works fine for me, and after logging in to IFS Cloud the Add-in works fine.

Userlevel 1
Badge +2

We don't have privileges to make shares, so we used the default admin share to install.

For example if the manifest is downloaded to C:\IFS this can be accessed from
\\loclhost\c$\IFS (fix the ‘a’ as that seems to be a forbidden word in community)
directly without making a new share. This allowed us to do the install.

Permissions have to be granted then from the IFS web interface both from the permission sets (for every new job a new projection) and from the migration jobs.

Userlevel 1
Badge +2