Middleware deployments will not start

  • 15 March 2023
  • 3 replies

Userlevel 2
Badge +6

Hi everyone,

I have a IT1 apps10 testing instance that until recently was working fine, now all of a sudden certain deployments have stopped working - namely ifsapp-main (in MainServer), ifsapp-int and ifsservices in IntServer.  When I try and restart them I get the error “ Error occurred while performing startApplication : Failed to start the application with status failed

Can anyone point me in the right direction to sort this out?


Best answer by Hypervox 16 March 2023, 15:45

View original

3 replies

Userlevel 4
Badge +6

Have you tried a reconfiguration of the application server?

Please try below options.

  1. Restart middleware server using the script.mws-svr.cmd found in ifshome folder.
  2. Reconfiguration of the middleware server.
Userlevel 7
Badge +25

Hi @Hypervox,

In addition to what Jagath has mentioned above, you can also have a look at the answer in following post.

Regardless of whether you can see the .ear files or not, as mentioned in the 4th step, go through all the steps mentioned in the answer. 

Hope this helps!

Userlevel 2
Badge +6

Thanks guys,

I tried both options (learned a lot in the process too ;) ) and the reconfigure failed on the first step - because it couldn’t contact the database.  Turns out someone has shut the container database down and not told me - as soon as I started the container database (and pluggable) again, the deployments started working again.

So, I should have checked the database first (my bad) - in my defence it had no reason to be down and I had checked it earlier in the week, so I assumed it was fine.  That’ll teach me :)

Once again, thanks for your help.