Question

Connectivity Inbox (INVOIC) message line stuck in posted

  • 10 June 2021
  • 0 replies
  • 29 views

Badge

Hello,

I am trying to implement receiving supplier invoices in XML format via IFS Connect.

I have set up connector reader and attached to CONNECT_SERVER1 server. I’ve set up the appropriate routing address (linked to InboundDistributionTransactions:ReceiveSupplierInvoice) and routing rule.

I am using the XML format as described at http://host:port/fndext/soapgateway?handler=InboundDistributionTransactions&op=ReceiveSupplierInvoice&type=xml_request

When I put an XML file in this format into the correct folder the connector reader ingests it and it disappears from the folder as I would expect.

I can then see within the Application Messages queue that the XML has been processed and has the status ‘Finished’.

The destination Address (InboundDistributionTransactions:ReceiveSupplierInvoice) using the Connector BizAPI also has the status ‘Transferred’.

Application Message

If I then go to ‘Explore Connectivity Inbox’ I can see the message with status ‘Accepted’. If I look at the details of this message there is no error text but under ‘Lines’ I have two rows, one for row and one for header both with the state ‘Posted’ as shown below.

Connectivity message details

I can’t find the invoice anywhere so I assume it has not yet been processed.

I’ve checked system parameters and the Connectivity processes are enabled

System parameters


When I check the database processes I can see the processes are running and not reporting any errors, however when I right click and ‘View background jobs’ there are no background jobs for either of these processes despite it having ’run’ many times.

Database processes

 

No background jobs

However, when I view the background jobs for other database processes (such as Transaction_SYS.Process_All_Pending__(0, ‘Default Queue’, ‘%’, job_id_)) I do see background jobs for that process.

Can anyone help me understand what is going wrong?

Many thanks

 


0 replies

Be the first to reply!

Reply