Issue
Purchase Orders (page) > Order Date (field) – Not working correctly - PURCH This was supposed to be fixed in UPD23 but fixed in UPD24
Steps:
Go to "Purchase Orders" window > Populate all POs
Search from Order Date for "Exact Date". In my case I tried to search 9/14/2022 but no data found.
Cause:
The reason for this error lies in the database where the data is saved as "Timestamp" in the Purchase_Order table.
Resolution:
Based on the findings of the issue, a JIRA ticket (SCZ-25165) was generated to address it. The R&D team committed to resolving the ORDER DATE issue and incorporated fixes in the UPD23 release as outlined in the ticket. However, the error persisted in UPD23 but was successfully rectified in UPD24. The bug ID for this resolution is 168570.