Solved

Configuration combination not returning the correct value

  • 22 September 2022
  • 2 replies
  • 39 views

Badge +1

 

Hi,

A Part is having 5 characteristics A,B,C,D,E

Configuration combinations tables are using all characteristics and returning values.

But from sales rules, it has been defined to detach a characteristic B when selecting an Option value from A,
But There is a Value defined in Configuration combination using characteristic B.

Due to detach of characteristic B, There is an error in Interim order header, component defined in Configuration combination table is not returning to the structure….

Any known fix for the issue?

more example…….

As from above example shown in picture 20-AO_QTY is the characteristic that detach when selecting DP from 20-COMP-CONT Characteristic. 1 is the default value for 20-AO QTY.
if there is a value in 20-AO QTY, it is not passed the connected component
 


Default value is return, not the connected value.

when we empty the value in 20-AO_QTY, then correct value will be returned.

icon

Best answer by Tharindu Sooriyaarachchi 23 September 2022, 08:18

View original

2 replies

Badge +1

Dear @Tharindu Sooriyaarachchi,

Current UPD is 11 and this solution works. Thank you for the feedback.

Thanks
Suresh

Badge +3

Hi @MAYURASR1989,

 

In which UPD are you getting this issue? Before the UPD 15, the null values were not considered in the Config_Combination_Table_API.Get_Combo_And_String__ method and no values returned. This has been fixed by the UPD15 patch: 162313 to return the configuration component. Probably this will fix your issue.

 

Best Regards,
Tharindu

Reply