Question

Why do I receive Server Errors in Employee Page after recent upgrade?

  • 17 January 2023
  • 0 replies
  • 283 views

Userlevel 5
Badge +9

ISSUE/QUESTION:  

There’s a generic Server Error thrown when navigating to Employee Page. And the issue can be reproduced consistently even if there’s no data or without populating the screen. 

This issue started after an upgrade/installation, and you have many custom fields in place. 

 

Error text: “Server error Sorry, there was an unexpected server error” 

 

ENVIRONMENT:    Aurena Client (IFS Cloud 21.2.14)

 

PRODUCT AREA: Custom object framework and HCM
 

AUDIENCE:  ALL

 

RESOLUTION/ANSWER: 

 

Steps:

  1. Check if end user has required permissions. Verify if you get the same error using an admin users such as ifsadmin or IFS application owner user. 

  1. If it’s not a permission issue check if there’re custom fields on the screen.  

  1. Finally, republish the custom fields that are in use. And check if the server error still exists.

CAUSE:

The metadata for the projection “PersonnelFileCompensationHandling” hasn't been properly deployed in the environment. The issue was with the custom fields created for the “Employee Salary Information” block in the Compensation window. Need to republish custom fields to correct this metadata.

 

SOURCE: CS0102588


0 replies

Be the first to reply!

Reply