Question

Application servar task mail body


Userlevel 3
Badge +6

Hi,

I want to send quick report with Application server task. But I cant change my Mail body. If use br tag

I got error..


13 replies

Userlevel 7

Hi,

I want to send quick report with Application server task. But I cant change my Mail body. If use br tag

I got error..

Can you maybe share some more details? I’m assuming that by ‘br tag’ you mean line break? 
Can you try using CHR(13) or CHR(10) instead?

Userlevel 3
Badge +6

Yes, Break line.

But I want to put in the mail body. Not in report. 

 

Userlevel 7

Yes, Break line.

But I want to put in the mail body. Not in report. 

 

Ah, just a line break should be fine.
 

 

Userlevel 7
Badge +16

Just a guess…. Does a self-closing tag work?

<br />

Userlevel 3
Badge +6

It was doesn't work.

Userlevel 6
Badge +14

savasciftci,

Have you tried any other html tag like <div>...</div> or <p>...</p> or any other. My idea is that the mail is just not a html version.

When you receive the mail are you able to see the details of the mail. So what type of mail has been received?

Regards,

Steve

Userlevel 3
Badge +6

Mail source view like that.

 

Userlevel 2
Badge +3

If you are not sure about the HTML code, use this online compiler. I use it to develop the email content and past it in the IFS.

https://www.w3schools.com/html/tryit.asp?filename=tryhtml_elements

Userlevel 3
Badge +6

Hi @samglk 

I create mail body in this online compiler. But It was doesn't work.

Userlevel 2
Badge +3

Hi @savasciftci 

If you write correct HTML code and press Run button, you will get the output in the right window as below.

https://www.w3schools.com/html/tryit.asp?filename=tryhtml_elements

 

You can follow HTML tags and basics: https://www.w3schools.com/html/

Thank you.

Userlevel 3
Badge +6

@samglk  In compiler it is work. I got error in ifs.

 

Userlevel 2
Badge +3

@savasciftci 

This is an unhandle exception. It might be an issue in Application Server or IFS bug. It should be looked at separately. Error seems the issue is in Locale, at the translation segment. Try the same using English as well.

If you enter details correctly it would work.

 

Userlevel 7
Badge +15

Hi @savasciftci ,

 

Check your mail sender if it’s setup with content type text/html

That could be the reason behind yo are not getting the html formatted mail body

 

Reply