Topic environment for 24R1.0 fails with no errors in log

  • 11 June 2024
  • 5 replies

Userlevel 7
Badge +17

 I’m trying to upgrade a customer environment to 24.1.0. All is well until I get to create the topic environment. I’ve tried that step twice and everytime the environment creation failed.

The strange thing about this is that there’s no obvious error in ifs_ant_generateddb log file. Every time the process seems to be killed during code generation (every time the piece of code generated was different).

I’m wondering if there’s anyone experiencing the same weird behaviour?

  • On the 10th of June it failed when trying to generate the code for ObjectPhysicalCountHistory.client
  • On the 11th of June it failed when trying to generate the code for PartCostBucketVariance.client



Best answer by SHAUN_KERSLAKE 11 June 2024, 13:30

View original

5 replies

Userlevel 5
Badge +11

@Marcel.Ausan Hi I have experienced Build Place issues over the past month and raised with IFS Support.

Apparently, there has been Azure resource issues since 7th May with VMs located in North European region. This has caused failures in environment creation or deletion in the build place. 

We had an environment fail, and it wouldn’t delete so Support had to remove behind the scenes. 

Eventually after re-trying it worked...

Userlevel 3
Badge +10

Hi, we have had similar problems to Shaun with Build Place (we are also North Europe), although in our case what happens is that the build fails and doesn’t produce any logs.  We’ve had a total of 4 instances of this during the second half of May.  We can’t delete the failed build or use our second environment after this happens.  IFS Support have to remove the failed build before we can try again.

I guess our symptoms are slightly different, but if you’re in North Europe it’s definitely worth checking with IFS Support.

Userlevel 7
Badge +17

@SHAUN_KERSLAKE  @MMcK thanks for the confirmation that there’s something strange going on with the processes in the Buildplace. I’ve also raised a support case with IFS.

I’ll continue deleting / recreating the topic environment. Hopefully I’ll get better luck next time 😀. Or I go ahead and do the PR to release-update branch directly, by-passing the topic environment creation 😁  

Userlevel 4
Badge +10

@Marcel.Ausan  yes there seem to be issues with building delivery environments. This is from today.

It would be so much more helpfull if they just add a notification to show there are downtimes with the lifecycle portal.


Userlevel 7
Badge +17

Thanks @kvbe. I also got confirmation from IFS Support that it was an issue with the VM Template: