How to schedule database tasks? | IFS Community
Question

How to schedule database tasks?

  • 21 June 2022
  • 6 replies
  • 107 views

Userlevel 4
Badge +10

We want to schedule a procedure daily. I set the schedule as every minute to test. The procedure does not have any parameters. It is sending the task to the background jobs when I run it manually. However, it does not work while we are scheduled. The schedule is not sending the task to the background job. There can be a problem with parameters, queues, or something else. From where do database schedules trigger? And How can we schedule database tasks?

 

 


6 replies

Userlevel 7
Badge +17

Hi @hhy38,

I am assuming your other background jobs are being scheduled just fine. From Batch Queue Configuration window in IEE, try assigning this database task to a particular queue, if you haven’t already done that. Also try increasing the schedule interval to something like 10 minutes and see if there is a difference. 

Hope this helps!

Userlevel 4
Badge +10

Hi @hhy38,

I am assuming your other background jobs are being scheduled just fine. From Batch Queue Configuration window in IEE, try assigning this database task to a particular queue, if you haven’t already done that. Also try increasing the schedule interval to something like 10 minutes and see if there is a difference. 

Hope this helps!

The same scenario is working on Prod. But, In the Test, there is a problem. I think someone closed something. Last week when I checked the batch queues. All of them were inactive. I activated them.

Userlevel 4
Badge +9

Hi @hhy38 ,

 

Try reinitializing batch queues. If you have done changes to the batch queues in some way then this might happen. Again I am not 100% sure why it is not triggering. 

Go to Batch queue configuration → Right click on top level of all the batch queues and click “Init All Batch Queues.” Hope this helps.

Thanks

Best Regards

Nadeesha Liyanage.

Userlevel 7
Badge +15

Hi @hhy38 Hasan,

 

If Initialize batch queues does not help, then it could be due to oracle parameter job_queue_processes is set to 0 which is a common problem after a delivery/env copy. Check following forum thread and set the job queue processes to resume background jobs.

How do I properly set the job_queue_processes parameter in the database to match my Batch Queue Configuration ? | IFS Community

 

Cheers!

Damith

Userlevel 4
Badge +10

Hi @hhy38 ,

 

Try reinitializing batch queues. If you have done changes to the batch queues in some way then this might happen. Again I am not 100% sure why it is not triggering. 

Go to Batch queue configuration → Right click on top level of all the batch queues and click “Init All Batch Queues.” Hope this helps.

Thanks

Best Regards

Nadeesha Liyanage.

Thank you. But, It does not work.

Userlevel 4
Badge +10

Hi @hhy38 Hasan,

 

If Initialize batch queues does not help, then it could be due to oracle parameter job_queue_processes is set to 0 which is a common problem after a delivery/env copy. Check following forum thread and set the job queue processes to resume background jobs.

How do I properly set the job_queue_processes parameter in the database to match my Batch Queue Configuration ? | IFS Community

 

Cheers!

Damith

I started a new work. So, I don’t have the SYS password. I will check next week. Thank you Damith.

Reply