Question

Aurena - Counter Lobby Element navigation to overview window

  • 20 July 2021
  • 5 replies
  • 86 views

Userlevel 1
Badge +4

Hi,

This is for Apps10 UPD12 customer.

I have a counter lobby element which shows the correct value. I have added navigation to this, only by selecting data source condition. When navigated, it takes me to the correct overview page, but populates with all the data.

End of the URL has a value <<usedefaultfilter=true». If I remove this or set this to false, then it shows the correct data. Where is the above value set to true from? is it possible to have it removed when navigating or setting it to false, instead of true?

Everything works as expected in IEE.

I followed instructions from the below thread but still not able to get it to work due to the above item. 

Can you please help?

Thank You & Best Regards


5 replies

Userlevel 7
Badge +12

@khtdinesha 

Hi Dinesha,

The option of showing all data, comes due to code defined in the page entityset. That is why it worked for supplier shipment lines, where it is not defined. In that screen, we don’t see a ‘Search all data’ button as well.  but in shop orders it has. 

On the other hand, this seems useful in terms of showing all data. But in the lobby navigation, it may be tricky. So it’s better to inform users about this toggle button. This seems to be the standard way in latest application. However if you have any more concerns after customer’s feedback, please feel to raise a ticket to review this further. 

Best Regards,

Userlevel 1
Badge +4

Hi Minoshini,

Thank you for the information. I was able to get the correct records by using the option you mentioned.

Since the user will have to do this every time they navigate from the lobby element, I am not how acceptable this solution will be. I have shared the details with them and waiting for their response.

Is there a way to default this or is it happening due to the settings in certain Aurena pages?

Thank You & Best Regards,

Dinesha Velivitiya

Userlevel 7
Badge +12

@khtdinesha 

Hi Dinesha,

I tried out a simple one for shop_ord and figure out why this happens. There is no issue in the lobby, but this occurs due to a setting in Aurena client.


As you have already noticed, this happens due to  « usedefaultfilter=true ». This addition in the URL and showing all the records are interconnected.

Actually we can toggle the “default filter” by using the "Search all records” button in the search panel. Once we toggle in “Search all records”, we will be able to see the custom search which results from lobby data source. 

And then you will be able to see your results.. :relaxed: 


Best Regards,

Userlevel 1
Badge +4

Hi Minoshini,

Thank you for your help. I imported the page and it worked as expected.

I modified your data source to use the view I was working with (SHOP_ORD) and changed the navigation to go to the shop orders window as needed.

However, it still brings all the records.

There are custom fields in this page. Would that cause a difference?

 

 

 

 

Thank You & Best Regards,

Dinesha Velivitiya

Userlevel 7
Badge +12

Hi @khtdinesha,

I will send you a simple example.
 

Data Source
Counter Element


Here we can see the lobby page in Aurena.
 


When we click on the count, it will redirect here.


Try this, and I think this should work for you. I will attach a simple lobby for your reference. If anything is differs from your lobby, let me know as well.​​​​​​​

Reply