Solved

404 Error

  • 14 January 2022
  • 2 replies
  • 225 views

Userlevel 5
Badge +12

Hi Community!
I am aware, that we already got several posts here for a 404 message. But this one seems odd to me.

History:

I have created a new database and imported a cloud based database dump into the database.

Using this db, I have now installed the MWS without issues.

 

I did this for a MIG2 environment and then for a TEST2 environment.

Interesting fact: MIG2 is working fine and TEST2 is getting the 404.

 

Using the debug console at start, you can see that a db connection seems not to work

 

In the logs, there are not really any hints for that

 

HTTP Access log

10.11.10.119 - - [13/Jan/2022:13:58:57 +0100] 00jD0m8LasS5mZ_5xRG7yW0001q400011B - "POST /main/default/clientgateway HTTP/1.1" 404 224 0

Displays a 404

 

no hint in the http server log

the rest of the logs do not contain anything regarding this as the access is not working.

 

the select which is pointed out here is working when connecting to the db directly

select lang_code_rfc3066 from &AO.language_code where installed_db ='TRUE' AND enabled_for_login_db = 'TRUE';

 

  1. PDB is open and state is saved
  2. Deployments are there
  3. restart of MWS is not having an error, but result is the same
  4. restart of DB and MWS do not change anything
  5. No Proxy
  6. all on the same server, no networking issues
  7. Aurena and B2B is not working as well
  8. All deployments can be stopped and started without issues

in some logs you can see, that the license is invalid, but that is okay and shows me, that the connection between MWS and DB is working somehow.

 

It seems that the clients are not connecting somehow.
Any ideas on that?

I already reinstalled the MWS. No change.

 

The next step would be to drop the DB again and install it anew including the datapump import.

 

Kind regards and thanks

Tobias

 

 

icon

Best answer by Technical Toby 17 January 2022, 12:05

View original

2 replies

Userlevel 5
Badge +12

An interesting fact on this!

 

I ran out of diskspace when doing the first installation due to having the db dump on the same server as well.

Removed all files and restarted the server afterwards. No issues then during the installation.

I checked all logs and tried to find a hint, but nothing helped.

Userlevel 5
Badge +12

Solution:

I have removed the TEST2 Instance and all files.
Afterwards, I have setup a new directory TST2 and installed IFS there.

Magic, it worked then. No 404 message, possible to login.

Regards
Tobias

Reply