Solved

Valid From Date of Approver for Voucher Approval

  • 10 January 2022
  • 1 reply
  • 44 views

Userlevel 5
Badge +8

We have a new Controller and we added her to the Voucher Approval workflow.

She started on 12/15/2021, but we backdated her in the Voucher Approvers screen to 7/1/2021.

We have a voucher that was created 1/5/2022, with a Voucher Date of 12/31/2021.  When she tries to approve it, we get the error Valid From date of the Approver should be earlier than the Voucher Date.

Can anyone help with what we are missing?

(IFS10 UPD9)

icon

Best answer by Shanuka Lashan 11 January 2022, 11:55

View original

1 reply

Userlevel 4
Badge +4

Hi

I checked your workflow in APP10 UPD9 version in IFS internal environments. Based on the given information, I tried to replicate a similar scenario in that environment. However, I was able to approve the voucher without any issue.

Below I have mentioned, how the basic data set up has been done.

As you can see in the above screen prints, ‘Approval Combination Rule’ has allowed the approver to approve vouchers with any combination of code parts (% is entered to all fields). Depending on the business requirement, you can change these combinations.

Also, if you have added the Approver/Approver Group to ‘Approver assigning rule’ window, make sure, the status is set to ‘Active’. This will only enable Voucher Approval Tab in Voucher Entry window. If this is not set up, user may need to Approve the voucher via ‘Approve Voucher’ window.

 

These are the specific basic data needed to while setting up the Voucher Approval Workflow. Other that that, you need to ensure User Group in which user is included is connected to Voucher Type. You can check this via Voucher Type window> RMB header> Voucher Series> Select the relevant year> RMB line> User Groups per Voucher Series window.

After setting up as mentioned above, I ran the Voucher Entry flow and voucher was approved without any issue. Few points I need to highlight, while I tested the flow are mentioned below.

Voucher Date is 12/31/2021

Entry Date is 1/11/2022

 

 

Please go through the above information and see if you have missed anything. If yes, try to run the flow with similar set up.

If that does not resolve the issue, you may check the same set up with a different user. Please let me know your testing results.

Kind regards,

Shanuka.

Reply