Solved

FSM 6 - Extract Rule not triggering


Userlevel 5
Badge +14

Hi,

 

We have an extract rule on a custom table for mobile that doesn’t appear to be triggering any data out to mobile.

A record is getting created. The extract rule for the table looks the same as other tables that are working just fine (e.g PART_NEED).

The sync rule looks fine, again as above no different to what we have for PART_NEED.

However when a record is created nothing is happening in terms data created to MM_MESSAGE_OUT for mobile to pick up.

 

What can I use to be able to root cause why? i.e. server logging.

Or is there a generic have you remembered to do ‘x’?

 

Any directions would be greatly appreciated.

 

Regards

yAdt

icon

Best answer by SAMLK 1 May 2024, 04:09

View original

13 replies

Userlevel 6
Badge +26

Hi @AdrianEgley 

When you run the sync rule in XML poster, do you get any results?

Cheers!

Userlevel 4
Badge +13

Hi Ady,

Could you share the expanded Addresses section for your custom sync rule here if possible?

Userlevel 5
Badge +14

Thanks both.

@Shneor Cheshin - yes I can take the Sync Rule and post that independently and both the Ownership and Related Query do what I would expect.

 

@SAMLK  - The expanded Addresses section for the sync rule on the extract are the same as others for Mobile.

 

Thanks again


Ady

Userlevel 6
Badge +26

Hi @AdrianEgley 

I am unsure what screenshot you attached in your comment, but it does not look like the sync rule screen.

Cheers!

Userlevel 5
Badge +14

@Shneor Cheshin 

Apologies, it’s from the extract rule for the table. I had assumed the expanded Address section referred to the Extract and not Sync. I then added the incorrect reference too.

But yeah its the addresses section from extract. I’m not 100% where an Address section would be on the sync rule tbh.

 

Ady

Userlevel 4
Badge +13

Thanks both.

@Shneor Cheshin - yes I can take the Sync Rule and post that independently and both the Ownership and Related Query do what I would expect.

 

@SAMLK  - The expanded Addresses section for the sync rule on the extract are the same as others for Mobile.

 

Thanks again


Ady

Hi Ady,

Did you manually create the extract rule or, was it automatically created after you defined the sync rule for custom table? Sorry for the delayed response!

Userlevel 5
Badge +14

@SAMLK 

I believe it was automatically created.

The Extract and Sync Rules go back to 2014.

But since going live with FSM6 (late ‘23) we’re seeing payments created in FSM not get passed to mobile. Going through the process nothing hits the mm_message_out table, therefore I am assuming it’s extract rule related.

Ady

Userlevel 4
Badge +13

Ady, 

Could you try to add a space on your initial query and save the sync rule? This would automatically adjust the extract rule if there was something missing in the config. Could you try this out and let me know the result? Also, how are the payments created? Is this bypassing the framework methods using custom code? Do you have any idea

Userlevel 5
Badge +14

Hi,

I have done that on the sync rule and even gone to the extent of deleting it to allow FSM to recreate. The extract still doesn’t seem to fire.

Payments are created a number of differents way, but ultimately it’s a post through the service either XML/JSON.

Ady

Userlevel 5
Badge +14

@SAMLK 

What is a bit more bizarre is that the Extract and Sync Rules work as intended in our Test Environment.

From checking mm_message_out in that environment I can see the message I’d expect to see from the sync rule. 

However in DEV and Live this simply is not happening.

Ady

Userlevel 6
Badge +26

@Shneor Cheshin

Apologies, it’s from the extract rule for the table. I had assumed the expanded Address section referred to the Extract and not Sync. I then added the incorrect reference too.

But yeah its the addresses section from extract. I’m not 100% where an Address section would be on the sync rule tbh.

 

Ady

HI @AdrianEgley 

Sorry, but I am not following, maybe @SAMLK has a better view of what you are trying to do.

Go to the ‘sync rule’ screen. Search and find your sync rule. Share the XMLs you have there.

I think the XML in the extract rule (your screenshot) is generic and identical to all objects. But it is the XML in the sync rule screen that is executed and determines what data is synced to mobile.

Cheers!

Userlevel 4
Badge +13

Hi Ady,

This is a little behavior! Could you backup your sync rule in DEV and remove both the sync rule and extract just to check there are no anomalies? Then recreate only the sync rule for the custom table. The extract is automatically created. Could you give it a try if possible? Also, the data in custom metadata, sync rule, extract are identical in both DEV and TEST? Do you see any errors on the server log or mobile log related to this?

 

Userlevel 5
Badge +14

@SAMLK / @Shneor Cheshin - thanks both.

I have located the issue, and apologies for not doing this first but the server logs started to put me down the right path. The recreation of the Sync and Extract rule may have helped. But it also turns out that extra columns had been added to the metadata for the table by the ‘METRIX’ account which I found odd. There aren’t in the database, so it was having an issue with that. So the mobile and server logs together helped also.

 

Thanks again for the time. Got there in the end.

Ady

Reply