IFS Cloud - WADACO - IFS Scan it : wrong pre-filled values

  • 15 September 2022
  • 5 replies

Badge +3

IFS Cloud 22R1 - WADACO - IFS scan it

Issue description : If I manually fill a value for a field, this same value is used for the next field.
When I choose a value in the list of values, the problem does not occur.
This problem does not occur in WADACO, I observe it only in IFS scan it.

example: configuration of register arrival: 

  • step 1: Purchase order no.
  • step 2: Part ID
  • step 3 : Serial number
  • step 4 : Condition code 

If I manually enter the PO N° before saving, the value is automatically pre-filled in the field of the next step (Part ID).
Similarly, if I manually enter the part ID, the serial number will be pre-initialized with the previously entered Part ID. 

Similarly, the condition code is initialized with the serial N°...


Question : Which configuration should I do to avoid this problem?


5 replies

Userlevel 5
Badge +11

In this case I would guess it is Use Automatic Value that is set to Fixed, turn it off to not get an automatic value.


Generally you get automatic/prefilled values from different settings the configuration, it can come from Default Value or Fixed Value fields (for Fixed it is depending on what setting you have in Use Fixed Value), or it comes from Use Automatic Value if that have been set to either Fixed or Default, it could also come from List of Value have been set to auto-pick, or it could come from Use Subsequent Value if its set to Fixed or Default (and you have an item in Subsequent Data Item ID column)

Userlevel 5
Badge +11

But as you also describe it sounds to be some kind of new client bug if you say that the value you entered for Purchase Order will be moved into Part No for some strange reason. I have never heard about that issue before. So there is probably no setting you can do in the configuration that would fix that.

Userlevel 5
Badge +11

@AnneCath Cantau which OS/platform was this Scanit app? was it Windows or Android or iOS

We might have some similar one reported in some rare cases for the windows app.

Badge +3

Hi @Dario Zani , thanks for your answer.

my tests are done on Windows 10 Professionnel version 21H1

and the IFS scan it version is : 22.8.613.0


I’ve modified the configuration according to your advices.

I’ve turned Use Automatic Value to off and still have the issue.

thanks again!


Userlevel 5
Badge +11

Hi @AnneCath Cantau 

I’m sorry I first thought you wanted to know how to configure to get automatic/prefilled values into the items.

But later on when I read your description again I realized what you described was client issue when the input field is not refreshed or cleared properly so it regained the old value from previous manually entered item.

This is clearly a client bug since that should not happened. The only similar thing we have seen was for the windows app (android/iOS app and regular Aurena client seems to work) and for the receive case item in Register Arrival, but it is still not solved since I guess it was down prioritized, but as you describe this it happens for all items that you enter manually in Register Arrival then it is much worse then what was previously seen, so I would recommend to report this as new bug.

I’m curious if you have only encounter this for Register Arrival and not for any other process, since it would be strange if it only happens for Register Arrival since it seems to be client issue.