Solved

Wadaco - Report Picking of Part Shop Order Pick List

  • 22 November 2021
  • 4 replies
  • 47 views

Why does not “Qty to pick” work with automatic default value? Does not matter if I use “default” or “Fixed”, input result is always blank when performing picking.

 

icon

Best answer by JBerg 3 December 2021, 13:23

View original

4 replies

Userlevel 4
Badge +9

Have you tried to move Qty to Pick down a bit further to the end? I noticed you have it higher than the template configuration. There is some code to handle some automatic handling for that item, but it depends on what have been scanned and identified before. If its a serial part you will 1 as value, if input uom and input qty is known it will use those to calculate the quantity and other ways it can fetch the quantity assigned from the Shop Order but it then requires all SO/stock/picklist items to come before the quantity for it to be able to fetch it.

I did some quick testing just now, sometimes it works and sometimes it don’t, it depends on what type of part it is or what location you have chosen. Not sure if there is any bug here or if that is how it is suppose to work, I’m not a Shop Order expert. The shop material pick line needs to have a quantity assigned and all items identifying that line needs to come before Qty to Pick

 

Yes, i have tried to match the default template but i cannot get it to fetch the information.

Another thing i have noticed is that in App9 configuration the command was “qty to issue” but in App10 it’s “qty to pick”. Maybe I need to change configuration to better match the commands between App9 and App10.

Userlevel 4
Badge +9

You need to move the qty_to_pick to below the location_no item for it to work (location is part of the stock items that I mentioned earlier), so the default template will not work either.

The same thing and configuration order issue existed also in Apps9 even thou the ‘data item’ was named differently then.

When the default template was designed for Apps9 they probably never noticed that there was a built in functionality to fetch the quantity automatically since the template has it Off as default so that is probably why the quantity happened to come before location instead of after it.

I finally got it to qty_to_pick to work with both fixed and default value! :yum:

Problem was the new feature in App10, that you can pick handling units on shop order pick list.

Solution to get it working was to set a fixed value “0” in handling unit id since we do not use handling units in shop order.

Reply