Solved

Cloud - ScanIt - an Error when trying to log in as end user


Badge +1

Hi,

We come across the below error when we try login to Cloud Version of IFS Scan It app as an end user (works fine for IFSAPP). The IFS Scan It app version is 22.2.470.0 on android.

It looks some thing to do with permissions, so checked for WADACO related projections and they all granted via “WADACO_MOBILE_USER” and “WADACO_PROJECTIONS” permission sets.

I’m not sure what the “SiteVirtual” means could be some technical word.

Appreciate a hand to find out the missing steps.

 

 

 

 

icon

Best answer by Mohamed Infaz 11 March 2022, 13:01

View original

12 replies

Userlevel 5
Badge +10

Hi,

Can you please grant the following security group to WADACO_MOBILE_USER permission set?

 

Badge +1

Hi Infaz,

Thank you very much for the quick response and it worked!

Best regards

Chitrangana

 

Userlevel 5
Badge +10

Happy to help you Chitrangana :relaxed:

Badge +1

Hi!
We get the same error message even though we granted the security group. 

Our installation is Cloud 22R1. Any tips?

Userlevel 5
Badge +10

@addjonasa , Did you refresh the security cache? also can you login to the WADACO client by a super user like IFSAPP?

Badge +1

Yes, I refreshed security cache and IFSAPP is able to log into Scan It.

Userlevel 5
Badge +11

Hi Jonas,

 

You might have to re-run the script security_wadaco_mobile_user.ins again. There have been issues during installation that this script fails due to AURENA_NATIVE_RUNTIME not been installed when this script is run. It was recently changed to be a POST-script instead so its run after most installations to overcome this issue. 

Badge

Hi Guys,

I have the same problem “SiteVirtual has not been granted...”

I have enabled the ifs_aurena_nativ IAM client.

I have granted the scanlt security group to the WADACO_MOBILE_USER permission set.

It doesn’t work for me on an IFSAPP user and another regular user.

I can log in to the app, but after a few seconds I’m getting this error “SiteVirtual has not been granted” 

Badge +1

Hi Artur,


Please make sure you have the following in the WADACO_MOBILE_USER permission set.
 

  1. Go to Permission Set page and search for WADACO_MOBILE_USER permission set and select the Projections item from the record selector.
  2. Grant “ScanIt” projection if it is not already there, using the “Add/Revoke” button.
  3. If the ScanIt projection is already there, then make sure the Access Level is full, if not grant full access by “Change Access” button.

As Dario has mentioned about, re-running the security_wadaco_mobile_user.ins would help.


Best Regards,

Badge

Thanks, dinuka9 for your fast reply. 
Unfortunately, it still doesn't work for me.
I had this setting correctly:

Could you tell me something more about security_wadaco_mobile_user.ins script, where can I find it?

Badge

We found this script and after rerunning it, the problem still occurs. Any idea?

Badge

One more update. We make a test and we granted all available permissions to our test user

 

 

After that user can log in to scanlt and he doesn't receive an error, but I'm still not sure that the application is working correctly...

Reply