Solved

Error :Row(Person(xxx), was changed after it was selected. reselect and try again.

  • 18 November 2020
  • 9 replies
  • 42 views

Userlevel 2
Badge +5

Getting the error when updating the change password field for the person record.

Error :Row(Person, was changed after it was selected. reselect and try again.

Am able to update rest of the fields in the person record. So am not able to change the password for any person.

 

icon

Best answer by Lee Pinchbeck 18 November 2020, 15:36

Hi @TatKhandM,

In the Custom Metadata screen you need to search for PERSON. If it already exists then great, if not you will need to create a new record for the PERSON table.

Once in PERSON you need a column entry for NACL. Again, if it selects thats great but if not just click new and enter NACL for the column. There is a tick box field for ‘force select’, make sure this is ticked and then save.

Then refresh cache, log out and log back in.

If you need further help with custom metadata then click the question mark in the top left of the screen when you are in custom metadata. This will take you to the user guide for the area.

Kind regards,

Lee Pinchbeck

View original

9 replies

Userlevel 6
Badge +13

Hi @TatKhandM,

Can you please try adding metadata to the NACL field on PERSON to set force select to Y. You may then need to refresh cache, log out and then back in to reattempt.

Hope this helps,

Lee Pinchbeck

Userlevel 2
Badge +5

Hi Lee,

        Am not able to find the NACL field on PERSON. can you please provide more info to find the filed.

 

Userlevel 6
Badge +13

Hi @TatKhandM,

It is a hidden field so cannot be viewed on the screen but it will still allow you to add it on the metadata screen when you make an entry for the PERSON table.

Kind regards,

Lee Pinchbeck 

Userlevel 2
Badge +5

Hi Lee,

 Appreciate your support.

Can you explain the what is the use of NACL field?

 

Badge

 I am having a similar kind of issue, I have searched all over the internet and even have posted on number of threads on different forum, no solution seems to work. I am really frustrated, can anyone of you here help me resolve this issue, I am very much tired now.
 

Userlevel 2
Badge +5

Hi Lee,

      I found the NACL column in the metadata person but the ForceSelect field is disable . So how to enable it.

 

Userlevel 6
Badge +13

Hi @TatKhandM,

In the Custom Metadata screen you need to search for PERSON. If it already exists then great, if not you will need to create a new record for the PERSON table.

Once in PERSON you need a column entry for NACL. Again, if it selects thats great but if not just click new and enter NACL for the column. There is a tick box field for ‘force select’, make sure this is ticked and then save.

Then refresh cache, log out and log back in.

If you need further help with custom metadata then click the question mark in the top left of the screen when you are in custom metadata. This will take you to the user guide for the area.

Kind regards,

Lee Pinchbeck

Userlevel 2
Badge +5

Hi @TatKhandM,

In the Custom Metadata screen you need to search for PERSON. If it already exists then great, if not you will need to create a new record for the PERSON table.

Once in PERSON you need a column entry for NACL. Again, if it selects thats great but if not just click new and enter NACL for the column. There is a tick box field for ‘force select’, make sure this is ticked and then save.

Then refresh cache, log out and log back in.

If you need further help with custom metadata then click the question mark in the top left of the screen when you are in custom metadata. This will take you to the user guide for the area.

Kind regards,

Lee Pinchbeck

The issue is solved . Appreciate your support

Userlevel 2
Badge +5

Hi Lee,

Can you explain how adding metadata to the NACL field on PERSON to set force select to Y solving the issue. what is the use of NACL column ?

Reply