User Cannot Run Quick Report - Granted Access | IFS Community
Question

User Cannot Run Quick Report - Granted Access

  • 31 January 2020
  • 9 replies
  • 530 views

Userlevel 4
Badge +8

I have one specific user that cannot run a quick report. She has a permission set that was granted access. I confirmed under the Manage Grants that her permission set is there and she is listed under the Users. Other people in her group that have the exact same permission sets she has can run this report. 

Has anyone else ever ran into this?


9 replies

Userlevel 7
Badge +16

Hi @SaraCrank,

 

Could you please check if the user has access to the presentation object which corresponds to the report? In order to grant the privilege to execute this report you have to grant the Presentation Object.

Userlevel 4
Badge +8

@Himasha Kapugeekiyanage - Yes, she has access to the presentation object. That is the grants that I referenced above. I RMB on the quick report and go to Manage Grants and on the Presentation Object Grants screen, she has the permission set that was granted access as well as being on the Users tab. We’ve tried Revoking and Regranting and neither one solved the issue. I also deleted the quick report from her personal profile and that “Features” section of her personal profile has been deleted since this issue popped up. 

Userlevel 4
Badge +7

@Himasha Kapugeekiyanage - Yes, she has access to the presentation object. That is the grants that I referenced above. I RMB on the quick report and go to Manage Grants and on the Presentation Object Grants screen, she has the permission set that was granted access as well as being on the Users tab. We’ve tried Revoking and Regranting and neither one solved the issue. I also deleted the quick report from her personal profile and that “Features” section of her personal profile has been deleted since this issue popped up. 

 

Is the issue with the user not being able to see the QR listed, or they can see it but get thrown an error when they attempt to run it? If there are users who have exact permission sets granted but are able to run the report, a good place to check is if there are any business rules preventing seeing the information (ex. user not added in a specific site). Generally, if you run the QR statement in some developer tool like SQL Developer under the specific user, it will likely throw an error that can help to pinpoint the source where permission is not granted.

Userlevel 6
Badge +13

Hi @SaraCrank ,

Did she get any specific warning message when running the quick report? 

Userlevel 4
Badge +6

@Himasha Kapugeekiyanage - Yes, she has access to the presentation object. That is the grants that I referenced above. I RMB on the quick report and go to Manage Grants and on the Presentation Object Grants screen, she has the permission set that was granted access as well as being on the Users tab. We’ve tried Revoking and Regranting and neither one solved the issue. I also deleted the quick report from her personal profile and that “Features” section of her personal profile has been deleted since this issue popped up. 

Have you tried to “Refresh Security Cache”?

After performing this action, she would have to restart her IFS Enterprise Explorer client.

Userlevel 3
Badge +8

Security Refresh and then ask user to come out of client.

Log back in to IFS again. That should solve the problem.

Userlevel 2
Badge +6

Hi,

 

In IFS some view has

--

FROM   customer_order_tab 
WHERE  EXISTS (SELECT 1 FROM user_allowed_site_pub WHERE customer_order_tab.contract = site)
AND    order_no IN (SELECT * FROM customer_order_usg)) t0

----

this kind of site filters.

 

Have you checked your views in the quick report.

 

 

Userlevel 7
Badge +11

Hi,

The Presentation Object grant will let you see the Quick Report in the navigator, but having that is not enough. Check if the user has grants to the objects used in the SQL query, for example the views, APIs etc. One way to check this is to run the exact SQL query from PLSQL while logging in as the end user.

If you have site filters or row based security on views etc., then you  will get an error or a blank report.

Also, make sure to refresh the security cache and exit and login-in again after any configuration change.

 

 

Userlevel 5
Badge +10

Is it just this one report or any?  Does user have the Crystal Runtime add-on?

 

Reply