Question

Right CIFX format

  • 1 November 2019
  • 4 replies
  • 161 views

Badge +2

I have some problems with cifx, and as only partner I lost possibility to generate new cifx via LCS, so I don’t know right format of cifx :

1) When I start SolutionDeveloper 2.5.1.0 it gives me following warning:

One or more issues have been found in the .cifx file.
-No languages specified in some installatinos (English will be set as the default ...)

I tried some formats, but nothing works.

<LANGUAGES>
     <LANGUAGE>cs</LANGUAGE>
     <LANGUAGE>en</LANGUAGE>
</LANGUAGES>

 

<LANGUAGES>
     <LANGUAGE>cs-CZ</LANGUAGE>
     <LANGUAGE>en-US</LANGUAGE>
</LANGUAGES>

 

2) Also I don’t know what are rights values for this parameters when GET used:

<FOUNDATION1>
   <VERSION xsi:nil="1"/> <!-- 700 ? -->
   <PATH xsi:nil="1"/>
</FOUNDATION1>
<TRACK>IFSAPP10</TRACK>
<MARKET>GET</MARKET> <!-- Core ? -->
<VERTICAL>None</VERTICAL>

 

3) When promoting “Cust” plsql file, SolutionDeveloper does not checkout “Ext” files from “GET”, so generation failed. Could be some problem in previous point? Or in module definition? Maybe it’s some network problem.

      <MODULE>
       <NAME>ENTERP</NAME>
       <VERSION>3.0.0</VERSION>
       <MARKET>Core</MARKET>
       <VERTICAL>None</VERTICAL>
       <CPS>5</CPS>
      </MODULE>
      <MODULE>
       <NAME>ENTERP</NAME>
       <VERSION>3.0.0</VERSION>
       <MARKET>GET</MARKET>
       <VERTICAL>None</VERTICAL>
       <CPS>5</CPS>
      </MODULE>

 

or may be problem in rrc file?

enterp;enterp 3.0.0-GET;BASE;GET;0;\\wwavmfs01\pf\Archive\ExtArchives\Archive10_GET\enterp\GET\enterp 3.0.0-GET\;DISK
enterp;enterp 3.0.0;BASE;CORE;0;\\wwavmfs01\pf\archive\archive10\ENTERP\CORE\ENTERP 3.0.0\;DISK


4 replies

Userlevel 4
Badge +9

Hi @InfFilipV welcome to IFS Community.

For your problem no 1 you can use below format in CIFX file. Remember to define this in each and every installation in the CIFX. The problem 3 looks like a bug to me. Have you tries reaching IFS support?

    <LANGUAGES>
<LANGUAGE>
<LANGUAGE_CODE>cs</LANGUAGE_CODE>
</LANGUAGE>
<LANGUAGE>
<LANGUAGE_CODE>en</LANGUAGE_CODE>
</LANGUAGE>
<LANGUAGE>
<LANGUAGE_CODE>es</LANGUAGE_CODE>
</LANGUAGE>
<LANGUAGE>
<LANGUAGE_CODE>nl</LANGUAGE_CODE>
</LANGUAGE>
<LANGUAGE>
<LANGUAGE_CODE>pl</LANGUAGE_CODE>
</LANGUAGE>
</LANGUAGES>

Thanks.

Badge +2

I have some problems with cifx, and as only partner I lost possibility to generate new cifx via LCS, so I don’t know right format of cifx :

1) When I start SolutionDeveloper 2.5.1.0 it gives me following warning:

One or more issues have been found in the .cifx file.
-No languages specified in some installatinos (English will be set as the default ...)

I tried some formats, but nothing works.

<LANGUAGES>
     <LANGUAGE>cs</LANGUAGE>
     <LANGUAGE>en</LANGUAGE>
</LANGUAGES>

 

<LANGUAGES>
     <LANGUAGE>cs-CZ</LANGUAGE>
     <LANGUAGE>en-US</LANGUAGE>
</LANGUAGES>

 

2) Also I don’t know what are rights values for this parameters when GET used:

<FOUNDATION1>
   <VERSION xsi:nil="1"/> <!-- 700 ? -->
   <PATH xsi:nil="1"/>
</FOUNDATION1>
<TRACK>IFSAPP10</TRACK>
<MARKET>GET</MARKET> <!-- Core ? -->
<VERTICAL>None</VERTICAL>

 

3) When promoting “Cust” plsql file, SolutionDeveloper does not checkout “Ext” files from “GET”, so generation failed. Could be some problem in previous point? Or in module definition? Maybe it’s some network problem.

      <MODULE>
       <NAME>ENTERP</NAME>
       <VERSION>3.0.0</VERSION>
       <MARKET>Core</MARKET>
       <VERTICAL>None</VERTICAL>
       <CPS>5</CPS>
      </MODULE>
      <MODULE>
       <NAME>ENTERP</NAME>
       <VERSION>3.0.0</VERSION>
       <MARKET>GET</MARKET>
       <VERTICAL>None</VERTICAL>
       <CPS>5</CPS>
      </MODULE>

 

or may be problem in rrc file?

enterp;enterp 3.0.0-GET;BASE;GET;0;\\wwavmfs01\pf\Archive\ExtArchives\Archive10_GET\enterp\GET\enterp 3.0.0-GET\;DISK
enterp;enterp 3.0.0;BASE;CORE;0;\\wwavmfs01\pf\archive\archive10\ENTERP\CORE\ENTERP 3.0.0\;DISK

Hi @InfFilipV

Regarding point #3:
We have the same problem and it is quite annoying.
Have you managed to find a solution?

regards

Janos

Badge +2

Hi @InfFilipV

Regarding point #3:
We have the same problem and it is quite annoying.
Have you managed to find a solution?

regards

Janos

Hi @jasahu,
unfortunately no.

But, we had this issue also in delivery process, sometimes Ext was not loaded and dynamic dependency modules was not loaded very often.

Solution Developer before delivery checkout deploy.ini from harvest, and because there is problem with not downloading GET files, it ignore them and use Core one from Archive.

So we check-in GET version of deploy.ini into _STD package and it helps (or we manually adding this deploy.ini files as ManualInsertFile to the delivery - and before build changing build from fresh to up-to-date).

 

This could help also in deploy on local machine.

I spend last year on previous versions where we does not using GET, so I did not try solve this issue.


Only my actual idea without try:

Maybe checkout of GET deploy.ini into workfolder and making file writable (to avoid rewrite by SD) will help.
 

Filip

Badge +2

I have some problems with cifx, and as only partner I lost possibility to generate new cifx via LCS, so I don’t know right format of cifx :

1) When I start SolutionDeveloper 2.5.1.0 it gives me following warning:

One or more issues have been found in the .cifx file.
-No languages specified in some installatinos (English will be set as the default ...)

I tried some formats, but nothing works.

<LANGUAGES>
     <LANGUAGE>cs</LANGUAGE>
     <LANGUAGE>en</LANGUAGE>
</LANGUAGES>

 

<LANGUAGES>
     <LANGUAGE>cs-CZ</LANGUAGE>
     <LANGUAGE>en-US</LANGUAGE>
</LANGUAGES>

 

2) Also I don’t know what are rights values for this parameters when GET used:

<FOUNDATION1>
   <VERSION xsi:nil="1"/> <!-- 700 ? -->
   <PATH xsi:nil="1"/>
</FOUNDATION1>
<TRACK>IFSAPP10</TRACK>
<MARKET>GET</MARKET> <!-- Core ? -->
<VERTICAL>None</VERTICAL>

 

3) When promoting “Cust” plsql file, SolutionDeveloper does not checkout “Ext” files from “GET”, so generation failed. Could be some problem in previous point? Or in module definition? Maybe it’s some network problem.

      <MODULE>
       <NAME>ENTERP</NAME>
       <VERSION>3.0.0</VERSION>
       <MARKET>Core</MARKET>
       <VERTICAL>None</VERTICAL>
       <CPS>5</CPS>
      </MODULE>
      <MODULE>
       <NAME>ENTERP</NAME>
       <VERSION>3.0.0</VERSION>
       <MARKET>GET</MARKET>
       <VERTICAL>None</VERTICAL>
       <CPS>5</CPS>
      </MODULE>

 

or may be problem in rrc file?

enterp;enterp 3.0.0-GET;BASE;GET;0;\\wwavmfs01\pf\Archive\ExtArchives\Archive10_GET\enterp\GET\enterp 3.0.0-GET\;DISK
enterp;enterp 3.0.0;BASE;CORE;0;\\wwavmfs01\pf\archive\archive10\ENTERP\CORE\ENTERP 3.0.0\;DISK

Hi @InfFilipV

Regarding point #3:
We have the same problem and it is quite annoying.
Have you managed to find a solution?

regards

Janos

Hi @jasahu,
unfortunately no.

But, we had this issue also in delivery process, sometimes Ext was not loaded and dynamic dependency modules was not loaded very often.

Solution Developer before delivery checkout deploy.ini from harvest, and because there is problem with not downloading GET files, it ignore them and use Core one from Archive.

So we check-in GET version of deploy.ini into _STD package and it helps (or we manually adding this deploy.ini files as ManualInsertFile to the delivery - and before build changing build from fresh to up-to-date).

 

This could help also in deploy on local machine.

I spend last year on previous versions where we does not using GET, so I did not try solve this issue.


Only my actual idea without try:

Maybe checkout of GET deploy.ini into workfolder and making file writable (to avoid rewrite by SD) will help.
 

Filip

Hi @InfFilipV ,

I understand, it does not look that good :)

Recently I created a case on LCS regarding this and in contact with them, progress is not that fast, but hopefully we can solve it:

LCS Case:
G2249983

I am not sure that you have the rights to see that, if not, I will summarize it to you if you are interested

 

 

Reply